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Sliver Version Recent Change Log

Version 1.6.5 (released February 16, 2018)

®  Adds the capability to stack multiple subplots within a single 2D scatterplot window. To add a stacked plot
simply select the Add Stacked Subplot button rather than Finish after selecting variables for a plot. For
Cartesian plots the stacked subplots are arranged vertically and share the same x-axis variable. For polar
plots the stacked subplots are arranged as concentric plots sharing the same theta-variable. Stacked subplots
can be any mix of plots with fixed-sized points or with points sized per another variable (bubble charts).
Cartesian and polar plots cannot be mixed in one plot window.

e Adds a colored outline to any scatterplot points that are larger than a pixel size defined in Options—> Plot
Settings. The default size threshold is 10 pixels since the outline tends to wash out the fill colors of smaller
points. The outline color can be defined in Options=>Color Scheme, with a default of light gray. The
outline not only makes the plots look nicer but it distinguishes points that overlap.

e  Updates the PDF export to support both fixed and variable-sized stacked scatterplots. The option to set the
fixed point width in Options>PostScript/PDF Export Settings has been removed and the point size is
now read from each plot itself. The option for hollow vs. filled points has also been removed and this
property is now derived directly from the current state of each plot.

e Updates the Grand Tour, which under certain circumstances ran at an uncontrolled speed under newer
versions of Java.

®  Minor bug fixes and various user interface improvements.
Version 1.6.1 (released December 27, 2017)

®  Minor bug fixes and improvements.
Version 1.6 (released December 2, 2017)

e  Scatterplots are now restored from a session file as well as the PC Plot, although any horizontal
compression or expansion of axes in the main PC Plot is removed. The PC Plot is restored as the bottom
window, with the scatterplots restored on top in the stacking order of their display when the session was
saved.

e Adds the capability to save dashboard templates based on the current layout of plots in the session, and then
to read new data files into a dashboard template, automatically creating all plots in the same sizes and
locations along with their brushing rules, ranges, point sizes, etc. This is very convenient for quickly
populating a dashboard view with the contents of different data files. The new menu functions
File->Create Dashboard from Session and File>Read File into Dashboard — every <n> lines provide
this feature.

e Adds command line support for launching Sliver from a command window or from a script.

o  <Sliver executable path> <data file path> to open a data file
o <Sliver executable path> <session file path> to open a previously saved session file
o Optional parameters can be added at the end of the line. All options are available when reading in
a data file, but only —deleteall can be included in a session file command line.
= -dashboard <dashboard file path> to read the data file into a previously saved
dashboard template. The input data must consist of at least as many variables as in the
saved dashboard file. Dashboard plots are plotted based on variable order rather than
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name, so the data file should retain the same variable order as when the dashboard was
created.

= -vars <variable selection file path> to only read in variables listed in a file. The format
is one variable name per line (in any order), corresponding to the format of variable files
saved within variable selection windows in Sliver.

= -every n toread every nth line of the data file

= -deleteall to delete all previous Sliver instances

e Adds an Analysis menu function to export 2D scatterplots to Matlab® in addition to 3D scatterplots. Both
now support options for plotting points, lines or both, with selectable point size, line width and line color.

e The existing option to not draw a path between points more than a selectable distance apart in Google Earth
is expanded to include the option to draw a dashed vertical arc.

e Adds a Plots>Reset PC Plot Margins menu option in case resizing and/or zooming causes misalignments
or off-screen text.

e Adds a new method of selecting an axis. Currently this is done by clicking on an axis name while pressing
ALT key. This can now also be performed by pressing a digit key 1-9 to select one of the first 9 axes,
counting from the left. Pressing » shifts the selection to the next axis to the right and pressing N shifts the
selection to the next axis to the left, with wraparound. This is particularly convenient when a large number
of axes makes it difficult to click on the desired axis name, or just to reduce mouse operations.

e Adds Boolean combination options (Replace, OR, AND and XOR) to apply with any existing selection
when using the menu function Selections—> Enter Selection Range for an Axis. These combinations now
exist for both swiping a selection and entering a selection range along an axis.

e Pressing a key when selecting variables to read from a file will jump to the next variable name starting with
that letter or number, wrapping around as needed.

e Adds a default 2D scatterplot window size to the Plot Settings.

e Adds additional range brush palettes to choose from, including a full 2-color to 16-color Univ_Tennessee
palette set and a number of 5-color and 10-color palettes identified with “-5” or “-10” at the end of the
palette name. A new Appendix G provides color swaths of built-in color palettes.

e  Various minor updates. Note that the Enter Range for Axes and Reset to Full Axes Ranges functions are
now located under the Axis menu rather than the Analysis menu.

Version 1.5.5 (released August 3, 2017)

e Adds 43 color palettes for range brushing to the existing Sliver rainbow palette, selectable in the Plot
Settings. These palettes are from the colormap package of R. See Appendix F for information on including
your own custom palettes.

e Adds an option in Plot Settings to progressively color the selection while swiping (if not utilizing a Boolean
combination).

e Sliver now does not exit after the warning message when attempting to input data that is not a number, such
as a string.

e Provides the option when saving selection or visible lines to save all the variables in the original input file
even if they were not all input when the file was read, enabling Sliver to filter a file based only on selected
input variables.

e The DataPlayer window used in count-based animation of the data now has an option for narrow vs. full
window. It also now supports mouse scrolling for incrementing and decrementing the data row as well as
f/s hotkeys for faster/slower when playing and p hotkey to play/pause and r hotkey for reverse.

e Incorporates DataTools 1.2.8, which eliminates a problem where an additional column was added when
adding a calculated column.
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e  Various minor updates

@)
@)
©)

In reading every # lines of the input file, the range of # has been increased to 0-500.
The opacity of plotted connections in Google Earth is now independent of the pillar opacity.
Dots in the path when saving Google Earth KML files are now allowed again.

Version 1.5 (released March 18, 2017)

e Adds support for 2D scatterplots with point sizes dependent on another variable (bubble charts). With the x
variable, the y variable and the color mapping, the variable point size indicates yet another dimension in a
scatterplot.

e Adds zooming capability to the PC Plot Matrix window. This may be slow for large datasets given the
number of lines involved, but the zoom level is remembered. The existing zoom method for all windows
(Ctrl plus mouse scroll), will now also work by just pressing the + and — keys. This particularly helps when
touchpads on laptops do not have the same behavior as a PC mouse when scrolling. In all cases, including

the Alt key zooms horizontally while the Shift key zooms vertically.

e Adds new features for Google Earth plots:

o

A number of options specific to a plot type have been moved from the main Google Earth settings
under the Options menu into the window that appears when the plot is selected under the Plots
menu. This is more convenient and allows individual settings for the different plot types. Overall
settings are still populated under the Options menu.

Adds an option to add timestamps to any Google Earth plot. The timestamps at the points can be
chosen to be the row number as seconds since midnight (simply to provide a timespan), or the
values of any variable at the points as seconds. If a variable time-formatted in hh:mm:ss is
selected, it is converted to seconds so the player will then show the associated time. When the
KML file is opened, Google Earth presents a small player control panel that also includes a second
cursor to set an interval of time. This can be used to animate the plot, only showing plotted
features as the slider is manually positioned or automatically played. The automatic animation
speed can be adjusted by clicking on the wrench icon in the player control panel. This feature is
useful to provide animation in Google Earth without running Sliver at all, or to reduce clutter in
complicated plots by only showing a particular range of the plot at a time.

In Pillar and Connection plots, and whenever spheres are added to a Path plot, a window provides
an option to display the corresponding row values of selected variables in a pop-up when an
element is left-clicked in Google Earth (called balloons). This is a great way to see the data at any
point in the Google Earth displays.

Whenever spheres are added to a Pillar or Path plot, the window above will also provide an option
to display the corresponding row values of any selected variables in a label when a mouse-over of
a sphere is performed. This is very useful for fast analysis or in finding the location of a particular
value in a plot.

It is possible to display a mapped string rather than a number in pop-ups. This uses a string
mapping file whose path is entered in the Plot Settings. If enabled, values for each variable are
compared to a list of matching numbers and strings for that variable in the file, and if a match
occurs the string is displayed instead of the number. This file has the format of the output string
mapping file of the Replace Strings with Numbers function of the DataTools menu, although the
string mapping file can also be created by hand (see Appendix E for the format).

Count-Based Animation that includes Google Earth animation now provides an option to move the
Google Earth camera view to follow the icon. The range, tilt angle and relative heading of the
camera from the icon as it moves can be specified. If the option to draw a line from the icon to a
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secondary set of coordinates is enabled, the relative heading can also be switched in sign to always
be opposite that line for better viewing of it, or the heading can always be along that line.

Google Earth animation sometimes loses sync due to collisions between reading the position data
and writing the data, which then requires right-clicking on the Position label in the left panel and
choosing Refresh. These occurrences are greatly reduced now by implementing doubly-nested
network link files.

e  Adds the choice in the Plots>Display Values on Mouse-Over menu function to either display the
numerical values or use string mapping as described above to check values against a string mapping file
populated in the Plot Settings and, if found for a variable, display the string. This only applies to the main

PC Plot.

e Any variable with the string (sec-time) anywhere in its name is automatically interpreted as having units of
seconds and will be transformed into the hh:mm:ss time format in the Sliver displays.

e  Updates DataTools menu functions:

o

Sliver associates commas in double quotes in CSV files as delimiters, and fails to load such files
since the column count is deemed inconsistent. Implementing a real-time check on commas when
a file is loaded, though, significantly slows down the input of data. A new DataTools function
Remove Commas from Strings is added to remove these commas and the surrounding double
quotes from a CSV file prior to reading it into Sliver.

Added a function Extract Rows with Multi-Column Values to extract rows based on Boolean
combinations of values across multiple variables.

The Replace Strings with Numbers function, which is more significant now that mapping to the
original string values is implemented, now operates only on user-selected columns. This is also
useful to avoid replacing time-formatted values that Sliver can natively input.

e Adds minor improvements:

o

O O O O O

Restores the functionality of the line to secondary Google Earth coordinates

Ignores leading zeros in data

Accepts non-integer seconds for time-formatted (hh:mm:ss) data

Skips writes to the settings file when locked due to Dropbox syncs, etc.

Correctly propagates time format and name staggering when axes are moved or deleted
Implements some performance improvements
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1. Introduction

Sliver is a software application for data visualization and analysis using methods of modern exploratory data
analysis and data mining (siffware). It incorporates parallel coordinate plots, 2D and 3D scatterplots, and Google
Earth path plots, all fully linked through user-defined color brushing and data animation. These highly visual
displays reveal correlations, patterns, trends and anomalies in multi-dimensional (multivariate) systems, and these in
turn can significantly aid in the diagnostic analysis of sensitivities and error sources in a system.

Data can be input from a comma-separated value (CSV) file or a tab-delimited text (TXT) file in either decimal/time
or hexadecimal format with a header row for variable (column) names. The decimal/time format includes data in
hh:mm:ss and mm:ss format as well as decimal values. Decimation (reading every nth row) is supported, and a set of
data tools is provided to manipulate the data before being input.

Sliver is packaged as a set of files contained in a single zipped file. There is no installation required—simply extract
the files into a local folder on a Windows PC and double-click to launch the Sliver vi.5.exe file.

A Companion Tool to Traditional Plotting Programs

) Figure 1
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1. Correlate several variables against time across wide time spans with many plotted values and transitions.
This is important, for example, in verifying that the conditions that cause the event only occur at the times
of the problems.

2. Correlate variables against other variables independent of time. At best, two or three variables can be
plotted against each other in a scatterplot.

3. Visually identify anomalous system behavior. This capability would be useful in identifying undiagnosed
software bugs that have not yet been observed in the system.

4. Study occurrences not tied to time tags (such as times in video) that require searching for multivariate
conditions.

The suite of tools provided by Sliver assists in these types of analyses.
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2 . Data Visualizations in Sliver (a very brief tutorial)

Sliver offers several forms of data presentation, all connected statically by color brushing of data ranges of interest
and dynamically by animation of the data set. Select the File->Read File->All Variables menu option and open
the cars.csv dataset included in the Sample Data folder to follow along with this brief tutorial.

We will first describe the types of displays available, with minimal attention to how they are launched and
configured. Later we will cover the settings, menu options and hotkey assignments available for exercising the plots.
NOTE: Some of the screen captures show an older menu layout without the new Selections and Analysis menus, but
the text is correct on their use.

Parallel Coordinate Plot (PC Plot)

In Sliver all input data is first plotted as a parallel coordinate plot, or PC Plot, with all other displays created as
offshoots of this main data display. The parallel coordinate plot window can be resized, zoomed and panned.

In a parallel coordinate plot, the axes of values for the variables lie parallel to each other, typically running vertically
and with a linear mapping from the minimum to maximum value of each variable. Each instance of measurement of
the variables (i.e., each row of the input data file) is represented by a segmented line, or polyline, that passes through
the corresponding value on each variable axis. Below is a standard example shown in Sliver of data for 392 car
models introduced between 1970 and 1982 (the cars.csv dataset). Each of the variables (MPG, Cylinders,
Horsepower, Weight, Acceleration (really seconds to 60 mph), Year, and Origin (US/Japan/Europe) is assigned to
an axis with values running linearly from its minimum to maximum values.

@ Slivervl6 D:/Users/Ron/Documents/Parallel Coordinates/MyParallelCoordinateSW/Sliver v14 to 1.6 Dev/SampleData/cars.csv | [ e

File Options Axis Selections Brushes Plots Analysis Animate DataTools Help

10

/Japan/Europe)

What can we tell right away? We can see that there were 3, 4, 5, 6 and 8 cylinder models introduced that generally
had an inverse (criss-cross) relationship with MPG values ranging from 9.0 to 46.6 mpg, a correlation between
number of cylinders and horsepower (although the 3-cylinder models did surprisingly well) and between horsepower
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and weight (with that one anomalous line angling downward), and a strongly inverse relationship between weight
and time to 60 mph (the variable Acceleration).

D L ———E
%Elivervl.ﬁ D:/Users/Ron/Documents/Parallel Coordinates/MyParallelCoordinat
File

To deduce more we need to isolate data. For example, we can

Options  Axis  Selections Brushes Plots  Analysis Animate DataTor

color all the data related to 8-cylinder models by swiping the
mouse to create a rectangle surrounding those lines, as shown
on the right. Sliver then selects and colors those lines with the
selection color (light purple by default) as shown below. Note
that after the first swipe the lines change from white to a light
gray color. We can also modify the selection by swiping other
lines and combining them with AND (with the shift key
pressed), OR (with the ctrl key pressed) or XOR (with both
keys pressed) operations. (NOTE: if swiping is slow to react, try toggling the ALT key). Progressive colormg of the
selection while swiping rather than coloring it only after the swipe is completed is available in the Options=>Plot
Settings menu option. This operation reveals correlations while a selection is being swiped, but it is too slow to act
for very large data files.

The small range values at the upper and lower ends of the selection box in the small display in the upper right are
shown by default, but can be turned off using the Options—>Plot Settings menu option. They can be very useful for
showing ranges while swiping.

@ Slivervl.6 D:/Users/Ron/Documents/Parallel Coordinates/MyParallelCoordinateSW/Sliver vi4 to 1.6 Dev/SampleData/cars.csv ‘ =|slEl iE-J

File Options Axis Selections Brushes Plots Analysis Animate DataTools Help

5140.0

10

Acceleration E Origin{US/Japan/Europe)

We now can see that all the 8-cylinder models were made in the US, with none made in 1980 and 1982 and only one
made in 1981. The ranges of the variables in the selection can also be seen.
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For more detail we can turn on a menu option to highlight the variable row values when the mouse hovers over a
line (Plots>Display Values on Mouse-Over-> Without String Mapping). An example is shown below, where the
values for the 8-cylinder car with the best MPG are displayed. We can see that this 1981 model had the second-
lowest horsepower (105 HP) and second-worst acceleration (19 seconds to 60 mph). Repeat the menu selection or
press ESC once or twice to no longer show axis values when the mouse hovers over a line.

Sliver does not support strings, only numbers. However, the DataTools menu provides a function to replace strings
in variables with unique numbers in a file to allow it to be read into Sliver (DataTools>Replace Strings with
Numbers). This function also creates a text file listing the mapping between strings and assigned numbers. If the
path to this string mapping file is entered in the Options—=>Plot Settings window, or the path to any file created in
this format (see Appendix E), the menu option Plots->Display Values on Mouse-Over->With String Mapping
can be selected. Any row numbers matched to a variable string will then display that string rather than the numerical
value for that variable in the main PC Plot window.

@ Slivervié D:/Users/Ron/Documents/Parallel Coordinates/MyParallelCoordinateSW/Sliver_v1.4 to_1.6_Dev/SampleData/cars.csv | = E &J

File Options Axis Selections Brushes Plots Analysis Animate DataTools Help

5140.0

|
|
|

9.0

MPG y s e - o Oric Japan/Europe)

This demonstrates a fundamental philosophy of Sliver: The visualizations provide a qualitative view of the data, but
the actual data is immediately accessible as well. We have seen that axis values appear by default while swiping and
remain visible afterward to show the swipe range. Here the variable values for any line are easily displayed on
mouse-over. The same is true in other plots such as scatterplots and Google Earth plots, as well as in the data
animation modes. We will soon see that histograms and means can also be displayed for any axis, and statistics for
the lines of each color brush is available. This close pairing of the data underlying the visualizations is a powerful
feature of Sliver.

We can assign the selection to a more permanent color “brush” with the Brushes—> Assign Selection to New Brush
menu option—here we choose a particular shade of green. And we can color other selections, here selecting each
cylinder number and color brushing them independently by calling the same menu option after each selection as
seen below.
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@ Sliver v1.6 D:/Users/Ron/Documents/Parallel Coordinates/MyParallelCoardinateSW/Sliver v1.4_to_1.6_Dev/SampleData/cars.csv | O | B )
I,

File Options Axis Selections Brushes Plots  Analysis Animate DataTools Hé‘hs

51400

MPG ) s e celeration ‘ Origin(US/Japan/Europe)
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We can study other aspects of the data by selecting and coloring different sets of lines. In fact, let’s look at the
anomalous line we saw in the overall plot before, the diagonal line running from near the top of the Horsepower axis
to the middle of the Weight axis.

We swipe that line to highlight it as a selection (we can swipe a line between axes) and we again turn on the
Plots>Display Values on Mouse-Over->Without String Mapping menu option to show the values at each axis.
We have the display below, where we see a 225 HP car from 1970 with a radically low weight of 3086 Ibs. and
consequently a 10 second to 60 mph rating, but it comes in at a disappointing 14 MPG. This type of anomaly, often
noticed on the fly, can identify unsuspected software errors or other anomalous behavior in a system.

D Sliver v1.6  D:/Users/Ron/Documents/Parallel Coordinates/MyParallelCoardinateSWSliver_v1.4_to_1.6_Dev/SampleData/cars.csv [E=E—

File Options Axis Selections Brushes Plots Analysis Animate DataTools Help

5140.0

Acceleration Origi apan/Europe)

We can also easily choose our own ranges along an axis in which to apply colors. After selecting an axis, choosing
the Selections>Enter Selection Range for an Axis menu option will pop up a window to enter minimum and
maximum values. Lines that pass through this range on the axis are then automatically selected in a chosen
combination with any existing selection (Replace, OR, AND, or XOR). The selected lines can be color brushed with
the Brushes—>Assign Selection to New Brush or the Brushes>Add Selection to Existing Brush menu option,
and more sets of lines can be colored by selecting different ranges and color brushing them as desired.

Other menu options for selecting lines are Selections—>Select All Visible Lines (also invoked with Ctrl-A),
Selections>Select All Unbrushed Lines, and Selections=> Toggle Selection for Visible Lines.
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We can deduce more of the relationships, but the overlapping lines are a problem. This is called overplotting, and
there are ways to reduce this effect. For example, we can choose to hide any color with the Brushes—>
Show/Hide/Recolor Brushes menu option, and here we hide all color brushes except the green one, as shown on
the right. We can then select and color subsets of these lines. This selection and trimming of data is very important
in isolating data of interest for study.

@ Slivervl.6 D:/Users/Ron/Documents/Parallel Coordinates/MyParallelCoordinateSW/Sliver_v1.4_to_1.6_Dev/SampleData/cars.csv ‘ = B |

File Options Axis Selections Brushes Plots Analysis Animate DataTools Help

1613 10

Weight Acceleration Origin(US/Japan/Europe)

Often one variable or a combination of variables represents a measurement of error, so we might select and color-
code the ranges of error. There is a menu option to range brush an entire axis or just a selected set of lines along an
axis through a set number of up to 16 spectral colors. The default is 16 colors, but this can be changed with the
Options—>Plot Settings menu option. The color palette can also be selected with this menu option, with the built-in
Sliver rainbow palette seen here as the default.

Let’s say we want to range-brush the entire MPG axis. First we make sure we have not selected any lines, or the
range brush will span only those lines—we can do that by swiping anywhere in the display where there is no line.
Then we can select the MPG axis by pressing the Alt key and clicking on the axis name, which colors the selected
name. An alternative is to press the digit 1 to select the first axis. Pressing n shifts the selection one axis to the right,
and pressing N shifts one axis to the left. Once the axis is selected, we can press the r key or select the Axis>Range
Brush menu option to automatically range brush the entire axis, again by default in a spectrum color from dark
purple to red upward in 16 colors using the Sliver rainbow palette, as shown below.
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€ Sliverv1.6  Dy/Users/Ron/Documents/Parallel Coordinates/MyParallelCoordinateSWSliver_v1.4_to_1.6_Dev/SampleData/cars.csv [

File Options Axis Selections Brushes Plots Analysis Animate DataTools Help

51400

/lapan/Europe]

However, say we want the worst MPG to be the red end, and that’s at the bottom of the axis right now, so we first
invert the axis by pressing the i key (or using the Axis=>Invert menu option) after the axis is selected. The axis is
inverted and parentheses are added around the axis name to denote that it has a high-to-low orientation. We then
perform the range brush operation and we end up with the display below. The dark purple lines are drawn first so
they lie underneath the more red colors, but we can see correlations here. We can invert the axis again if we wish
and the red end will lie at the bottom of the axis.
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= E)

@ Sliver vl.6 DyUsers/Ron/Documents/Parallel Coordinates/MyParallelCoordinateSW/Sliver_v1.4_to_1.6_Dev/SampleData/cars.csv

File Options Axs Selections Brushes Plots Analysis Animate DataTools Help

5140.0

Selecting an axis and range brushing it removes all other brushes and makes all lines visible, applying the range
colors to all lines that have not been shifted off the ends of the axis (see page 18 on shifting lines up and down).
However, if any lines are selected, then only the selected, visible lines are range brushed, and the colors span the
selection rather than the entire axis. Unselected lines retain their visibility and their color brushes, so to range brush
lines along an axis while leaving hidden lines invisible, simply select all the visible lines and then range brush the
axis. If any range brush color matches a color of an unselected line the brushes are simply merged.

Another convenient use of range brushing selections rather than an entire axis is when, say, we want the value of
zero on an axis to be blue but positive and negative extremes to be red. To do this, we can select the range from zero
to the positive extreme (either by swiping or, to get exactly zero at the low end, by using the Selections->Enter
Selection Range for an Axis menu option). We range brush this selection. Then we invert the axis with the
Axis->Invert menu option, select the range from zero to the negative extreme (now at the top) by swiping or using
the menu option above, and range brush this selection. Then we can invert the axis again and we end up with a color
of blue at the value of zero stretching to red at both extremes.
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Perhaps we want to
color the data according
the major groupings of
values of a variable.
One situation that could
benefit from this is a
categorical variable, or
in other words, a
variable that has
discrete values. Range
brushing may not
uniquely color the
different values with
different colors, so there
is a gap brush option
that will color lines on
an axis based on the
largest separations
between them. Here we
choose the Origin axis
by clicking on the axis
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name while pressing the Alt key (or by pressing the 7 key to select the seventh axis from the left), and then we select
the Axis=>Gap Brush option, ending up with the display here. Up to 20 colors, based on gap sizes, can be applied
using the up/down arrow keys to increase/decrease the colors (try it on a different axis). Here we could have
individually selected and colored the lines for the three values, but the automatic option is much faster, and there are
times when an axes has gaps that are not discrete but are significant. (We could have gap-brushed another
categorical axis, the Year axis, but the data is not well-correlated to the year, and a cluttered display results.)

We can also re-order the axes to show more relationships between the variables. In this case, the relationship
between the horsepower and weight, other than the anomalous case we observed, does not tell us much, and the
relationship between horsepower and acceleration would be clearer if they were next to one another. Also,
categorical variables squeeze polylines through just a few points, so it can mask relationships among other axes. For
this reason, it’s usually best to move categorical axes to the ends.

We can move an axis by
selecting it (pressing Alt
and clicking the name)
and either pressing the m
key or selecting the
Axis>Move menu
option. Drag the arrow to
the space between other
axes or at the end where
you want the axis to
move. Moving the
Acceleration axis next to
the Horsepower axis
reveals a strong inverse
correlation between the
two variables. Moving
the Cylinders axis to the
left end of the display
reveals a strong
correlation between
mileage and horsepower
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independent of the number of cylinders, which was not very apparent before. The resulting display is shown on the
right. Note that the number of re-orderings to get all the variables as neighbors of the others is surprisingly small: the
integer value of (n+1)/2 for n axes.

Now say we are only
interested in studying
the cars made in Japan
and Europe, so we hide
the blue brush using the
Brushes—>
Show/Hide/Recolor
Brushes menu option,
yielding the display on
the right. It would be
easier to glean
behaviors if the visible
lines were spread across
the full spans of the
axes. There are three
ways to spread the lines
vertically, either by
saving and reloading
the visible set of data to
automatically change

Dat = [=[E -
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the ranges, or by shifting the lines in the display along the axes, or by selecting the Axis->Enter Range for Axes
menu option (not shown in these screenshots).
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The first method can be done by selecting the File->Save Visible menu option to save the visible subset of the data.
Opening that file will automatically re-scale the axes to the ranges of the saved data. However, this is not a very
interactive way to visualize subsets of the data.

The second method is
to retain all the data
but shift the ranges of
the axes to spread the
visible lines along the
axes of interest. We
can select any axis and
use the Axis menu
options or arrow keys
to shift the lines at this
axis up and down from
either the top or the
bottom of the axis
(Up/Down arrow for
shifting up/down at the
top, Left/Right for
shifting up/down at the
bottom). The ranges
shown at the ends of
the axes are
automatically updated.
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The steps are discrete, so it’s likely we can’t get the lines to extend exactly to the end of the axes, but if we do this
for all the axes we can end up with the display on the right.

The hidden lines are still there, but shifted, as seen in the display on the right where the blue brush is again made

visible through the
Brushes—>
Show/Hide/Recolor
Brushes menu option.
The blue lines could
have been visible
while the shifting was
occurring. Shifting of
lines can also mitigate
a situation where a few
extreme data values for
a variable compresses
the remainder of the
data at the other end of
its axis. Scatterplots
also display any shifts
when they are created,
but later shifts are not
dynamically updated—
you have to create a
new scatterplot to

jiver v1.4_to_1.6 D Dat = [=[CE [t
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reflect any new shifting. In all cases, exports of the plots display any shifting that has been applied.

The third method of shifting axis ranges is to invoke the Axis=>Enter Range for Axes menu option, which pops up
a window to select the axes to shift and then a window to manually enter the range values for these axes. Other
menu functions relevant to setting axis ranges are Analysis>Center Axes on Means, Analysis—> Center Axes on a
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Selected Line (useful, for example, for comparing the performance of other runners across splits with a particular
runner like you!) and Analysis> Reset to Full Axes Ranges.

The Analysis menu provides other functions related to selections and display. The Analysis=>Show/Hide
Histograms and Means draws a user-selectable number of histogram bins along the left side of each selected axis,
where the height of each bin is proportional to the number of lines intersecting the axis within the span of that bin.
The mean of each axis is marked by a horizontal line on the right side of the axis. This is demonstrated in the figure
below, where some lines have been swiped to better show the yellow markings. This is very useful for interpreting
the clusters of data in the PC Plot. Only visible lines that intersect an axis are considered, so shifting lines off an axis
removes them from calculations of the histograms and means. However, Analysis—>Center Axes on Means resets
the axes ranges so that all visible lines lie along them before centering on their means. Finally, Analysis—> Brush
Statistics shows the statistics for any selected lines and for each existing brush.

i Sliver D:ﬂmmllemamlld&m
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For easier viewing of PC Plot windows consisting of many variables, Sliver offers the options to vertically stagger
the names and range values to avoid overlapping, and to horizontally compress or expand the spacing between two
selected axes. Each are reversible, so different groups of axes can be spread out to help analyze their relationships.

The figure below shows a PC Plot in which the names and range values been staggered vertically via the
Axis>Stagger/Unstagger Names menu option and the axes spread out between the fiber and sugars axes via the
Axis->Compress/Spread Axes menu option. Moving axes of interest together as neighbors first will increase the
benefits of horizontal spreading the axes. This spreading will also be reflected in the Transparent PC Plot Window
that we will discuss shortly.

14 Dev/Samplebata/DiNutiontxportNumbersiles.c N, . W 1 I . (T I e |
e

And so it goes for the PC Plot window, and we have not yet come to the other types of brush-linked plots.
Correlations and clustering in the data become visually apparent by re-ordering, selecting, color-brushing and hiding
combinatorial sets of data. In this way we can winnow down to the data of interest, say to data that corresponds to
high levels or error or to high performance. We can also save just the selected data or just the visible data to a new
CSV or TXT file, and then reload the file in order to reset the ranges of the axes to the new minimum and maximum
values for greater separation of those polylines or manually shift or enter new ranges. Also, note that selections can
be made in any scatterplot windows that are created (as described later), and often it is easier to identify and select
points of interest in these plots than lines in the main PC Plot window. All selections and color-brushing are
automatically propagated among the PC Plot and all scatterplots.

The data set used for this example is small at 392 rows (the numbers of selected and total polylines are shown in the
upper right of the display). Sliver easily handles up 100,000 rows of data of, say, 16 variables with reasonable
processing delays. It can be used with larger data sets with somewhat longer delays—in fact it has been used to plot
up to 500,000 rows of data with a little patience and limited interactivity. One tip for larger files is to choose to click
corner points rather than swiping in order to select lines. This option is set in the Options—>Plot Settings menu
option—in this case the display does not need to continuously update as you swipe with the mouse. Also, with larger
data sets the lines soon become an indiscriminate mass, so range-brushing of colors and hiding of polylines are
critical in reducing the display to one with visual distinctions.

The PC Plot window can be maximized by pressing the rectangle in the upper right corner of the window, or
stretched by dragging the corners of the window. It can also be zoomed in or out at any point by pressing Ctrl while
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rolling the mouse wheel or by pressing the + and — keys (no need to press Shift). In any case the mouse must be
moved into the window in order to resize the plot to the new dimensions of the window. If zoomed, panning is then
accomplished by clicking the scrollbars along the side and bottom, or by using the left/right/up/down arrow keys.
However, if histograms and means are drawn when a zoom is performed, the scrollbars are not added to the window
and you will have to zoom out and in with the mouse in different locations to move around or simply use the arrow
keys.

For a convenient listing of command keys that are available for different functions in Sliver, select the Help-> Tips
menu option. This User’s Manual is also available under the Help—=>User’s Manual menu option. More detailed
information on Sliver operation, including the windows that appear when menu functions are selected, is found in
Section 3 Sliver Detailed Operations of this manual.

But first continue on to view and try out more Sliver data visualizations.
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Parallel Coordinate Plot with Transparency

As described above, one method of interpreting the mass overplotting of lines in the parallel coordinate plot for large
data sets is to use range brushing to color code the data and then using the other visualizations described below.
Another method is to hide selected groups of lines by color brushing them and using a menu option to hide those
brush colors. Also the axes can be re-scaled to spread out the lines either by shifting the lines off the ends of a
selected axis using the arrow keys, or by shifting or manually setting the range of a selected axis using the Axis
menu functions, or by exporting the visible lines to a new data file and loading that file.

Applying a level of pixel transparency, also called alpha blending, also gives an overall sense of the clustering in the
data, i.e., the main arteries of the lines. The resulting plot is reminiscent of an X-ray, revealing inner structures. The
colors of the lines also add when overlapping, which helps distinguish the structure even more.

Sliver does not support alpha blending in the main, interactive PC Plot window due to practical limitations on
processing time. However, Sliver provides two means of viewing the parallel coordinate plot with transparency.
First, a separate window of fixed size can be plotted from the Plots menu to view the PC Plot with adjustable
transparency. Second, the PC Plot and any scatterplots can be exported to PostScript and then converted to PDF
using Acrobat Distiller—there are many settings available in Sliver for this case, and the resulting PDF can be
panned and zoomed as well.

Transparent PC Plot Window

A transparent plot can be created in a separate window as shown below by selecting the Plots>New Transparent
PC Plot menu option. This viewing window does not dynamically update when brushing or other changes are
performed on the main PC Plot. Mouse selections and other functions are not enabled in this window. It can also be
slow to draw for larger datasets. The size of the window is set in the Options->Plot Settings menu option.
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PC Plot with Transparency

anti-aliasing: on alpha: 0.150 linewidth: 1.0

The following functions are available in this window:

1. The degree of opacity (the alpha value) can be changed by pressing numbers 0 through 9 on the keyboard,
corresponding to alpha values of 0.01, 0.02, 0.05, 0.10, 0.15, 0.20, 0.25, 0.3, 0.4 and 0.5. Lower alpha
values correspond to greater transparency. The UP/DOWN arrows on the keyboard fine-tune the alpha
value between these major increments. The current alpha value is shown along the bottom right (the
example below has an alpha value of 0.15).

2. The width of the lines can be decreased/increased with the LEFT/RIGHT keyboard arrows. The current
linewidth value is shown along the bottom right.

3. Anti-aliasing of the lines can be turned ON or OFF by toggling the lowercase or uppercase “A” key. This
can improve the sharpness of the lines and the quality of the overall image, and it is beneficial when a
screen capture is made for presenting the plot. The example here has anti-aliasing turned on, as indicated in
the lower right. Note that this very significantly slows display updates for new alpha values or linewidths,
particularly for larger data files, and should normally be turned off for faster performance.

4. A Help display of these functions toggles on and off in the upper right corner of the display when the
lowercase or uppercase “H” key is pressed.

When color brushing or other changes are made in the main PC Plot window, a new Transparent PC Plot can be
created from the Plots menu. This terminates the current transparent window if it exists and creates a new one with
the updated changes. The current values of alpha, linewidth and anti-aliasing are saved between plots and sessions,
and are automatically applied to the new plot.
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This brings us to the Analysis>K-Means Clustering menu option, which provides automatic brushing of clusters
in the data using the k-means algorithm. Choosing this menu option pops up a window for selecting which variables
to include when identifying clusters. It also allows the number £ of clusters in which to partition the data, as well as
the number of those clusters to brush in rainbow colors. The most significant clusters are brushed up to the total
specified. The cluster having the most data points is brushed in red and the cluster with the least data points (of the
number of clusters to be brushed) in blue. There is also an option to automatically update or launch the Transparent
PC Window described above. This provides a means of viewing the identified clusters in the transparent view to
verify that the selected number & of clusters and the number of clusters to color brush through the data is optimal, at
which point the process can be repeated with different values. This clustering function requires that the free R
statistical software be installed on the PC, with the path to its RScript.exe file selected in the Options—>Analysis
Settings menu option.
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Export to PostScript and PDF

As a second option, Sliver provides a File->Export Plots to PostScript/PDF menu function that creates a
Postscript file of the PC Plot and any single or stacked scatterplots with a selectable (configurable) transparency,
line width and paper size. The Options—>PostScript/PDF Export Settings menu option configures the settings.
The Adobe Acrobat Distiller application can convert this to a PDF file, and if the path to Distiller is entered into the
settings the conversion will automatically occur and the PDF file will be launched for immediate viewing.

Note that there is a one-time settings change in Adobe Acrobat that must be performed to enable export with
transparency. This update procedure is described on page 68.

An example of a Postscript output that was automatically converted to PDF is shown below. This plot does not
appear as vivid as the screenshot of the previous transparent PC Plot window, but this depends on the alpha value
and the blending mode that is selected in the PS/PDF settings. Also, choose Leave Color Unchanged in the Adobe
Distiller menu function of Settings>Edit Adobe PDF Settings—> Color->Color Management Polices for
blackest backgrounds and boldest colors. In this case the options for including the axes and text in the output
were not selected in the PS/PDF export settings, and therefore these are not shown. Acrobat automatically displays
anti-aliased plots, and provides zooming, panning and much faster rendering than in the previous display window.

In general, exporting plots (including scatterplots) to PDF instead of taking screenshots is an excellent way of
obtaining vector-drawn, presentation-quality graphics whether transparency is chosen or not. Because of the large
number of intersections and the extensive flattening process required, printing the PDF typically requires saving it
first as, say, a 600dpi PNG file.
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PC Plot Matrix (PCM)

The PC Plot can only show relationships between neighboring axes. Axes can be moved to different locations to
provide different orderings, but a convenient way to visualize pair-wise relationships between all variables is to
create a parallel coordinates matrix, or PCM. This is similar to a scatterplot matrix, in which 2D scatterplots of all
variable pairs are displayed in a matrix. Here PC plots between every pair of axes are shown. In addition, the
individual plots are placed within a minimum number of rows in such a way that a continuous PC plot also occurs
across all the axes in each row. Use the Plots>New PC Plot Matrix menu option to create this window. The size of
the window can be configured using the Options—>Plot Settings menu option, limited to just less than the size of the
display.

The existing zoom methods for all windows (Ctrl plus mouse scroll or the + and — keys) works for the PC Plot
Matrix as well. Again, the Alt key zooms horizontally while the Shift key zooms vertically. Zooming may be slow
for large datasets given the number of lines involved, but the zoom level is remembered between invocations.

Shown below is an example for the cars.csv dataset. Each row represents a PC Plot across all the variables, while a
neighboring pair of axes for any two variables can be found somewhere in the three rows. This provides a quick look
at all the relationships in the data, and may spur you to re-arrange axes in the main PC Plot. This window is passive;
selecting, brushing or hiding brushed lines cannot be initiated in this window, but any such changes in the main PC
Plot are automatically applied to the PCM window. Any changes to the color scheme settings of the PC Plot window
also propagate immediately to the PCM window. Axes deleted in the main PC Plot will be deleted in the PCM when
the PCM is created again. Axes inverted in the PC Plot, however, will not appear inverted in the PCM. The window
size is set by an option in the plot settings.

For an even number N of | R
variables, there will be N/2
rows with an axis for each
variable placed in each row.
For an odd N, as in this case,
there will be (N-1)/2 rows,
but the axis for the last
variable will be repeated at
the beginning of each row in
order to show all the variables
neighbored pair-wise in this
number of rows.

The PCM window may seem
cluttered, but in fact
interesting and useful
relationships can be seen even
when there are, say, 10 rows
of plots across 20 variables.
But there are ways to reduce
clutter:

1. Different selections and brushings can be applied in the main PC Plot, and lines of any brush color can also
be hidden, as mentioned above. Selected lines appear on top in the selection color.

2. The plot can be zoomed and panned to reveal more details.

3. The PCM can be exported to PostScript and PDF just like the PC Plot in the previous section. A separate
alpha (opacity) value for the PCM can be entered in the Options—> PostScript/PDF Export Settings menu
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option, and the export obeys the general settings for showing axes and text (although this is one case where

including the text is very useful).

Two more PCM displays are shown below. The second has been exported to PS/PDF with 0.05 opacity.
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2D Scatterplots

Scatterplots are often described as the most effective visual display of data relationships between two variables. In
Sliver the user can create multiple 2D scatterplots of the data. These scatterplots represent cross-sections of the data
set and are used in conjunction with the parallel coordinate plot to better locate data clusters and outliers, and to
identify structural (functional) relationships between the variables. 2D scatterplots can also be exported to Matlab®.

Sliver creates 2D scatterplots of any two selected variables in either Cartesian (x,y) or polar (r,0) coordinates using
the Plots>New 2D Scatterplot menu option. When polar coordinates are chosen, the angle can be in either degrees
or radians and can increase counterclockwise from the x-axis or, as in azimuths in navigational data, clockwise from
North (the y-axis). After the two variables are selected for the coordinate system, click on the Finish button to create
the scatterplot. We will see in the next section that additional scatterplots can be stacked in one scatterplot window,
sharing a common x-variable or Cartesian plots or theta variable for polar plots.

The axes of the scatterplots range from minimum to maximum values just as the axes of the PC Plot. The initial size
of a scatterplot is set in the Options—>Plot Settings menu function. As in the PC Plot, each scatterplot window can
be resized, zoomed and panned. A traditional plot of values vs. time can be created by selecting time (or data row
number) as the variable for the x-axis and stretching the scatterplot window into a wide, narrow strip.

Below is a parallel coordinate plot in Sliver of the nutrition content per 100g of 1153 foods (left axis) grouped into
20 food colored groups (second axis from left, from which the colors have been brushed using gap brushing as
described earlier). This dataset is included as D3NutritionExportAlINumbersFilled.csv file in the Sample Data folder
in the Sliver distribution. There are 14 variables representing protein, calcium, sodium, fiber, vitamin C, potassium,
carbohydrates, sugars, fat, water, calories, saturated fats, monounsaturated fats, and polyunsaturated fats.

To analyze particular variable relationships, we can create scatterplots. Below are two such plots, one for fat vs.
protein and one for fat vs. carbohydrates. The data in these plots share their colors with the brushed colors in the
parallel coordinate plot. In fact, data can be swiped for selection and colored in any one of these three plots and the
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colors are automatically propagated to the other plots, and this is what is meant by fully-linked plots. Actually these
2D scatterplots are really 3D plots considering the use of color as a function of one or more other variables.

The colored food groups are well-clustered in the scatterplots. There are two outliers in the first scatterplot that are
curious. We can turn on the option again to show axis values when the mouse is hovered using the Plots->Display
Values on Mouse-Over—> Without String Mapping menu option. This function works on scatterplots as well as
the PC Plot. Placing the mouse over the rightmost outlier in the left scatterplot below highlights (increases the size
of) that dot, and the data values appear in that plot as well as the other two plots. We see that this food has 61.3g of
protein and 31.3g of fat per 100g! The rightmost plot shows that it has zero carbohydrates, and all the values are
shown on the PC Plot. What can this food be? The leftmost axis of the PC Plot identifies the food as #1092 of the
1152 foods, and checking this against the original data assignment reveals it to be barbecue-flavored pork rinds. The
other outlier is plain pork rinds.

There are a number of scatterplot settings that can be applied. For example, the plotted points here can easily be seen
on a monitor, but are very difficult to see in print. Using the Options->Plot Settings menu option, the dot size can
be set to a different value, for example, and the plot can alternatively use hollow circles rather than dots. Hollow
circles are useful for revealing hidden points and the density of clusters.

When the point size is set to 1 pixel in the Options=>Plot Settings menu option, the points cannot be resized later
without making a new scatterplot. However, if the point size in the settings is 2 or more (and the initial default is 2),
then the points can be resized by pressing the letter “b” and “I” keys (for bigger and littler). They can also be toggled
between hollow and filled by pressing the “o0” key.

A colored outline to any scatterplot points that are larger than a pixel size defined in Options->Plot Settings. The
default size threshold is 10 pixels since the outline tends to wash out the fill colors of smaller points. The outline
color can be defined in Options->Color Scheme, with a default of light gray. The outline not only makes the plots
look nicer but it distinguishes points that overlap.
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An example of a plot with hollow points of a large point size is shown below, zoomed into a section of the fat vs.
protein scatterplot.

[ Scatterplot y: fat (g) x: protein (g)
~

There is also an option to select another variable to define the size of each point, including a scale factor. In addition
to the x-variable, y-variable and color there is now a fourth dimension of size incorporated into these “2D”
scatterplots. These types of plots with variable point sizes are called Bubble Charts. The smaller points are drawn on
top of larger points for visibility, and even greater visibility is achieved by exporting the plot to PDF with
transparency as described earlier.

Below are two examples of a bubble chart for the cars.csv dataset. In the first plot a new variable was created having
a large value for cars made in the US, a middling value for cars made in Japan, and a small value for cars made in
Europe, based on the Origin(US/Japan/Europe) variable in that dataset. When this 2D scatterplot was created, a box
was checked to include a size variable and this new variable was selected with some scale factor. The figure plots
MPG vs. Horsepower, and is range brushed for Weight and sized for the Origin of the cars (the high-horsepower
cars in this dataset were all made in the US).

In the second plot below, the MPG variable was plotted against the Year, showing a general trend toward higher
MPG as time went on. The Horsepower variable was range brushed from lowest to highest in the PC Plot, revealing
some interesting outliers in the scatterplot. The Cylinders variable was chosen for the size of the points, along with a
scale factor, showing that in later years there were cars with high cylinder counts but good mileage. Just as in 2D
scatterplots of fixed point size, these variable size points can be selected by swiping and the Plots—> Display Values
on Mouse-Over menu options will display values on mouse-over in any plot.
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Note that the Sliver color scheme is completely configurable with the Options—>Color Scheme menu option. The
above plots have absolutely brilliant colors on a monitor, but for print purposes a light background or solid dots may
be preferable. The figures below show a polar scatterplot with two different backgrounds that were exported to PDF
without transparency to provide a vector-drawn graphic of presentation and document quality.
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Stacked 2D Scatterplots

Multiple scatterplots can be stacked in one scatterplot window by selecting the Add Stacked Subplot button rather
than the Finish button after selecting the axis variables for the current plot or subplot in the 2D Scatterplot window.
For Cartesian plots the stacked subplots are arranged vertically and share the same x-axis variable. For polar plots
the stacked subplots are arranged as concentric plots sharing the same theta-variable. Stacked subplots can be any
mix of plots with fixed-sized points or with points sized per another variable (bubble charts). Cartesian and polar
plots cannot be mixed in one plot window. Below are two examples of these. The first Cartesian stacked plot shows
the outlines added to points larger than the default of 10 pixels in diameter (here the default light gray color), which
greatly helps to distinguish them when they overlap. The second polar stacked plot shows selected points in purple.
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3D Scatterplots

Sliver can either use Google Earth to display 3D scatterplots or export its data to Matlab for its interactive 3D
scatterplot function.

Google Earth provides extremely fast rendering of icons in a 3D setting, and it supports transparency levels that are
useful when viewing many thousands of points in space. (However, Google Earth may not display a scatterplot of
tens of thousands of points.) Mouse controls easily rotate, zoom and pan the view to look for structure, and the zoom
control in the upper right provides precise zoom control. Spherical points of configurable size and transparency are
positioned in a cubical volume of 0.1 nautical mile per side positioned above a white, remote part of Antarctica.
Axes. Axes labels are drawn as well. Again, the color brushing based on one or more variables confers a 4D
characteristic to the 3D scatterplot.

The Plots>New 3D Scatterplot menu option is used to create these. Three variables are selected, one for each axis
for a Cartesian plot. All linear variable axes are scaled from minimum value to maximum value to expand to the
bounding box. Angular variables wrap a full 0 to 360°. All the spherical points are colored according to the current
color brushing of the other plots. A Google Earth KML file is generated, and if the path to the Google Earth
executable is provided in the settings the file is automatically launched in Google Earth. Color brush changes in the
other plots do not automatically update the Google Earth 3D scatterplot, but a new KML file is easily generated
using the same menu option that can have the same or different filename. If it is saved with the same name, Google
Earth automatically asks to redraw the existing plot. Once created and saved, these KML files are available to be
directly loaded into Google Earth at any time, individually or in combinations. Axis labels are separate KML
placemarks and can be unchecked in Google Earth to remove them if they obscure any detail.

NOTE: When moving or sending a KML file that displays spheres such as a 3D scatterplot, you must include
the dot.png file that was added to the directory of the KML file! This PNG file provides the graphic for the
spheres, and if it is missing Google Earth will complain or replace it with another shape.

Also, you can zip a KML file into a KMZ file (which needs to end in .kmz) with a size approximately 1/10 of
the original KML file. You can include the dot.png file in this zip file. This zipped KMZ file will open
correctly in Google Earth, which unzips the contents before displaying the plot. A KMZ file is a very
convenient way to decrease the size of emailed Google Earth plots as well as to include needed graphic files.

Below is an example of a 3D Cartesian scatterplot generated by Sliver. The 3D aspect is not appreciated without
interactively manipulating the plot by rotating, zooming and panning, so a second view is also provided here to help
give a sense of what can be visualized with such a plot. Note that the point sizes are defined in units of pixels, so
when zooming in the points spread apart—you are not simply zooming in closer to a fixed cluster.
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In addition to Cartesian coordinates, Sliver supports Google Earth 3D plots of data in spherical and cylindrical
coordinate systems, with angles specified in either degrees or radians, selectable in the same window where the
variables to plot are selected. The user can also choose whether math-based or navigation-based conventions are
used. The math convention for spherical coordinates (r, 0, @) has 6 increasing counterclockwise from the x-axis and
¢ down from the z-axis, while in navigation the azimuth 0 increases CW from North and the elevation ¢ is relative
to the horizon (the x-y plane). The North and East axes in navigation mode point to North and East in Google Earth,
respectively.

NOTE: To help visualize relationships, the 3D scatterplots are scaled to fit the data in a given volume. The x, y and
z axes of a plot in Cartesian coordinates are scaled so the minimum and maximum values of each variable span a
single, cubical volume outlined by the coordinate planes. The angles in spherical and cylindrical plots can span a full
0 to 360° (or 0 to 2z if radian units are selected), so these plots fill a 2x2 cubical volume. Two outlines of the 2x2
cube are drawn for reference. The minimum radius in spherical coordinates lies at the origin and the maximum
radius lies at some point on a sphere touching the 2x2 cube. The minimum and maximum values of z in cylindrical
coordinates span the 2x2 cube vertically, with the minimum at the very bottom.

Below is a spherical plot color-brushed in concert with other plots. You can tell a great deal about a system by
studying 3D data plots such as this.
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As another application, a 3D scatterplot of a hiking, biking, or aircraft path given by latitude, longitude and altitude
values provides an extremely clear visualization (scaled in each dimension to fit the cubical volume). This can be
clearer than a standard Google Earth path plot because of the lack of a cluttered background.
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In addition to plotting 3D scatterplots in Google Earth, Sliver can export data to plot as a 3D scatterplot in Matlab.
Choosing the Analysis>Export 3D Scatterplot menu option pops up a window to choose the three variable for x,
y and z in a Cartesian coordinate system, along with the size of the points. If Matlab is installed on the PC and the
path to the matlab.exe file is entered in the Options—=> Analysis Settings menu option, the 3D scatterplot will appear
in a Matlab figure with the color brushing that was applied in Sliver. The interactive controls and myriad of settings
of Matlab can then be applied to the plot as desired, and the plot can be saved in Matlab format if desired.
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Google Earth Path Plots

Google Earth is also used to plot path data from variables representing latitude, longitude and altitude. The
Options>Google Earth Settings menu option in Sliver provides settings for units (degrees vs. radians, feet vs.
meters), path opacity and width in pixels, vertical supports extending the ground and their opacity, and the altitude
reference (sea level, clamp to ground, etc.). Since the path is composed of connected data points, the path segments
are colored according to the color brushing of the other plots. This is extremely useful, for example, in identifying
the points along a path where particular conditions occur.

These plots can be helpful in visualizing and analyzing data for runners, bikers, hikers and so forth, particularly
when data such as speed, pulse rate and such is available for study. Garmin Connect, RunKeeper and Strava, for
example, offer CSV downloads of running and biking data uploaded from GPS devices. The Plots=>New Google
Earth Path Plot menu option is used to create the plot. Variables are selected for the three coordinates, and an
option is presented to only plot every nth row of data. This is important because transparency of supports decreases
with more points. There is also an option to not connect geographic points farther apart than an entered distance, or
to connect them with a dashed vertical arc. Otherwise, plotting a set of segments would add straight lines between
them, but these segments can be isolated by entering a minimum separation distance to connect. Note that to show a
single disconnected point, the option for supports must be enabled in the Google Earth Settings.

With supports turned on and full opacity in the settings, a KML file for a plot such as the one below is created and
automatically launched in Google Earth if the path to the executable is entered in the Google Earth settings. The
mouse can be used to zoom, rotate and pan the view as desired. The flight path below would be smoother but there
was a very limited number of flight coordinates in this dataset.
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There are also settings in the Options—>Google Earth Settings menu to apply multipliers and offsets to the latitude,
longitude and altitude values. One application of this is to plot a second variable as the altitude, with an altitude
offset and multiplier sufficient to plot the curve directly above the flight path. This shows values of another variable,
and possibly another color brushing, above the flight path.

For example, by selecting the same latitude and longitude variables as before but choosing a different variable as the
altitude, we can generate a plot of this variable at any point along the flight path, saving the KML file with a
different filename. This gets added to Google Earth by Sliver, and this new plot lies directly above the existing flight
path. It is much easier to visualize this by using mouse controls to pan and zoom, but one view is provided below.
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To overlay additional paths using the same geo-coordinates after performing a different color brushing possibly
related to a different variable, a new Google Earth plot can be created in the same way as the first one and saved to a
different KML file. Although the paths will exactly overlap when both KML files are displayed, there is a
shimmering effect in the supports that will reveal two or three sets of colors as Google Earth is zoomed and rotated.
Also, we can create multiple versions of the same path in separate KML files and simply toggle them off and on in
the left pane of Google Earth as layers, allowing us to see differences in the path colorations as the paths appear and
disappear.

Another way of visually overlaying data along a path is to create a thin path with supports that is colored (in the PC
Plot) according to certain variable conditions, and then create a second path colored for a different set of conditions
and placed with a small altitude offset. Then the supports show one variable dependency while the path along the
top shows a different dependency, as shown below.
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Or we can create a ribbon-like path along the top whose innermost colors reveal values under certain variable
conditions and whose outer colors reveal other conditions. The top path width in the figure above is re-plotted after
the Google Earth setting for path width is wider, say 12 pixels. Then the path width setting is changed to, say, 4
pixels and the altitude offset is increased by 10 meters, a new variable or combination of variable is color brushed,
and the flight path below is produced that shows one color dependency in the supports and two color dependencies

in the path along the top. Widths can be adjusted to provide easily readable colors depending on characteristics of
the flight path.

=R Google Earth
File Edit View Tools Add Help
v Search 0O else]e] 0% @ (] [ Xala[= Signin

—

ex: Restaurants.

Get Directions History

v Places
& wy places
=M Temporary Places
& Fiightpatht ki
& FiightPath1NarrowTopCo...
& FlightPath1WideTopColor...

Qm[ [+|v]e
v Layers Earth Gallery >
= [ = primary Database
® [ Borders and Labels
Places
@ 0= photos
= roads
® [ 30 buidings
# [J€4 ocean
# [ &% weather
& g Gallery
# [J@ clobal Awareness
® 00 more
\

\ l \
\
\
i Cmd |
' Seagleearth
(\

636/ft  eye alt 2142 ft

Page 41



Sliver v1.6.5 User's Manual | 16 February 2018

For a path that lies along the ground, it can be useful to plot time as the altitude variable, with an appropriate offset
and multiplier assigned to the altitude in the Google Earth settings. Here the negative of the time in seconds would
be the altitude offset in the Google Earth settings so that the altitude would be zero at the initial time, or alternatively
the time variable can be offset by the initial value before the CSV file is created and an altitude offset of zero
applied. The altitude reference setting should be set to Surface of the Earth, and the altitude multiplier set to a value
that provides a reasonable height for the overall path plot when multiplied by the overall time in seconds.

In the end, this provides a visual display of the time at each point along a path, such as in the birdwatching walk
shown below. The location and time of day information was recorded on a smartphone app (Maps 3D PRO®) during
the walk, then exported and emailed as a GPX (.gpx) file to a computer, and finally opened directly in Excel (it can
read GPX files) and saved as a CSV file that was read into Sliver. The time axis was range brushed in the PC Plot
with the default Sliver rainbow brush, so the walk starts at the purple end of the spectrum (the low end) and
proceeds to the red, upper end. Path supports were enabled and a separate KML for the path clamped to the ground
was also created as a visual aid. Slower paces and complete stops are displayed as points where the path rises
sharply, since the time increases with little or no latitude/longitude movement, and in this case the pauses and stops
mark places where interesting birds were found. Other variables such as EXIF metadata information in photos taken
along the way could be added and used for color brushing. A similar KML file for another person with the same
altitude offset and multiplier will show encounters and near-encounters by intersecting or nearly intersecting paths.

When creating a Google Earth Path Plot, options are provided to add timestamps, pop-ups and labels. These require
spheres added along the top of the path to serve as clickable points such as those on the path in the figure above.
Since the options are common to all Google Earth plots, they are discussed later in a separate section.

A separate KML file is created every time a Google Earth plot is created, so they are always available to be loaded
into that program outside of Sliver and can be mixed and matched as desired. There is also a DataTools>Merge
KML Files menu option to combine multiple KML files generated by Sliver into a single KML file. You can also
zip a KML file into a KMZ file (which needs to have a suffix of .kmz) to decrease its size by about a factor of 10.
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Google Earth Connection Plots

The menu option Plots->New Google Earth Connections Plot creates a KML file that plots lines between a
selected pair of geo-coordinate variable sets (lat/lon/alt for point 1, lat/lon/alt for point 2) in each row of data,
colored with the brush for that row. Plotting every nth row is also possible.

There is also an option to assume the endpoints of the connection lie on the ground. Otherwise, lines connected
between distant points can pass through the Earth if the altitude reference is not set to Clamp to Ground in the
Google Earth Settings. This also means that the altitude variable does not have to be selected, which is necessary
when only ground coordinates are available. This ground connection lies on the surface of the Earth along the great
circle path between the points, with width, opacity, etc., set as before in the Google Earth Settings. An example
showing US-bound outgoing flights from the Chicago O’Hare Airport on January 15, 2008, color-coded for arrival
delay, is shown below. Note that you can create multiple connection plots to complete grids of lines for rectangular
areas, and the DataTools>Merge KML Files menu option can be used to combine them into a single KML file.
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The file of data for this plot is found in the SampleData folder, although you will want to select only variables with
numerical values such as Origin Lat/Lon, Destination Lat/Lon, Arrival Delay, etc. There are 972 flights in this plot,
but many connections overlap because many cities have multiple flights from O’Hare in a single day. One option is
to not assume the connections lie on the ground and use another variable, such as departure time during the day, as
the altitude, with an appropriate multiplier in the Google Earth settings so that the altitude changes are visible. The
first plot below is such a connections plot where the altitude at the O’Hare position is the departure time multiplied
by such a factor. This reveals the various flights better, and can be explored using Google Earth controls to see if
later flights to a city, say, are delayed more than earlier flights. Settings for the plotted lines (units, width, opacity,
supports and their opacity, etc.) are taken from the Google Earth settings except that the altitude reference is not
used when endpoints are chosen to lie on the surface.

You can also draw vertical parabolic arcs between two connections lying on the ground rather than a line. The
heights of the arc for different distances (the ratio of the distance between the points and the height) is user-
selectable. This arc lies above the great circle path between the points. Again, the width, opacity, supports, etc., for
the arcs is set in the Google Earth Settings, where you probably prefer the supports to be disabled. The second plot
below is of the same data as previously but with a slightly different color-coding. This plot overlaps flights.
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As before, this KML file can be added to any other KML files displayed in Google Earth.

When creating Google Earth Connections plots, options are provided to add timestamps and pop-ups (but not labels)
as discussed in a separate section.
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Google Earth Pillar Plots

The menu option Plots>New Google Earth Pillar Plot plots vertical rods at geographical points on the surface of
the earth. This is very nice for marking individual points, even densely spaced points, with Sliver color-brushing and
either a fixed height or variable heights. The width and opacity of the pillars is user-selectable in the pillar plot
window. The height above the ground of the pillars can either be a third variable or be set as a fixed value entered in
the window. There is also an option to place a sphere on top of each pillar of that color and a configurable size and
opacity. These vertical rods with or without spheres are a finer alternative to the large pins and markers that Google
provides by default.

NOTE: If spheres are added to the pillars, any move of the KML file must also include the dot.png file added
to the directory of the KML file when it was created, as it provides the graphic for the spheres. If it is missing
Google Earth will complain or replace it with another shape.

Also, you can zip a KML file into a KMZ file (which needs to end in .kmz) with a size approximately 1/10 of
the original KML file. You can include the dot.png file in this zip file. This zipped KMZ file will open
correctly in Google Earth, which unzips the contents before displaying the plot. A KMZ file is a very
convenient way to decrease the size of emailed Google Earth plots as well as to include needed graphic files.

For example, to show the flight delays in the previous section, it is possible to add pillars at the destination
coordinates with a height proportional to the flight delay. Where there are multiple flights to a destination, adding
spheres to the tops of the multiple pillars will separate the delay information in a color-coded stack of spheres.
Below is a Google Earth plot of the ground-based connections KML file from the previous section along with a new
KML file of a pillar plot with latitudes and longitudes of each destination and a height that is a multiple of the
arrival delay (the Google Earth Settings for altitude multiplier and offset are applied to the height in a pillar plot
unless a fixed height is selected). Range brushing was first performed on the arrival delay axis, so the higher, red
spheres represent flights with the longer delays. Setting a lower sphere opacity would better show overlapping
spheres—however, the height could have been assigned to a different variable, such as the number of times a sphere
color occurs for a destination, and then each colored sphere would sit at the height for the count of that color.
Individual KML files can be turned on or off in Google Earth in the left side panel, and in fact displaying only the
pillars makes a more readable graphic if the paths are not important.
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Below is a pillar plot of Chicago homicide locations in 2016 through Christmas, where the data is brushed blue for
the incidents where an arrest was made. This plot was made by choosing in the Pillar Plot window a fixed pillar
height of zero and choosing to add a sphere on top of each pillar of size 2 and maximum opacity of 16.
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Here is another pillar plot of the same data, where all the lines in the PC Plot were brushed yellow. In the Pillar Plot
window here, the pillar width was increased and the opacity of the pillars decreased. The pillar height was again
selected to be fixed rather than a variable value, but the height was set very high. The option to add spheres to the
tops of the pillars was not chosen, but that would not make a difference since Google Earth was zoomed in enough
that the tops of the pillars are not visible. Given the nature of the crimes, the ascending translucent pillars are
evocative, I think, of the loss that these communities faced.

Again, the DataTools>Merge KML Files menu option can be used to combine multiple KML plots into a single
KML file for convenience, and timestamps, pop-ups and labels are supported as described in the next section.
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Google Earth Timestamps, Pop-ups and Labels

When creating Google Earth plots, options are shown to add timestamps, pop-ups and labels. These provide
interactivity to the plots and to associate data with locations in the plots. All information is embedded in the
generated KML file, so Sliver does not have to run in order to provide the user with an interactive Google Earth
experience. Detailed information on selecting these options is provided in Section 3 Sliver Detailed Operations.

Timestamps

A timestamp is a value added to every plotted point that specifies a time of day. When timestamps are present in a
KML file opened in Google Earth, a small player control panel automatically appears in the upper left corner of the
Google Earth window, with endpoint times spanning all timestamps in the file (or multiple files if more than one is
opened). Sliding the main cursor across the time scale shows the plot components at the time corresponding to their
timestamp. The player also includes a second cursor to set an interval of time relative to the main cursor, and this
can be adjusted to only show plot elements within the span of time between the two cursors, perhaps only one
element at a time. The player controls can be used to animate the plot, only showing plot elements as the slider is
manually positioned or automatically played. The automatic animation speed, which may be too fast at its default
setting, can be adjusted by clicking on the wrench icon in the player control panel. A zoom button in the player
controls will reduce the range of the slider and also slow down the play.

Timestamps can be applied to Path, Connection and Pillar plots. The timestamps at the points can be chosen to be
the row number as seconds since midnight (simply to provide a timespan), or the values of any variable at the points
as seconds. If a variable time-formatted in hh:mm:ss is selected, it is converted to seconds so the player will then
show the associated time. The timestamps will roll over into new days if the number of seconds is large enough.
Note that the Convert Date/Time to Numeric function in DataTools will convert all kinds of date and time formats to
either seconds since midnight (for time intervals or times of day) or to decimal days since the start of the first date in
the file.

The timestamp feature is useful to provide animation in Google Earth without running Sliver at all. It is useful to
show events in the order that they happen, or to reduce clutter in complicated plots by only showing a particular
range of the plot at a time. It is also possible to create one plot without timestamps and then create another one with
timestamps and a short interval in order to animate motion along a visible route.

Popups

In Pillar and Connection plots, and whenever spheres are added to a Path plot, a window provides an option to
display the corresponding row values of selected variables in a pop-up when an element is left-clicked in Google
Earth (these are also called balloons). In a Path plot the spheres on top of any supports must be clicked, but Pillar
spheres and bases as well as Connection lines can be clicked. The variables names and values are displayed in
tabular form in the pop-up. This is a great way to see the data at any point in the Google Earth displays.

It may happen that a pop-up pointer may be a bit offset from the selected point, or that a scrollbar appears in a
truncated pop-up. In either case, zooming in or out by one notch (one roll of the mouse) will correct this.

Labels
Whenever spheres are added to a Pillar or Path plot (not supported in a Connections plot), the window above will
also provide an option to display the corresponding row values of any selected variables in a label when a mouse-

over of a sphere is performed. These are displayed as a single row of values separated by commas, without the
variable names. This is very useful for fast analysis or in finding the location of a particular value in a plot.

Displaying Strings in Pop-ups

It is possible to display a mapped string rather than a numerical value for selected variables in pop-ups. This uses a
string mapping file whose path is entered in the Plot Settings, the same file used when selecting the Plots> Display
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Values on Mouse-Over->With String Mapping menu option described earlier. If enabled, values for each variable
are compared to a list of matching numbers and strings for that variable in the file, and if a match occurs the string is
displayed instead of the number. This file has the format of the output string mapping file of the Replace Strings
with Numbers function of the DataTools menu, although the string mapping file can also be created by hand (see
Appendix E for the format).

Below is the same Google Earth Pillar Plot as earlier that has timestamps, pop-ups and labels applied. The plot
shows Chicago homicides in 2016 through Christmas. The data provided by the city includes strings, so the Replace
Strings with Numbers function in the DataTools menu was used first to map any strings to unique numbers in those
variables. The string mapping file that was created as part of this function was then entered in the Options—-> Plot
Settings window, and the option to map numbers to strings was checked off when creating the plot. The date field
was converted to seconds since the first event in the file using the Convert Date/Time to Numeric function in the
DataTools menu and saved to a new variable, and this variable was selected to provide the timestamp in seconds.
The start date for the timestamp is an entry in the window for the timestamp, and was set to 1/1/2016.

All three features are seen in this screenshot. The timestamp player is shown in the upper left corner, and it can be
seen that the date converted to seconds provides the full range from 1/1/2016 to 1/25/2016. The cursors span the
entire range, so all points are shown. The left cursor can be slid to the right to close the interval of visibility. The
Play button is the rightmost tiny button at the top, with buttons to zoom in and out of a play range to the left of it.
The animation speed can be adjusted by clicking on the wrench icon in the upper right.

Left-clicking on a point brings up the cyan pop-up with the values for that point for all variables that were selected
(the latitude, longitude, and date converted to seconds were not selected for this display). The string mapping
filename was entered into the Plot Settings and the box was checked to map numbers to any corresponding strings
for the displayed variables, so variable values were mapped back to their original strings.

The mouse cursor in the lower right is hovering over another point, which then shows a label next to it. Labels span
only one line and show only values, not variable names. Here only the Case Number and Date were selected to be
included in the label. The size of the label can be adjusted in Tools=>Options=>3D View in Google Earth.

NOTE: Anyone with this KML file is able to fully operate these controls and displays—there is no need to
have Sliver. However, the dot.png file added to the directory of the KML file must be moved along with any
moves of the KML file, as it provides the graphic for the spheres.
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Animation
Sliver provides three modes of animation (motion graphics) for visualizing data:

1. Grand Tour — the capability to rotate n-dimensional data in n-space and project the result onto the 2-
dimensional plane of the computer monitor. This dynamic mashing of data can provide visual identification
of clusters of points, outliers, nonlinear relationships, and low-dimensional substructures that may not be
apparent in individual two-variable or three-variable scatterplots. Color brushing is again fully synced with
the other plots. This functionality is similar to that of the CrystalVision and GGobi data visualization tools
listed in Appendix A. References describing the use of the Grand Tour are included in Appendix B.

2. Count-Based Animation — the capability to “play” the rows of data and animate the plots, including
animating Google Earth plots and syncing the played data with external video player software or other
software applications. This real-time correlation is particularly useful when analyzing data associated with
flight video or other instrumented data. Often errors can only be detected visually in flight video, for
example. Here flight video can be played or jumped forward or backward and all Sliver plots, including any
Google Earth path plot of the aircraft, will follow the video, allowing visual situations to be matched with
the data at that time.

A preset selection is provided in the animation menu for playing data with the Sliver Data Player. However,
any set of parameters can be entered to interact with other software or instrumentation as described in the
Count-Based Animation section below.

3. Real-Time Data — the capability to gather and display data as it is written to a data file by an external
script or instrumentation. This is useful when monitoring of data is desired over a period of time. The
animation can be stopped for data analysis using Sliver functions; when restarted, it continues at the point
in the data file where it left off.

The Grand Tour

Between n =3 and n =9 variables can be assigned to n dimensions in the Grand Tour animation when the
Animate->Grand Tour menu option is invoked. The n orthogonal axes rotate randomly in the Grand Tour window
at a speed and direction controlled by the user. The scatterplot points shown on the display are the 2D projections of
the locations of the points in n-space. In effect, the functions along each axis become orthogonal, linear
combinations of all the variables. The dynamic behavior of these points, e.g., clusters of points moving as a group or
structured along an axes, reveal data correlations. The animation can be paused for selecting individual or groups of
points by brushing, and brushings among the Grand Tour window and other plots are fully synced.

Two sample views of the same data in the Grand Tour window are provided below. The point size was increased for
better viewing here, but resolutions down to 1x1 pixels as well as zooming are available for larger data sets. Three
clusters of data were observed to follow closely in their movement as the plot rotated in 5-dimensional space. The
animation was paused and the mouse was used to swipe one of these groups. This selection was automatically
propagated to the PC Plot and other 2D scatterplots. The main PC Plot Brush menu was used to assign the selection
to a color brush, which propagated back to the Grand Tour display. This was repeated for the other two groups,
resulting in the second image below. This second window also displays Help information on the various mouse and
keypress operations available in the Grand Tour.

The circular display in the lower right shows the relative contributions (projections) of each axis onto the plane of
the display. This is very useful to appreciate the effects of the variables on the distributions of points. In the first
image variable 3 (shown as the variable linolenic in the text in the second image) provides the greatest contribution
in the upper right direction, while variable 1 (oleic) has virtually no effect on that distribution. In the second image it
can be seen that variables 2 and 5 (linoleic and eicosenoic) are the most significant contributors to the separated
distribution, with eicosenoic providing the separation of the blue group from the others and linoleic instrumental in
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separating the green from the red groupings. This is useful in assigning color brush filters in the main PC Plot. The
overall transformation (rotation) matrix can be saved to a file for more quantitative analysis if needed.

As seen in the Help text in the second image, automated pursuits (in a random walk manner) are also provided that
optimize the central space (to help separate point groups), central mass, separation of colors, or separation of the
color that can be most isolated. This is discussed in greater detail in a later section.

B Grand Tour
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B Grand Tour

Paused.

As another example of the use of the Grand Tour animation, open the Pollen.csv file in the SampleData subfolder
(File->Read File — every 1 line(s) as decimal or time). This dataset consists of 3848 samples of pollen with 5
variables for different characteristics plus a Number variable running from 1 to 3848. Range brush or color the PC
Plot as you wish and invoke the Animate->Grand Tour menu option. Select the 5 variables other than Number and
start the Grand Tour. If you zoom into the center of the animation (press p to pause and then press + to zoom in, and
use the x key to move the plot to the right to center it), you will see the word EUREKA rotating as points in the 5-
dimensional space. These points were artificially added to the dataset as an exercise in data exploration.

e - = — . — e . O =
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Count-Based Animation

Animation with the Sliver Data Player

Sliver has a built-in player for data animation that sequences rows in the data file and animates the plots and
optionally an external program such as a video player. When this animation mode is invoked with the
Animate->Count-Based Animation menu option, the player interface appears:

7 Sliver Data Player = ]

Left-Click on a slider to drag it to a new position, or Right-Click in a channel to move the slider at that pasition. Left-Click in a channel to move the slider by one in that direction, and hold down to continue moving by one.
Mouse scrolling is also supported to increment or decrement the Row number. Hotkeys include p for play/pause, /s for faster/slower while playing, and r for reverse.

Row number

it
-w_________________________________________________________________________________________|

1 40 79 118 157 196 235 274 312 352 391

Narrow Window > Play >> | << Reverse << ‘ & Nolooping (" Wraparound (" Zigzag Exit

Rows per second

0
- ___________ |
EET: -9 -84 12 -60 48 E N 12 0 12 u G 18 60 12 84 96 108 120

The top green scale shows the current data row number of the total data rows loaded into Sliver. The tab can be
dragged to the right to any row value, or the green bar can be left-clicked to advance the row, or the green bar can be
right-clicked to immediately jump to a row. The bottom red row provides the rows per second to play, either
forwards or backwards, and the Play/Pause button starts and stops the player. The maximum rows per second to set
in this interface is entered in the first Count-Based Animation window. Looping or zigzagging of the data is selected
with the radiobuttons in the right center of the player window. There is an option for narrow vs. full window to save
screen space by removing the labels. It also supports mouse scrolling for incrementing and decrementing the row
number as well as f/s hotkeys for faster/slower when playing and p hotkey to play/pause and r hotkey for reverse.

Let’s begin an animation. The data file consists of small airplane data. We want to show scatterplots of variables
against time, so we need to add a column with a variable for the row number. We first select the DataTools 2Add
Column for Row Count menu option described later in this manual to add the Row variable as the first column.

Then the data file is loaded into Sliver, producing the parallel coordinate plot with Row as the leftmost axis. The
rightmost axis is selected with an Alt-Click, shown as the red name below. Then the range brush option is invoked
to automatically color the lines from minimum to maximum values on that axis with 8 colors ranging from blue to
red. The corners of the plot are then dragged to resize the plot to fill the width of the display.

Stiver  C:/Apps/MyPCSW/aaN3192MetadataExport2.csv.
File Options Brushes Axis Plots Animate DataTools Help
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Now two scatterplots are created using a menu function, plotting two variables vs. Row. Since the rows represent
samples in time, these plots show these variables over time. The plots are resized to thin strips and placed above the
parallel coordinate plot. They are then zoomed and panned horizontally and vertically (in different amounts) to best
view the individual curves.

At this point the Sliver Data Player is invoked with the Animate->Count-Based Animation menu option, where
we accept the defaults (or click on the Sliver Data Player preset which reloads the defaults) and do not check the
option to animate Google Earth. The animation is then started. The PC Plot is reduced to a bright line representing
the current data row values. A configurable number of trailing fading lines show previous lines to highlight variables
that are rapidly changing. All the lines are shown in their colors from range brushing the full PC Plot. The two
scatterplots highlight their data points for the current value of time (row number). They display their axis values if
configured to do so in the window that appears when the animation is launched, and the plots roll along to maintain
the current position in the center of the window unless they are very near the start or end. The sliders can be moved
with the mouse to view the curves at past and future times, and when released the animation continues.
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Let’s stop the animation with Animate-> Stop
Animation. All plots return to their previous state.
Now we create a Google Earth path plot using the
Lat, Long and Alt variables. Then we again select
Animate->Count-Based Animation and choose to
also animate Google Earth and select the aircraft
icon and the option to animate a line to a secondary
set of coordinates (but not to color that line per
another variable). The animation is restarted, and
now the Google Earth path plot is also animated,
showing an aircraft at the current location on the
flight path pointed to its heading. An optional line
from the main icon to a second set of selected
coordinates (t_lat, t long and t_elev), is also
displayed. The Animate window provides another
option to color this line according to the value of a
different variable (white if zero, range brushed
from blue to red over its range otherwise).

NOTE: If Google Earth stops updating during the
animation, right-click on the “Position” label in the left pane of Google Earth and select Refresh. Plotting less
points in Google Earth reduces the chances that it will stop updating.

There is also an option in the Animate window to move the Google Earth camera view to follow the main icon. The
range, tilt angle and relative heading of the camera from the icon as it moves can be specified. If the option to draw a
line from the icon to a secondary set of coordinates is enabled, the relative heading can also be switched in sign to
always be opposite that line for better viewing of it, or the heading can always be along that line.

We might also launch a video player and load a video from the flight. If the frame of the video can be read or
written, the video can be played in sync with all the rest of the data (see the next section). (The example flight path
image here was captured during a different animation, so the coloring does not match the color brushing in the PC
Plot above.)

All variable values are shown visually and numerically on the plots as the play occurs. An entire display spanning
two monitors is shown below, demonstrating the data visualization possible using the animation feature of Sliver.
The position in the flight path is represented here by a scatterplot of latitude vs. longitude as well as in the Google
Earth path plot. More windows can be inserted by reducing the sizes of the existing ones, and in fact the scatterplot
dots and parallel coordinate lines are set larger than necessary here so they are more visible when printed.
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Two or more instances of Sliver can run in a common Count-Based Animation. A single Sliver DataPlayer window
will serve to control all instances (creating a new player in any instance will replace the one in the previous
instance), so it is possible, for example, to animate multiple paths in Google Earth simultaneously with their own
icons. The animation is based on row number, so you will want to make sure the data used in all Sliver instances
starts at the same time of day, for example, and have the same data rate. Note that the same data file can be read into
multiple Sliver instances and different variables selected for the animation.

. .
€) Scatterplot r: speed (m/s) theta: heading (deg) [E=EEE

heading (deg) ) 0 /4842 (0.0%)
et

The animated 2D scatterplots
shown above are plotted in
Cartesian coordinates.
However, a polar plot can
provide a unique and very
useful plot for animation. An
example is shown on the right,
where the speed is plotted as the
radial distance r and the
heading is plotted as 6.
Actually, this data might be
better plotted in the optional _
navigational format, where e T
North lies at the top, East at the '
right, and 0 is plotted eastward
from north as the azimuth.

1613672 <= speed (m/s) <= 254.0039

Count-Based Animation with Other Software Applications or Instrumentation

The animation of the data is based simply on whatever number is currently in the last row of a user-named text file.
Syncing the data from an external program only requires a script to be written that continuously appends numbers to
the end of the file based on the video frame or some other characteristic of the external program. Conversely,
animating an external program can be done using the internal Sliver Data Player interface, which itself writes
current row numbers to the end of a text file. The conversion of this number to the current data row is user-defined
in the animation settings, including the data row offset, a multiplier to apply, the file to read the number from, and
the script to launch. The file containing the count numbers is deleted between Sliver sessions to limit its size.
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Real-Time Data Animation

Sliver also provides real-time input and display of data in the PC Plot and 2D scatterplots. This is useful for
instrumentation and monitoring operations. There is an option to display all the data or only retain the most recent n
data entries (to limit clutter), and to either restore all the undisplayed data or delete it when the animation is stopped.

The interface is very simple. A file is created that has three rows, the first being the header row with the variable
names and the other two rows consisting of the maximum and minimum expected values for the variables. This file
is then loaded into Sliver as an ordinary data file, producing a PC Plot with scaled axes and lines across the top and
bottom of the scales (maximums and minimums) corresponding to the two rows of data. The real-time data
animation mode is entered through the Animate->Real-Time Data Animation menu option. After specifying the
options listed in the previous paragraph, Sliver deletes the data from the two input rows and continuously monitors
the same data file. Whenever an external script appends a new data line to the file, the PC Plot and all 2D
scatterplots are populated with the data.

The real-time animation is exited through the Animate->Stop Animation menu option, and if the option to restore
undisplayed data was selected all data lines are shown. At this point all functions of Sliver are available to act on the
data. Restarting this animation will continue data collection at the point in the input data file where it left off—if
data was written while the animation was stopped the display will very quickly update as it inputs all the new lines
and catches up with the current data. A message appears whenever the display lags the input data.

Range brushing of an axis can be performed before the real-time animate mode is entered. The two data lines
(maximums and minimums) that were initially entered are then colored, a good indication that the range brushing is
set. Thereafter, input data is assigned to the appropriate brush color, and the PC Plot lines and 2D scatterplot points
are drawn accordingly. This color brushing is useful to quickly detecting extreme data as it occurs.

SliverNG  C:/Apps/MyPCSW/aaaartanimstart.csv E]@ \

File Options Brushes Axis Plots Animate DataTools Help

100.0 100.0 100.0 95.0 100.0 110.0
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The number of data points that can be input  fEE_—Ga———
is limited only by the computer memory,
but a million lines is quite reasonable. 1000
However, in this case all the data should not
be restored when stopped, as Sliver cannot
effectively operate on that many data rows.
Retaining the last 100,000 data points is
very reasonable, where perhaps 5X more
points is feasible if filtering the data is
performed as one of the first operations.
(Because of the slow interaction for very
large datasets, it is best when filtering these
to choose the setting in the Options—=>Plot
Settings menu option to click on corners of
a selection rectangle rather than swiping the
selected points with the mouse.)

Another example of real-time data
recording is shown below. An Arduino
microcontroller was used to collect 1000
temperature data from a temperature sensor

connected to an analog input pin. It then processed the data and provided three data values per sample separated by
commas: an x-value as the sample number mod 1000, a y-value scaled to fit 20 rows of plots of the temperature, and
the actual temperature value itself in degrees Fahrenheit. Sliver was put into real-time data recording mode, where
the first line of a CSV file held the variable names Time and Temperature and the next two lines were populated
with min/max values of x (0 and 1000)
and y (65 and 65+3 +20*17 where each
plot has a range of 17 degrees between
68 and 75 except for an offset of 3 at
the very bottom). The actual
temperature variable was range-
brushed in the PC Plot. Then the
maximum number of displayed points
was set to 19950 to support overwriting
on wrap-around, and a 2D scatterplot
was created to plot the incoming
values.

ﬁ{

A Python script monitored the serial
port and appended each line to the end
of the CSV file. The Arduino wrapped
the plot back to the top after 20,000
samples, where the 50-point disconnect
can be seen. When stopped the data
was available for immediate analysis as
well as later analysis by loading the
CSV file.

:

When a large number of input data points are retained in the plots, the display can lag the data. In this event, a
warning message is displayed along the top of the main PC Plot window indicating that the display is lagging the
input. Since the main PC Plot was not used here, that window was minimized, leaving only the scatterplot window
visible. The PC Plot is not updated while minimized, so this allowed the data rate to increase. Whenever the PC Plot
is un-minimized, it is automatically updated with the latest data.

Contact me if you would like the Arduino and Python code for this example.
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3. Saving Sessions and Dashboards

Once a dataset has been edited in Sliver, the main PC Plot and any 2D scatterplots that have been created in the
session can be saved to a session file and restored at any later time. This is accomplished using the File->Save
Session and File->Restore Session menu options. The ranges, color brushing, color schemes (which can be unique
if the color scheme is changed after 2D scatterplots are created), window placements and sizes, and all kinds of
information about the current state of the plots are stored and restored. The only attribute that is not saved is any
horizontal compression or expansion of the PC Plot axes (they are equally-spaced when restored). For a large
number of data sets this can replace many swipes and button clicks, and this allows a previously configured set of
plots to be instantly recreated for a specific dataset. The plots appear are recreated in their current stacking order on
the screen, except that the PC Plot will always be the rearmost.

A dashboard template stores the same plot information as a session file but is intended as a configuration of plots
that can be created for any dataset. Therefore, the dashboard file does not store the actual dataset of the current
session, just the characteristics of all the plots. The File>Create Dashboard from Session menu option is used to
create a dashboard from the current configuration of plots. The File->Read File into Dashboard menu option will
first prompt for the dashboard file and then for the dataset to be loaded into that dashboard. The dashboard file
references variables by index, that is, the axis number from the left starting at 1. Therefore, the variables do not have
to have the same names in a new dataset, but of course the ranges and color brushing are based on the axis number
so generally we want the variables in the same columns of the data file.

Below is an example of a set of plots on the Windows desktop that were created from a dashboard saved from
another session. These can span two or more monitors if desired. The upper right plot has a different color scheme
for its background, axes and text because it was created when the PC Plot had that particular color scheme defined
(via the Options=>Color Scheme menu function). While the colors of the actual points are dynamically linked to
the PC Plot while a plot is unlocked, the scatterplot color schemes are matched only when created and are not linked
to the PC Plot after that.

0/392 00%)
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The color brushing rules need to be
assigned when the dashboard is
created, as another dataset will
probably have values that do not
exist in the dataset that was used to
create the dashboard. When the
dashboard is created, a window will
ask how the existing plots should be
colored. For the main PC Plot, there
are options to

e not color brush it at all,

e range brush it according to
a selected palette and
number of colors, or

e  brush up to 10 specific
ranges with specific colors.

If range brushing is selected, the
variable number (the axis number
from the left starting at 1) to use for
range brushing is selected at the top.
If brushing specific ranges, the
range values with a unique color are
entered in a row and the gray button
at the end of the row is clicked to
select the color for that range. Gaps

B " Create a Dashboard

=>>>> Brush assignments for the main PC Plot

Variable number to color brush: ’l_jl

¢ Do not color brush

16 =

& Range brush using palette: Sliver_rainbow T MNurmber of colors:

" Brush according to the following ranges (inclusive) and colors:

From: | To: |
From: | To: | [
From: | To: |
From: | To: | :
From: | To: |
Frorm: | To: | |
Frorm: | To: |
Frorm: | To: | :
From: | To: |
From: | To: | [

»3»>>> Brush assignments for scatterplot: y = Variable 3 x = Variable1
For this dataset, y = Horsepower x = MPG (LOCKED)

Variable number to color brush for this scatterplot if not linked to the PC Plot: | 3 3:
" Link brushes to the PC Plot (an unlocked scatterplot)
16 <

" Range brush using palette: Sliver_rainbow - MNumber of colors:

% Brush according to the following ranges (inclusive) and colors:

From: | 460  To: | 100

|»

in the ranges are uncolored.

To: | Zﬂd

From: | 100.001 9
The color brushing rules are then ﬂ Cancel
entered for each existing 2D

scatterplot. The variable (axis) numbers for the plot are shown along with their current variable names (the names
are not stored). The scatterplot can be

e colored according to the PC Plot,
e range brushed with a selected palette and number of colors, or
e brushed for up to 10 specific ranges (not available for stacked subplots since they have unique ranges)

Again, if range brushing is selected, the variable (axis) number to apply the range brushing to is selected for the plot
at the top of its section in the window. Any scatterplot whose color brushing is not linked to the PC Plot will be
locked when the plots are recreated for a new dataset so they do not automatically link to it (the lock can be toggled
off with the “k” key).

Again, just to be clear, a session file contains all the information to restore the plot configuration for a specific
dataset that is also stored in the session file. A dashboard file contains only the plot configurations, so reading a file
into a dashboard requires selecting both the dashboard file and the data file. The data file must contain at least as
many variables as the session had when the dashboard was saved (additional variables after those are fine), and these
variables will normally be in the same order since the plot ranges, etc., are based on the variable (or axis) number
counted from the leftmost axis.

The exact contents of the session and dashboard files are listed in Appendix C and Appendix D. Sometimes it is
easier to directly edit one of these files in a text editor after it is created, or to programmatically create it.
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4 . Sliver Detailed Operations

This section describes the means of creating and manipulating the data visualizations shown in the previous section.
Sliver provides command-line support for opening data files from a command window or from a script, but most
people will simply double-click the Sliver executable file and click on the menu function to open a data file. This
section describes the use of the command line, the use of the mouse and keyboard, and the use of all the menu
options provided in Sliver.

Note that selecting a set of lines is not the same as brushing a set of lines. Selections are given a selection color, but
selections are temporary and are immediately replaced when a new selection is made unless an OR, AND or XOR
Boolean operator is specified. Selections are used to quickly investigate correlations of data within a plot and across
plots. The number of selected lines out of the total is provided in the upper right of the main window.

A selection can be saved (assigned) to a brush, however. The brush can be given any color, and these brushes are
more permanent than selections. Brushes can be assigned, hidden, re-shown, re-colored and unbrushed again via the
Brush menu. Selecting and then brushing lines that are already brushed will re-assign those lines to the new brush.

Selections and brushes are automatically updated across all plots except Google Earth plots and scatterplots that
have been locked (by pressing the & key), which require manual updating through creation of a new plot—in the
case of Google Earth plots the new plot should be saved with the same filename.

Note: Certain functions such as inverting, deleting, moving, shifting and compressing an axis after the PC Plot has
been zoomed (not simply resized) will first redraw the PC Plot to its original layout.

Launching Sliver via the Command Line

Sliver can be opened from a command line entered in a command window or executed from a user program or
script. Of course, just entering the path to the Sliver executable path will simply open the program. Entering a path
to a data file or a previously-saved session file will load that file. The filename can be followed by one or more
options. In the case of a session file, the only option that can be included is —deleteall, which closes all open Sliver
windows and instances first. In the case of a data file, the option —dashboard can be used to open the data file using
a previously-saved dashboard file for the configuration of plots. The option —vars can be used to only input variables
listed in another file, one per line. The option —every can be used to only input every nth line, which also sets the
internal decimation setting to that value. These are listed below.

Note that the path to the Sliver executable must be included when calling Sliver unless the command window
prompt is already at the Sliver directory. Even if the path is listed in the %PATH% environmental variable and
therefore Sliver will be found from any directory, the path must be included so that Sliver can internally change its
directory to the correct one. Below are more details on the command line usage:

o <Sliver executable path> <data file path> to open a data file

o <Sliver executable path> <session file path> to open a previously saved session file

e  Optional parameters can be added at the end of the line. All options are available when reading in a data
file, but only —deleteall can be included in a session file command line.

o -dashboard <dashboard file path> to read the data file into a previously saved dashboard
template. The input data must consist of at least as many variables as in the saved dashboard file.
Dashboard plots are plotted based on variable order rather than name, so the data file should retain
the same variable order as when the dashboard was created.

o -vars <variable selection file path> to only read in variables listed in a file. The format is one
variable name per line (in any order), corresponding to the format of variable files saved within
variable selection windows in Sliver.

o -everyn to read every nth line of the data file

o -deleteall to delete all previous Sliver instances
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Mouse and Keyboard Controls

The mouse and keyboard are used for manipulating the visualizations after they are created by the menu functions.

Use the mouse to either swipe across lines to select them (and color them the selection color) or to click the
two corners of a selection box, depending on an option set in the Plot Settings. For large files, choose the
setting to click for the selection rectangle corners instead of swiping, and press Enter to select or ESC to
cancel. Pressing Ctrl-A selects all visible lines.

Press Ctrl while selecting to OR a new selection with an existing one.

Press Shift while selecting to AND a new selection with an existing one.

Press Ctrl-Shift while selecting to XOR a new selection with an existing one.

Press Alt while clicking on an axis name to select the axis, which will color the name with the selection
color. Alternatively, press a digit key 1-9 to select that axis starting from the left, and then n to shift the
selection to the right or N to shift the selection to the left. Then invoke the Axis menu or press the i, X, m, r
or g key to invert, delete, move, range brush, gap brush or shift lines along the axis. In a gap brush, the
Up/Down arrow keys are used to increase or decrease the number of gaps and colors. Note that inverting,
deleting, moving and shifting an axis on a zoomed plot will cause the PC Plot to revert to its original size.
To shift lines along a selected axis, press the Up/Down arrows to shift them up/down at the top, and press
the Right/Left arrows to shift them up/down from the bottom, or use the Axis menu functions.

Drag the corners or edges of a plot to resize it, or click on the box in the upper corner of the window to
min/max it. Note that you have to move the mouse back into that window in order for the resizing to occur.
Press Ctrl and roll the mouse scroll wheel, or press the = and — keys, to zoom a plot in and out.

Press Ctrl-Alt and roll the mouse scroll wheel, or Alt plus the = or — keys, to zoom a plot horizontally.
Press Ctrl-Shift and roll the mouse scroll wheel, or Shift plus the = or — keys, to zoom a plot vertically.
Press S to resize plotted points to Plot Setting size after zooming to remove distortion or at any time to
update the point size to a new setting. This will generally be automatically performed. If the point size
setting was greater than 1 when the scatterplot was created, you can also press B or L for bigger or littler
points, and the letter O to toggle between filled and hollow circles.

Press K to lock (remain in the current state) or unlock a scatterplot window.

Use the Up/Down/Left/Right arrow keys to pan a zoomed plot.

Press H in the Grand Tour or Transparent PC Plot window to see additional mouse and key assignments.
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Menus

There are 10 main menu headings: File, Options, Axis, Selections, Brushes, Axis, Analysis, Animate, DataTools and

Help. These menus are discussed in this section.

File Menu
Sliver v1.6 e
Options  Axis  Selecti Brushes Plots  Analysic  Animate DataTools Help

Read File -- every 1 line(s) All Variables
Export Plots to PostScript/PDF
Save Selection Ctrl+5

Save Visible Ctrl+V

Save Session

Restore Session

Create Dashboard from Session

Read File into Dashboard -- every 1 line(s) »
Exit Ctrl+X

The File menu provides the means to load CSV or TXT files into Sliver

and to save the data for currently selected or visible lines to the same type
of file. It also allows the export of visible lines to a Postscript/PDF file for
viewing in an alpha-blended mode, and saving or restoring of the session.

Read File — Loads a CSV or TXT file into Sliver and creates the parallel
coordinate plot in the main window. Options for decimating the input
(reading in every nth line) and choosing a hexadecimal data format are
provided in the Options=>Plot Settings menu function, and their current
values are echoed in this menu text for convenience. The decimal/time
format includes any mix of decimal numbers and time data in hh:mm:ss or
mm:ss format, where the seconds can be a decimal value. Also, any
variable with the string (sec-time) anywhere in its name will
automatically be interpreted as having units of seconds and will be
transformed into the hh:mm:ss time format in Sliver. If the Select
Variables option is clicked, a window is presented to check off the desired
input variables as shown in the figure on the right. For long lists, pressing a
key will jump to the next variable starting with that letter or number. For
convenience, the current selections can be saved to a file from this
window, and these selections can be re-loaded when inputting a new file or
using functions in the DataTools menu.

Export Plots to PostScript/PDF — Exports the PC Plot, PCM and/or
scatterplots (including stacked scatterplots or scatterplots with point sizes
based on a third variable, or bubble charts) to a Postscript file. This
produces an alpha-blended version (one with transparency) that reveals
inner structure of the overplotted lines. It also provides presentation-
quality vector graphics of the plots. If the path to Adobe Distiller
executable file is input in the PS/PDF Settings, the Postscript file will be
automatically converted to PDF and launched for viewing.

Save Selection — Saves the data rows (polylines) that are currently

) Select Input Variables-l-:- = e S|

Check at least two variables below:

=

name

=

group

=

protein (g)

calcium (g)

<7

sodium (g)
fiber (g)

vitaminc (g)

EU

potassium (g)

=

carbohydrate (g)
sugars (g)
fat (g)

water (g)

U |

=

calories
saturated (g)
menounsat (g)
polyunsat (g)
id

A i i |

Select All | Deselect All Cancel oK

Read Selections from a File | Save Selections to a File |

selected into a new data file. Lines are selected by mouse swipes (or by clicking on corners of a selection rectangle
and hitting Enter if configured in the Plot Settings), and they appear in the color configured as Selected Line Color
in the Color Scheme. This is a convenient way of quickly filter the data in the data file. Loading the saved file also
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rescales the axes to fit just the selected data, spreading out the scales to cover only the necessary range. There is an
option to save all the variables in the original input file even if they were not all input when the file was read,
enabling Sliver to filter a file based only on selected input variables.

Save Visible — Saves all data rows (polylines) that are currently visible into a new data file. Lines are hidden by
assigning them to one or more brushes and then hiding those brushes through the Brush menu. There is an option to
save all the variables in the original input file even if they were not all input when the file was read, enabling Sliver
to filter a file based only on selected input variables.

Save Session — Saves the data and current states of the PC Plot and scatterplots to a user-named file that can be
restored at a later time.

Restore Session — Restores the data and current states of the PC Plot and scatterplots from a saved session file.
However, any horizontal compression or expansion of axes in the main PC Plot is removed. The PC Plot is restored
as the bottom window, with the scatterplots restored on top in the order of their display when the session was saved.

Create Dashboard from Session — Saves a dashboard template based on the current plot configurations that can
be used to create the same plot layouts for a different data file. A window will ask for the color brushing rules for
each plot as described in Section 3: Saving Sessions and Dashboards.

Read File into Dashboard — Applies the plot configurations of a previously saved dashboard to the dataset
contained in a new data file. The dashboard file is selected first, followed by the data file. The data file must have at
least as many variables as when the dashboard was saved (more is fine). Since the plot ranges, etc., are based on the
variable number (the axis number from the leftmost axis, starting at 1), these variables will normally be in the same
order as when the dashboard was created. Again, see Section 3: Saving Sessions and Dashboards for more
information.

Exit — Exits Sliver. The “X” in the upper right of the main window works equally well.

Page 65



Sliver v1.6.5 User's Manual | 16 February 2018

Options Menu

i Sliver - - ol ol bale

File [ Options | Axis Selections Brushes Plots Analysis Animate DataTools Help

Color Scheme

Plot Settings
—A s

nalysis Settings

Google Earth Settings

PostScript/PDF Export Settings

The Options menu provides pop-up windows to change Sliver settings for display colors, scatterplots, Google Earth
plots, and exports to Postscript/PDF. Note that all settings are saved between sessions and restored when Sliver NG
is relaunched.

Color Scheme — Provides a window to customize the color scheme of Sliver. Clicking on the assigned color in the
main window brings up a Color Chooser window to change it.

Basic colors:
Background Color: - Al N N |
_ e B B
Default Line Color: | . . = . .
EEEEN 4
Unselected Line Color: -
EEEEN
Selected Line Colon: - - - ]_ - r—
Axiz Color: |
::::: ' ' Hue: 40 Red: 255
Text Color: | | Sat: 240 Green: 255
ustom Colors > ColoriSolid . 120 Blue: 0
s Values Color _| [ ok || cancel | [ Add to Custom Colors
Scatterplot Point Outline Color -
OK| Load Defaults ‘ Apply | Cancel ‘
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Plot Settings — Provides a window to customize the various types of plots.

A very important option at the top

is the decimation of the file when Readevery | 1 3| line(s) of the input file
read in (reading every nth line), by
default 1 here. This setting is [ Do not show user help tips at top of plots

echoed in the File>Read File

. . [v Show axis values while swiping
menu option for convenient

reference when loading files [~ Interpret input file data as hexadecimal
Increase this number for better Instead of swiping, click corner points
performance when reading in large [ and Enter to select lines in the PC plot,
files say over 100.000 rows for a or ESC to cancel (best for large datasets)

b b
handful of variables or over 50,000 Progressively color selected lines while swiping
rows for 20 variables. [ for swipes without OR, AND or XOR operations

(SLOW for large datasets)

There is a checkbox to click two Default scatterplot height: | 600 3] width: | 800 =]
corner points of a selection box
rather than swiping, which is
convenient for very large files for Qutline filled scatterplot points larger than size: 2
which Swiping is slow. Another {will obscure the fill celor for smaller pixel sizes)
checkbox enables prOgreSSive [~ Use hollow scatterplot points (for size > 1)
coloring of the selection while
swiping rather than coloring it only
after the swipe is completed, but Thickness of PC Plot lines: | 1 3]
this operation will be very slow for Thickness of PC Plot axes: | 1 3]
large data files.

Size of scatterplot points (resizable if » 1): | 2 il

Line width of hollow scatterplot points: | 1 jl

MNumber of colors when range brushing: | 16 il

The sizes of the PC Plot Matrix Range brush color palette:  Sliver_rainbow -
and Transparent PC plot can be PC Plot Matrix height: | 980 =] width: 1820 2|

adjusted to best fit your desires and _ _ _
monitor size. Transparent PC Plot height: | 680 EI width: | 1200 El

Options to display values by strings require a string mapping file created by the

The initial size of scatterplots is set "Replace Strings with Mumbers” function of DataTocls or written in that format:

in this window, as well as the point C:/Sliver/stringmappingfile.td] Browse
sizes and whether they are hollow
or filled. Note that scatterplot Load Defaults ﬂ
points cannot be resized using the |
B (bigger) or L (littler) keyboard
keys, or toggled between hollow and filled using the O key, unless the size of the scatterplot points is greater than
one when the plot is created. The default size is 1 pixel.

The default thicknesses of the PC Plot lines and axes are 1 and 2 pixels, respectively, but these values can be
changed here.

The number of colors to use when range brushing an axis or a selection is selected here, as well as the color palette
to use. There are many palettes to choose from, with Sliver_rainbow as the default. See Appendix F for instructions
on adding your own custom color palettes.

There is also a field at the bottom to browse and enter the path to a file to map variable values to strings when the
Plots>Display Values on Mouse-Over->With String Mapping menu function is selected, or when the string
mapping option is selected for values in Google Earth pop-ups.
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Google Earth Settings — Provides a window to provide general Google Earth settings.

¥} Google Earth Setting:

Latitude values have units of: * degrees  radians Latitude multiplier: 1.0 Latitude offset: 0.0
Longitude values have units of: * degrees ( radians Longitude multiplier: (1.0 Longitude offset: 0.0
Altitude values have units of: { meters 1+ feet Altitude multiplier: 1.0 Altitude offset: 0.0

Altitude values are relative to:

{* Sealevel © Surfaceof theEarth © Ignore (clamp to surface of Earth)

Path to Google Earth executable
(Optional te aute-launch):

Load Defaults OK

C:/Program Files (x86)/Google/Google Earth/client/googleearth.exe Browse

Postscript/PDF Export Settings — Provides a window to customize the export of the parallel coordinate plot to
Postscript and PDF with alpha-blending (transparency). These settings are very useful in optimizing the output for
the two main reasons for exporting to PS and PDF:

1.

NOTE:

To obtain an “X-ray” view of the major line clusters (correlations) by assigning opacities to the lines of the
PC plot, which are often obscured by the overplotting from even moderately-sized data sets. (The other
action to take in this case is to range brush or gap brush an axis to color brush sets of lines, with the option
to hide one or more brushes.) Setting an opacity value less than one for the scatterplot points also helps in
seeing overlaid points.

To obtain presentation-quality printouts and graphics. For large datasets, there may not be sufficient

memory for Adobe Acrobat to flatten the file to send it to a printer, and in this case it can be saved in
Acrobat as a high-resolution (say, 600 dpi) PNG file, which can then be sent to the printer.

ONE-TIME REQUIRED SETUP FOR PDF EXPORT:

The paper size and AllowTransparency option must be set in the Adobe PDF Settings. To do this, open
Adobe Distiller (acrodist.exe in the Acrobat bin directory) and choose an option for Default Settings (Press
Quality or High Quality Print is recommended). Then select the Distiller menu option Settings - Edit
Adobe PDF Settings. In the main window (the General window), change the Default Paper Size to match
the paper size selected in the Sliver Postscript/PDF Export Settings (in Landscape mode)—for example, for
the “8.5x11 letter” setting in the screenshot shown below the Width would be set to 11.0 and the Height to
8.5 with Units of “Inches” (note that the default is the opposite). Then select the Fonts window and either
leave the Embed all fonts option checked and set the When embedding fails option to Ignore or Warn and
continue or simply uncheck the Embed all fonts option—otherwise, there may be an error message that the
Helvetica font can’t be found. For the blackest backgrounds and boldest colors you should also select the
Color window and choose the Leave Color Unchanged option under Color Management Policies.

Then click on the “Save As...” button, give your options file a new name and remember the folder where
Distiller will save it, and then click Save. Then go to that folder, open the new options file, find the line
with the phrase “AllowTransparency” near the top, and change the value from “false” to “true” and save
the file. This is the settings file that should always be selected by default in Distiller.
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In lieu of Acrobat Distiller, it is possible to open the PostScript file with the free GSView for Windows software.
GSView provides vector-drawn displays and printing but does not provide the transparency (the opacity will always
be 1.0). However, this is highly preferable to screenshots when presentation-quality plot images are desired.

Working our way down the settings list,
we first have the option to export just the
PC Plot, just the (2D only) scatterplots,
just the PCM, or all of them. The plots
appear on separate pages in the PDF. Both
fixed and variable-sized single or stacked
scatterplots will be exported when the
scatterplots are included.

There is also an option to either maintain
the aspect ratio of the current window,
which may have been resized, or to expand
the plots in both directions to fill the page.
In either case, the entire page background
is colored with the current background
color of the plot.

The line settings for PS/PDF export are
independent of the plot settings in Sliver
due to the different characteristics of a
monitor display. Here we can also set the
thickness and opacity of the PC plot and
the PCM lines. The scatterplot opacities
and outline thickness of hollow points can
also be set. However, the scatterplot point
sizes and whether the points are hollow or
filled are determined automatically from
the current states of the individual
scatterplots.

= 3 |

PostScript/PDF Export Settings

Types of plotsto export: © PCPlot  Scatterplots  PC Plot Matrix  © All Plots
Expand to fill the page and ... maintain aspect ratic  { allow aspect ratio to change
Thickness of PC Plot lines {(in 1/20 mm): | 1 jl
Thickness of thickened PC Plat lines (in 1/20 mm): | 5 il
Opacity of PC Plot lines (0,000 to 1.000): 01
Opacity of PC Plot Matrix lines (0.000 te 1.000): 005
Opacity of scatterplot peints (0.000 te 1.000): 1.0
QOutline thickness of hollow scatterplet points (in 1/20 mm): | 1 jl
¥ Printaxes Thickness of axes (in 1/20 mm): | 1 ﬁl
Opacity of axes (0,000 to 1.000): 0.5
¥ Printtext Textfontsize (inpt): | 8 il
Blend mode when opacity < 1:

* Normal  Multiply ( Screen  Owverlay  Darken  Lighten

" Color Dodge ¢ ColorBurn  Hard Light ( SoftLight ( Difference  Exclusion

Paper size (match with Distiller setting):  © 8.5x11 letter  8.5:d4 legal  11x17 tabloid

Path to Acrobat Distiller executable
(Optional to auto-launch):

oK Load Defaults

D:/MewTools/Adobe/Acrobat 9.0/Acrobat/acrc  Browse

Cancel

There is a choice to print or not print the axes, and their thickness and opacities if they are printed. There is also a
choice to print or not print the text (axes names, etc.), and a setting for the font size.
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There are 12 modes of alpha-blending Name Result
available in Adobe Acrobat for the entered Normal et i
.. b2Ysl T s
OP?CItleS. The Normal blend mOde WOI'kS NOTE Selects the source colour, ignoring the backdrop.
quite well, but with different backgrounds or -
. . . Muitiply B(cy.¢,) = cpxc
desired effects it may be beneficial to try out : s
. NOTE 1 Multiplies the backdrop and source colour values.
the different modes. These are the short
gl : : NOTE2  The result colour is always at least as dark as either of the two
deSCI‘lpthIlS Of the mOdeS hSted n AdObC constituent colours. Multiplying any colour with black produces black;
_1- multiplying with white leaves the original colour unchanged. Painting
document PDF 32000-1:2008 (Document successive overlapping objects with a colour other than black or white
Management—Portable document format— produces progressively darker colours.
Part 1: PDF 1.7), reproduced on the right. Screen Bley.¢,) = 1-[(1-cy) x (1-¢))]
= Cb+cs*(tb>‘c5)
o 1 NOTE 3 Multiplies the complements of the backdrop and source colour values,
The paper size (1n.Landscape) of the A e Y
PostScript output is also selectable. As
. h . . . NOTE4  The result colour is always at least as light as either of the two
mentloned above, the page size Settlng m constituent colours. Screening any colour with white produces white;
Tt screening with black leaves the original colour unchanged. The effect
AdObe D1§t111er Should be set to the same is 5|mila_r to projecting muitiple photographic slides simultaneously
value and in Landscape mode or the output onto a single screen.
will not be centered on the page. If the path Overlay B(cy, cy) = HardLight(c,, c,)
to the Adobe Distiller executable NOTE5  Multiplies or screens the colours, depending on the backdrop colour
. : : value. Source colours overlay the backdrop while preserving its
(acrodist.exe) is populated, the PostScript highlights and shadows. The backdrop colour is not replaced but is
file will be automatically converted to PDF. mixed with the source colour to reflect the lightness or darkness of the
backdrop.
Darken B(cy. c,) = min(cy. c;)
NOTE 6 Selects the darker of the backdrop and source colours.
NOTE 7 The backdrop is replaced with the source where the source is darker;
otherwise, it is left unchanged.
Lighten B(cy.c,) = max(cy. c,)
NOTE 8 Selects the lighter of the backdrop and source colours.
NOTE 9 The backdrop is replaced with the source where the source is lighter;
otherwise, it is left unchanged.
ColorDodge Brightens the backdrop color to reflect the source n
color. Painting with black produces no changes.
o, cp = O
B(cp.Cs) = 1, cp = (1 —c5)
(cp/(1 — €5)). otherwise
ColorBurn Darkens the backdrop color to reflect the source color.
Painting with white produces no change.
1 cp = 1
B(cp.c5) = o, (1A —cp) =c;
1— (@ —cp)/cs). otherwise
HardLight Multiply(cy, 2 x c,) ifc <05
By, ¢g) = { . : -
_Screen(cb,_xcs—l) 1fcs>0A5
NOTE 12 Multiplies or screens the colours, depending on the source colour
SoftLight cp—(1-2xcg)xcyx (1-cp) ifeg<0.:
B(cy, c) =
L {cb+(2><cs-l)><(D(cb)-cb) ife >0
where
[((16xx-12)xx+4)xx ifx<025
D(x) =4 . .
lvx ifx>025
NOTE 13  Darkens or lightens the colours, depending on the source colour
value. The effect is similar to shining a diffused spotlight on the
backdrop.
Difference B(cy.c,) = |°b' °s|
NOTE 14  Subtracts the darker of the two constituent colours from the lighter
colour:
NOTE 15 Painting with white inverts the backdrop colour; painting with black
produces no change.
Exclusion Blcy, ¢ = cpteg—2xcpyxe,
NOTE 16  Produces an effect similar to that of the Difference mode but lower in
contrast. Painting with white inverts the backdrop colour; painting with
black produces no change.
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Axis Menu

& Sivervis

LF\IE Options Selections Brushes Plots  Analysis Animate DataTools Help
Stagger/Unstagger Names

Enter Range for Axes
Reset to Full Axes Ranges
Cornpress/Spread Axes
Invert Asis
Move Axis
Delete Axis

Gap Brush Axis
Shift Lines Up from Top

Shift Lines Down from Top
Shift Lines Up from Bottom
Shift Lines Down from Bottom

The Axis menu offers the ability to shift up or down (stagger) every other axis name and range values to better view
overlapping names when many axes exist. It provides functions to enter ranges of one or more axes that are different
from the default maximum and minimum of the data that was read, and to reset to these default ranges. It also
provides a function to compress or spread a set of axes horizontally for easier viewing of axes of interest. In
addition, it offers other operations on a single axis after the axis has been selected by pressing Alt while clicking on
the variable name located under the axis. This action colors the name and produces helpful text along the top that
lists keystrokes for inverting (x), moving (m), deleting (x), range brushing (7), gap brushing (g) or shifting (arrow
keys) the axis. The example below shows the display after the alt (m) (for altitude in meters) axis is selected (and
colored in the selection color) and then inverted. In addition to the maximum value being at the bottom rather than
the top of an axis, the parentheses around an axis name indicates that the axis has been inverted.

The Invert, Move, Delete and Shift axis functions will cause the PC Plot to revert to its original layout if it has been
zoomed.

& stiver C:/Apps/MyPCSW/aaN3192MetadataExport2.csv.
Fle Options Brushes Axis Plots Animate DataTools Help
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An alternative to using a hotkey to perform an axis function is to use the menu functions under this Axis menu.

Stagger/Unstagger Names — Shift up or down (stagger) every other axis name and range views to better view
overlapping names when many axes exist.

Enter Range for Axes — Allows axes to be chosen and then pops up a window to allow a minimum value and a
maximum value of a range to be entered. The ranges of the chosen axes will be updated to this set of values. This is
very useful when a consistent range is best across axes, as in split times for races where comparisons with previous
splits is important.

Reset to Full Axes Ranges — Returns the ranges of chosen axes to their original values that span the range of
values for that axis.

Compress/Spread Axes — Expand or compress the horizontal interval between two selected axes, with the
compression factor selectable as well.

Invert — Inverts the axis and places parentheses around the name. Inverted axes are shown non-inverted in the
PCM.

Move — Initiates a move of the axis. An arrow is drawn from the axis name. To move the axis, drag the arrow to a
new location to the left or right of another axis and release the mouse. Pressing ESC cancels the move.

Delete — Deletes the axis and all scatterplots that use this variable. The remaining axes are redistributed to take up
the same overall space. Deleted axes are removed from the PCM the next time it is created.

Range Brush Axis or Selection — Clears all existing brushes and assigns new color brushes to any selected lines in
different ranges of the axis according to a palette selected in the Options=>Plot Settings menu function. This allows
a set of lines to be selected based on ranges of one variable while range-brushing those lines according to values of a
different variable. If there are no lines selected, all lines along the axis are brushed. The number of ranges to split the
axis into is defined in the Plot Settings, with a maximum of 16 colors, with a default of 16. To make the top end
(often interpreted as high error) occur at the lower values, first invert the axis, range brush it, and invert it again.

Range brushing just a selection of lines retains the color brushing of lines that are not part of the selection, and any
brush that is hidden is not range-brushed and remains hidden. Range brushing an entire selected axis removes all
existing brushes and assigns the lines on the axis to new color brushes based on the selected range palette. Lines that
have been shifted off the axis are unbrushed (uncolored) when range brushing an entire axis, but are brushed if they
are included in a range brush selection.

The image below shows the PC Plot after the MPG axis has been range brushed using the default Sliver rainbow
palette.
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€ Siver v16  DyUsers/Ron/Documents/Parallel Coordinates/MyParallelCoordinateSWSliver_v1.4_to_1.6_Dev/SampleData/cars.csv [= [ E fwed)

File Options Axis Selections Brushes Plots Analysis Animate DataTools Help

5140.0

10

Cylinders orsepowe eic ) (e Origin{US/Japan/Europe)

Gap Brush — Clears all existing brushes and assigns new color brushes to all lines (selected or not) based on the
largest gaps in the values along the axis. This is more useful than range brushing when coloring different values of a
categorical variable (i.e., one with discrete values). The groups of lines between the 10 largest gaps are initially
brushed with 10 different colors. The UP/DOWN arrows can then be used to change the gap sizes to increase or
decrease the number of colors from 2 up to 20 colors. Pressing ENTER exits this adjustment phase.

Line Shifting Operations:

The shifting operations described below can be used to spread lines along a selected axis to zoom into specific lines
of interest. This is particularly useful when extreme data has caused other lines of interest to be compressed at the
opposite end of an axis. Shifting the lines is an alternative to saving only the lines of interest to a file through the
File->Save Selected or File->Save Visible menu function and reloading the saved file. The arrow hotkeys can be
used instead of these menu functions.

NOTE: Re-select the axis if the arrow cycles through menus instead of shifting the lines.

Shift Lines Up from Top — Reduces the axis top range to shift the lines at the selected axis upwards at the top.
The UP arrow can also be used after the axis is selected.

Shift Lines Down from Top — Increases the axis top range to shift the lines at the selected axis downwards at the
top. The DOWN arrow can also be used after the axis is selected.

Shift Lines Up from Bottom — Reduces the axis bottom range to shift the lines at the selected axis upwards at the
bottom. The RIGHT arrow can also be used after the axis is selected.

Shift Lines Down from Bottom — Increases the axis bottom range to shift the lines at the selected axis downwards
at the bottom. The Left arrow can also be used after the axis is selected.
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Selections Menu

B Sliver

File Options Axis | Selections | Brushes Plots  Analysis Animate DataTocls Help
Select All Visible Lines Ctrl+ A
Select All Unbrushed Lines
EnterSeleeting Barige toe an Ao
Toggle Selection for Visible Lines  Ctrl+T

Thicken Selected Lines
Unthicken All Visible Lines

The Selections menu provides functions to select lines other than swiping them with the mouse, and to thicken any
lines that have been selected.

Select All Visible Lines — Selects all visible lines, a faster alternative to swiping across all lines on the screen.

Select All Unbrushed Lines — Selects all visible line that have not been assigned to a brush. This is often useful to
select all uninteresting lines that have not already been brushed, and then assign these newly selected lines to a new
brush and hide that brush to remove the lines from the visible display to better show the other lines.

Enter Selection Range for an Axis — Pops up a window to allow a minimum value and a maximum value to be
entered once an axis has been selected with an Alt-Click on the axis name. All lines lying on or between these
values will be automatically selected in a chosen combination with any other selected lines (Replace, OR, AND or
XOR). This is a far more convenient way of selecting a particular line or range of lines compared to zooming in and
finding those lines using the Plots—>Display Values on Mouse-Over menu option. By repeatedly using this
window, different sets of lines can be selected and each assigned to a brush in order to create custom range-brushed
colors. For time-formatted axes having range values such as 04:12:53, enter the values for the range in seconds.

Toggle Selection for Visible Lines — Performs a NOT operation on the current selection, toggling it to the
currently unselected, visible lines. This complements the OR, AND and XOR selection functions from keyboard
commands.

Thicken Selected Lines — Increases the line widths of the selected lines by one pixel. This menu option can be
repeated to thicken the selected lines further. This is useful to highlight particular lines of interest and for comparing
other lines to particular lines. When exported to PostScript/PDF, the thickened lines remain thickened and opaque,
and are drawn on top of the other lines.

Unthicken All Visible Lines — Reverts the linewidths of all visible lines to the value entered in the Options->Plot
Settings window.
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Brushes Menu

B Sliver

File Options Axis Selections | Brushes | Plots Analysis Animate DataTools Help
Add Selection to Existing Brush k
Show/Hide/Recolor Brushes Ctrl+R
Clear All Brushes

The Brushes menu provides operations on selections made with the mouse, including assigning the current selection
to a color brush and giving the ability to hide, show, re-color or remove one or more brushes.

Brush Color [ﬁ
Basic colors
Assign Selection to New Brush — Assigns the currently selected : F F F F : : :
lines (the current selection) to a new colored brush. No two L EEEE
brushes can have the same color. ENEEEEEN 4
EEEEEEER
Add Selection to Existing Brush — Adds the currently selected AL
lines (the current selection) to an existing colored brush selected C;D":"“.- R
in a window. e B0 Red 1
ot o L o b Sat: |240 Green'ﬁ
. e ColoriSolid - i
Show/Hide/Re-Color Brushes — Provides the ability make the — | Ad:: C'? - B=h | |
lines in a brush visible or hidden. This is useful when brushing e | =

and removing uninteresting sets of lines to better view the ones
of interest. Also, re-showing hidden brushes brings them to the
front, so hiding and showing brushes provides a means of re-

ordering the brushes in the plots. Choose brushes to show or hide.

Click on a brush color to change it.
. When re-shown, a brush is raised to
The Unbrush selection removes the brush and returns all the the front of all the plots. This is
lines in that brush to an unselected color. one way you can change the order of
the display of colors in the plots.

Clicking on color rectangle of a brush brings up a Color
Chooser window to select a new color to assign to the lines of
that brush.

@ Show © Hide © Unbrush
& Show ¢ Hide ¢ Unbrush
Clear All Brushes — Deletes all brushes and returns all lines to
the unselected state. & Show ¢ Hide ¢ Unbrush
# Show © Hide © Unbrush
& Show ¢ Hide ¢ Unbrush
& Show ¢ Hide  Unbrush

& Show ¢ Hide © Unbrush

& Show ¢ Hide  Unbrush

Apply | QK Cancel

Bl EEEEN
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Plots Menu

B Sliver

File Options Axis  Selections  Brushes Analysis  Animate DataTools  Help
Mew 20 Scatterplot Ctrl+P
Mew 3D Scatterplot
Mew Transparent PC Plot
Mew PC Plot Matrix
MNew Google Earth Pillar Plot
Mew Google Earth Path Plot
MNew Google Earth Con i

= - e

Anti-Alias PC Plot
Reset PC Plot Margins

EEe
% % Without String Mapping
With String Mapping

The Plots menu is the means of creating new scatterplots, 3D scatterplots and Google Earth pillar, path and
connection plots based on settings under the Options menu. It also invokes the display of values along each axis
when the mouse is hovered over a line (with or without mapping values to a string mapping file), which is not the
default action. Finally, there are options to temporarily anti-alias the PC Plot for cleaner screen capture, where any
other action removes this effect, and to reset the size of the original PC Plot margins without resetting its size in case
zooming and/or panning cause misalignments or off-screen text.

New 2D Scatterplot — Creates a new 2D i Select 2D Scatterplot Variables L= [ = |
scatterplot with x and y axis variables selected in =]
a pop-up window as shown on the right. Note e S
that two variables need to be checked off, with
one assigned as x and the other assigned to y, in I” PolarPlotin " degrees & radians
order for the plot to be created. There is no limit & CCW fromx-axis £ CW from North
to the number of scatterplots, and they can be Select a variable to specify the point sizes rather
created and deleted at will. If a polar plot is .
chosen, the axis names change to » and theta.
“x Cy ¥ MPG
For fixed size points, after the x and y variables Fx Cy [ Glinders
are selected and assigned to their respective Cx &y [ Horsepower
coordinate, the Finish button will create the 2D Fx Cy [ Weight
scatterplot. However, it is possible to stack @ x Cy [ Acceleration
multiple 2D scatterplots, either Cartesian or Fx Cy T Year
polar, and clicking the Add Stacked Subplot & x y T Origin(US/Japan/Europe)
button will bring up a new window to select a
new y variable (the x variable remains the same)
for Cartesian plots or a new theta variable (the r
variable remains the same) for polar plots.
Stacked subplots can be any mix of plots with
fixed-sized points or with points sized per
another variable (bubble charts). Cartesian and
polar plots cannot be mixed in one plot window.
E2
Cancel Add Stacked Subplot Finish |
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The settings for the plot (point sizes, hollow or not) are
taken from the Options—=>Plot Settings menu option by
default. However, there is a checkbox in this window to
size the areas of the points according to values of a
variable instead, either a third variable or one of the two
selected ones. Checking this box will change the Finish
button to Select Point Size Variable, and clicking on
that will bring up a new pop-up window, as shown on
the right. The selected variable specifies the area of the
point corresponding to each row of the data. There is
also a field to apply a scaling factor to that variable to
adjust its effect without having to edit the original data
file. Clicking OK returns to the page above to either
select Finish or Add Stacked Subplot.

Different scatterplots can be created with different
settings. If the size of the points is changed in the Plot
Settings after the plot is created, click on a scatterplot to
make it the active window and press the s key, which
re-sizes the points in just that plot according to the new
size setting. Pressing the s key also removes distortions
in the points due to zooming different amounts in the
horizontal and vertical directions, although this should
be done automatically.

If the point size in the Plot Settings was greater than
one when the plot was created, or if variable point size
is selected, pressing B or L will make the points bigger
or littler and pressing the letter O will toggle between
filled and hollow points.

Select a Variable G=NEN X
Check one variable below to set the
area (not diameter) of plotted points.
Additional scale factor to apply to the
point size initially and after zooming.
(Press B or L to make points bigger or 10
littler between plot zooms, Press O to
toggle between hollow and filled points.)
© MPG
[ Cylinders
[~ Horsepower
[~ Weight
[T Acceleration
[ Year
¥ Origin(US/Japan/Europe)
Cancel QK

Selections made in any scatterplot are propagated to the PC Plot and all other scatterplots. Selections in scatterplots
are always made by swiping an area with the mouse—the option to click corner points of a rectangle only applies to
the PC Plot, which is slower to respond to swipes for large files than a scatterplot.

Pressing k locks the currently active scatterplot from any changes even when the PC Plot is changed. This is useful
in comparing a scatterplot against another scatterplot after color brushing, hiding of lines, or other changes are done.
Pressing k again unlocks the scatterplot, which then updates to the latest configuration.
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New 3D Scatterplot — Creates a Select 3D Scatfe il
new 3D scatterplot in Google
. Check three variables and axes.
Earth. Here three variables must Cartesian coordinates are assumed if no checks below.
be CheCked Off m the pOp—up ¥ Spherical Coordinates Plot [~ Cylindrical Coordinates Plot in & degrees © radians
window, one allocated to each & MATH: theta CCW from x-asis, phi down from z-axis - NAV: theta CW from North, phi up from horizon

coordinate. Cartesian coordinates
(x,y,z) are assumed unless
spherical or cylindrical Or ®im @pn o 0T

Paoint size (1-15): | 2 jl Point opacity (1-16): 16 j‘

coordinates are checked. In the GE et ke

. . ¢ 5 theta { phi W Horsepower
latter two cases, there is a choice A e i Dl
between math-based or R
navigation-based conventions o Wi @y m e
(otherwise there are two default ®r € theta  phi [ Origin(US/Japan/Eurcpe)

choices named N/A). The math
convention for spherical
coordinates (r, 8, ¢) has 6
increasing counterclockwise from
the x-axis and ¢ down from the z-
axis, while for navigation the
azimuth 0 increases CW from
North and the elevation ¢ is
relative to the horizon (the x-y
plane). The North and East axes ok Conal|

in navigation mode point to North
and East in Google Earth, respectively.

-launch

Options are provided to input the (fixed) size and opacity of the points in the 3D scatterplot. The path to auto
Google Earth to display the 3D scatterplot is taken from the Google Earth settings under the Options menu.

Like Google Earth path plots, 3D scatterplots are saved in KML files that are selected or named by you. Once these
files are created, they can be opened in Google Earth (or double-clicked to launch them in Google Earth),
independent of Sliver. Therefore, a set of KML files can be created and later opened in Google Earth as needed, or
combined into a single KML file with the DataTools>Merge KML Files menu option. Note that when moving
or sending the KML file, the dot.png file created in the original directory with the KML file must also be
moved with the KML file, as it is the graphic used to create the spheres.

New Transparent PC Plot — Creates a new window containing the PC Plot with no axes or text but with an alpha
value (opacity) applied as described earlier. Hotkeys can change the alpha value (0-9 corresponds to 0.01, 0.02,
0.05, 0.10, 0.15, 0.20, 0.25, 0.3, 0.4 and 0.5, with UP/DOWN arrows to fine-tune the value), changing the linewidths
(LEFT/RIGHT arrows), toggling anti-aliasing (the A key) and displaying help (the H key). Creating a new plot
destroys the older plot, but settings are preserved and applied to the new plot.

The size of the Transparent PC Plot window can be set in the Options->Plot Settings menu option.

Note that when anti-aliasing is on the response to changes in the alpha value will be considerably slower. Larger
data can make the anti-aliasing function so slow it is essentially inoperable.

NOTE: Initiating a Transparent PC Plot will exit all Java programs, including a Grand Tour window if present.
New PC Plot Matrix — Creates a new window containing the PC Plot Matrix (PCM). If the PCM window exists, it
will be deleted and a new window created. This is sometimes necessary to remove an axis that is deleted in the main

PC Plot.

The size of the PC Plot Matrix window is set in the Options=>Plot Settings menu option. The window cannot be
resized once it is created, but it can be zoomed and panned.
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New Google Earth Pillar Plot
— Creates a new pillar plot in
Google Earth. If the height above
ground of the pillars is the value
of a variable, then three sets of
variables and coordinates must be
checked off. If a fixed height is
chosen, only two sets (latitude
and longitude) need to be
checked off.

There is a setting in the pop-up
window to plot every nth row of
the file—a lower number of
plotted rows (a higher n)
provides better transparency.

Z Select GoogléEarﬂ)

Check three wvariables and coordinates or
choose a fixed pillar height and check
two variables and ground coordinates.

Offsets and multipliers from the Google Earth
Settings are applied to latitudes and longitudes.

The altitude offset and multiplier is applied to

the height variable if a fixed height is not selected.

Plot every | 1 jl line(s) of the input file

Pillar width (0-25): | 2 3| Pillar Opacity (0-16): | 16 3]

W Use afixed pillar height (0-10000000): | 100 3] feet

IV Place a sphere on each pillar  Size (1-25): | 4 jl Opacity (1-16): lﬁjl

Adding a timestamp to each point in Google Earth allows time-based visibility and
playback of sections or individual points using controls within Google Earth itself.

[V Add a timestamp to every point (as defined in a later window)

@ lat ¢ long © Heigt [T ID
.  lat  Long ¢ Height [T Arrest
There are also options for the : :
K . K . @ lat  long ¢ Height [T Domestic
width of the pillar and its opacity, _
.  Llat  Long ¢ Height [ Beat
as well as the option for a fixed e e .
. . + lat on eight ear
height and a field for entering the r‘ o g . J 2
. . . . + lat Ls Height v Latitud
height in the units selected in the - g 2 G - = s
. Li O Heigh Lengitud
Options->Google Earth A e v tonae
Settings menu option. The units Select Google Earth

of the fixed height are taken from
the units selected in the Google
Earth Settings. Offsets and
multipliers for the latitude and
longitudes are also taken from
the Google Earth Settings, and

the associated multiplier and offset for

the altitude is applied to the height above
ground here if a fixed height is not

selected.

Check wariables, if any, to display their walues in
a pop—up balloon when an element is left-clicked, or
a label when the mouse hovers over a sphere, or both.

r Map these variables back to any original strings using
the string mapping file defined in Options-->Plot Settings.

There is also an option to place a sphere
on top of each pillar with a specified size
and opacity.

Finally, there is an option to add a
timestamp in Google Earth to every
point. As described earlier, timestamps
produce a player control panel in Google
Earth that will span the timestamps and
allow time-based selection of visible
points. Choosing this option brings up a
new pop-up window when OK is
clicked, as shown on the right.

Variables can be selected to be displayed

 pop-up " label ¥ both vV D
 pop-up " label ¥ both IV Arrest
& pop-up € label " both [V Domestic
& pop-up © label " both ¥ Beat

& pop-up © label " both ¥ Vear

@ pop-up O label O both V¥ Latitude
@ pop-up O label O both ¥ Longitude

Select All | Deselect All
Read Selections from a File

Cancel OK
Save Selections to a File

in Google Earth either in a pop-up (balloon) when left-clicked, or in a one-line label on mouse-over, or both. Pop-
ups appear when either a pillar or a sphere is clicked, while labels require a mouse-over of a sphere and the option
only appears if spheres were added to the tops of the pillars. Pop-ups display a table of the variable names and

values, while labels display only the comma-separated values on a single line.
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If the top box is checked, the variables in pop-ups and labels can also be replaced with strings for any values that
have a string assigned to them in a string mapping file entered in the Plot Settings. The format of this file is that
produced in a string mapping file when running the Replace Strings with Numbers function of DataTools. It can also
be manually created in the format given in Appendix E.

Clicking OK in the pop- .

up/label selection window “
3 3 Select the date fields and select one

brlngs_ up the tlme.Stamp option for populating hh:mm:s=s in UTC.

selection window if that Variable values are assumed to be in seconds

since midnight of this date unless the wvariable
was originally input in an bh:mm:ss format.

option was checked off in
the original window. This

WindOW iS ShOWIl on the Date of the timestamp for 00:00:00 time (midnight): Meonth: | 3 fl Day: | 22 jl Year | 2017 i‘

l'lght ¥ Use the data row number (as seconds)
[~ ID (as seconds)

The timestamp is applied as W ey

seconds since the start of a ™ Domestic (as secands)

date entered at the top of I~ Beat (as seconds)

this window, set to the R o

current day by default. This I Latitude (as seconds)

date can be changed to I™ Longitude (as seconds)

match an actual date of the
data, and this is more
important if the variable
selected for the times in
seconds is an actual time of
day. Otherwise it is a
convenient starting point for
some kind of timestamp.

The first selection is to ﬂ M
simply use the data row
number as the number of seconds. This provides a convenient form of a time interval, one second per line, over
which to operate with the player control panel in Google Earth. Alternatively, another variable can be selected to
provide the offset in seconds from the date above. A time-formatted variable in hh:mm:ss will be interpreted
correctly as a timestamp. All timestamps are rounded to one second.

Detailed information and examples of these options can be found in the section in this manual titled Google Earth
Timestamps, Pop-ups and Labels.
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New Google Earth Path - Séet ool s Va0 I s

Plot — Creates a new |
path plOt il’l GOOglC Earth. Check three variables and coordinates. Units,
HCI‘C three Variables must multipliers and altitude reference are derived
. from the Google Earth Settings menu option.
be checked Offln the pOp- Supports must be enabled to show isolated points.
up window, one each
allocated for the latitude, Plot every | 2 jl line(s) of the input file

Path width (in pixels): | 2 3| Path opacity (1-16): | 16 3]

longitude and altitude in
¥ Show supperts Support opacity (1-16): | 1 jl

Google Earth. As seen

earlier. it can be useful to ¥ For points more than | 2000 3: feet apart, do the following:

b

use a non_geographic & Draw no path atall " Draw a dashed arc with a distance/height ratio (1-25): | 5 3:
variable as the altitude to Spheres along the path are required for displaying the values of selected variables in pop-ups,

otherwise no selection window will appear. Spheres are clickable even if invisible (Opacity = 1).
¥ Place a sphere at each point along the path  Size (1-25): | 2 jl Opacity (1-16): | 16 fl

Adding a timestamp to each peint in Google Earth allows time-based visibility and
playback of sections or individual points using controls within Goegle Earth itself,

plot a variable along a
flight path.

There is a Settlng in the ¥ Add a timestamp to every point (as defined in a later window)

pop-up window to plOt The current altitude reference in Google Earth Settings is "SEA LEVEL".
every nth row of the file—

a lower number of plotted @ lat long " Ak [ Latitude
rows (a higher n) provides Clast © long ¢ At [ Longitude
better transparency. As a Colat Clong & At [ Alitude
%enelﬁll rule é)f thumb’ a & Llat " Long " Alt [ Varl
nd poin

ew thousa po .tS at @ lat  Llong © Alt [~ Va2
most along a path is

.  Lat ¢ Long ¢ Alt [T Latitude2
generally sufficient.

 lat  Long © Al [© Longitude?

There is an option to not & lat  Llong ¢ Ak [ Altitude?
draw a path between
points separated by more =l
than an entered distance. Cancel oK

This prevents a flight path
between segments from having a connecting line between them, which is important if they are widely separated or
unrelated. Also, connected path segments of a single color act as a group when timestamps are added to the path
plot—the entire colored segment has a single timestamp. To enable individual points along the path to have separate
timestamps, check this box and enter zero in the field so no points are connected along the path. This requires that
supports be drawn, however, in order to see individual points. There is also an option to draw dashed vertical arcs
with a selectable height to distance ratio between points separated by more than the entered distance.

The path width and opacity, and the option to show supports down to the ground and their opacity, are entered in
this window. Settings for the units of the variables, multipliers and offsets for each variable, the reference for the
altitude, and an optional path to auto-launch Google Earth to display the path are taken from the Options—> Google
Earth Settings menu option.

Spheres can be added to the points along the path, sitting on the supports if they are enabled. However, their opacity
can be set to one so they are not visible. Spheres are important because pop-ups and labels require them as
clickable or mouse-over points—the supports will not work in this regard.

As in the Google Earth Pillar Plot, there is an option to insert timestamps for the path elements.

After clicking OK, a window appears to select variables for pop-ups and labels if spheres are enabled. Another
window for choosing the variable or row number for the timestamps appears if timestamps are enabled. This
windows are identical to those for Google Earth Pillar Plots—please refer to that section for details on the window
entries and to the section in this manual titled Google Earth Timestamps, Pop-ups and Labels for detailed
information and examples of their operation.
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Again, the KML file is named by you, and these KML files can be opened in Google Earth independent of Sliver.
Also, these files remain by default in the Temporary Places listing in Google Earth, and can be independently hidden
or displayed by checking or unchecking them in that listing. This allows multiple plots created in Sliver to be
displayed at the same time, allowing the kind of compound displays seen earlier in this manual. The
DataTools>Merge KML Files menu option provides a means of combining multiple KML files into a single KML
file for convenience. Waypoints and other data can be entered manually within Google Earth and displayed as well.
Remember to include the dot.png file in the KML directory if the KML file is moved or sent.

New Google Earth

Connections Plot —

Cl‘eates a new To plot connections in Google Earth, check six variables and coordinates,
. . or check the box for no altitude variables and check four variables and
connections plot in

reference are derived from walues in the Google Earth Settings menu option.

coordinates. Width, opacity, supports, units, multipliers and altitude
Google Earth. Here

by default SiX Note that altitude references of "S5ea level™ or "Surface of the Earth"™

. can for longer distances produce lines passing below the Earth's surface.
variables must be
Checked Off in the Plot every | 1 ﬁl line(s) of the input file

Connection width (in pixels): 2 jl Connection opacity (1-16): | 16 él

pop-up window, one
[ Showsupports Support opacity (1-16): | 1 ﬁl

each allocated for
the latitude,
longitude and
altitude of the first
point and the
latitude, longitude

IV Assume endpoints lie on the ground (no altitude variables)

™ Draw vertical arcs from the ground instead of lines with a distance/height ratio (1-25): | 5 3:

m

Adding a timestamp to each point in Google Earth allows time-based visibility and
playback of sections or individual points using controls within Google Earth itself.

¥ Add a timestamp to every point (as defined in a later window)

. @ latl  longl AL ¢ Lat2  long2  AK2 [T Year
and altitude of the
d int. Aeai @ latl longl ¢ AL ¢ La2  long2 7 A2 ™ Month
seconda point. am
. p . g ?  latl ¢ Llongl " Al ( Lat2 ¢ Llong2  Al2 [T DayofMonth
there is an option to }
l t th @ latl ¢ Longl ¢ Al ( La2  Long2 (" Al2 [T DepTime
ot every nth row.
p y #latl  longl ¢ AL £ Lat2 " long2 T A2 [ AnTime
Thi 1ol I @ latl ¢ Llongl ¢ AL ¢ Lat2 " long2 C A2 v OriginLat
18 w1 p ot a_ e C latl % longl ¢ Al ¢ Lla2 ( long2 A2 ¥ OriginLen
(a connection) in Clsl Clongl C Al @ Ls2 Clong2 € AR ¥ Destlat
Google Earth . Clatl ¢ longl ¢ Al ¢ Lat2 {F long2 A2 ¥ Destlon o
between the pair of
points in each o] Concel |

plotted row. The

width and opacity of the connections, and the option to show supports down to the ground and their opacity are
entered here. The units of the variables, multipliers and offsets for each variable, and the reference for the altitude
are taken from the Options—=>Google Earth Settings menu option just as for a Google Earth Path Plot.

There is an option to assume that the endpoints lie on the ground, and checking this option grays out the altitude
radiobuttons, therefore requiring only four variables to be checked off. This is very useful if ground coordinates are
all that are available. The lines will lie on the ground along the great circle between the two positions. If that box is
checked, as in the figure here, a second option to draw vertical parabolic arcs between the ground positions rather
than the lines is enabled. The ratio of arc height to distance (actually the inverse distance to height ratio) can be
entered. The arc will lie over the great circle between the two points on the surface of the Earth.

As in the Google Earth Pillar Plot and Google Earth Path Plot, there is an option to insert timestamps for the path
elements.

After clicking OK, a window appears to select variables for pop-ups, which will appear when a connection is left-
clicked. Labels are not enabled because connections do not respond to mouse-overs and spheres are not an option
for connection plots. Another window for choosing the variable or row number for the timestamps appears if
timestamps are enabled. This windows are identical to those for Google Earth Pillar Plots—please refer to that
section for details on the window entries and to the section in this manual titled Google Earth Timestamps, Pop-ups
and Labels for detailed information and examples of their operation.
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Display Values on Mouse-Over — Toggles the mode in order to display values. When the mouse hovers over a
line in the PC Plot or over a point in any 2D scatterplot, the values are displayed in every plot. This can take a few
seconds for large files. The line in the PC Plot is highlighted and the values appear next to the axes, and the
corresponding point is highlighted and values displayed in each 2D scatterplot.

There are two options when choosing this menu function. Choosing Without String Mapping simply displays the
numerical values of the variables along the line the mouse is hovering over. Choosing With String Mapping
compares the numerical value for each variable to a string mapping file entered in the Plot Settings, and if a match is
found for that value of a variable, the string is displayed instead of the number. This will only happen in the main
PC Plot window, not in any scatterplots, which will always show the number. The format of the mapping file is that
produced in a string mapping file when running the Replace Strings with Numbers function of DataTools. It can also
be manually created in the format given in Appendix E.

Pressing ESC twice or re-selecting this menu function will exit this mode. Exiting the mode will increase the speed
of updates to the display.

Anti-Alias PC Plot — Performs an operation to smooth the lines in the main parallel coordinate plot to some
degree, making them less jagged. This can make screen captures more readable and professional-looking. The
screen captures in this manual were not anti-aliased. Any operation that affects the main PC Plot turns off the anti-
aliasing of the lines.

Reset PC Plot Margins — Redraws the PC Plot to have the initial margins without resetting its size. This is useful
if zooming and/or panning causes misalignments or off-screen text.
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Analysis Menu
%T SI;er v1.6

File Options Axis Selections Brushes Plots | Analysis | Animate DataTools Help

Brush Statistics
Show/Hide Histograms and Means

Center fxes on Means

Center Axes on a Selected Line
FE'

Export 2D Scatterplot

Export 3D Scatterplot

The Analysis menu provides a variety of functions that can help in analyzing the relationships among the data.

Brush Statistics — Displays statistics of the data of each brush as well as the current selection. This includes the
minimum and maximum values, average value, variance and standard deviation for each variable of all brushes and
for the current selection if one exists.

Show/Hide Histograms and Means — Draws a user-selectable number of histogram bins along the left side of
each selected axis, where the height of each bin is proportional to the number of lines intersecting the axis within the
span of that bin. The mean of each axis is marked by a horizontal line on the right side of the axis. This is very
useful for interpreting the clusters of data in the PC Plot. Only visible lines that intersect an axis are considered, so
shifting lines off an axis removes them from calculations of the histograms and means.

Center Axes on Means — Allows axes to be chosen and then centers them on the means of each selected axis in
order to visualize variations from the mean. If some lines are off-axis, this function resets the axes ranges so that all
visible lines lie along them before centering on their means.

Center Axes on a Selected Line — Allows axes to be chosen and then centers them on a particular selected line in
order to visualize variations from a particular row of data.

K-Means Clustering — Provides automatic brushing of clusters in the data. Choosing this menu option pops up a
window for selecting which variables to include when identifying clusters. It also allows the number & of clusters in
which to partition the data, as well as the top number of those clusters to brush in rainbow colors, with the cluster
having the most data points brushed in red and the cluster with the least data points (of the number of clusters to be
brushed) in blue. There is also an option to automatically update or launch the Transparent PC Window described
above. This provides a means of viewing the identified clusters in the transparent view to verify that the selected
number £ of clusters and the number to color brush through the data is optimal, at which point the process can be
repeated with different values. This clustering function requires that the free R statistical software be installed on the
PC, with the path to the RScript.exe file selected in the Options—-> Analysis Settings menu option.

Export 2D Scatterplot — Pops up a window to choose two variables for x and y in a Cartesian coordinate system,
along with options for plotting points, lines or both, with selectable point size, line width and line color. If Matlab is
installed on the PC and the path to the matlab.exe file is entered in the Options—> Analysis Settings menu option, the
2D scatterplot will appear in a Matlab figure with the color brushing that was applied in Sliver. The interactive
controls and myriad of settings of Matlab can then be applied to the plot as desired, and the plot can be saved in
Matlab format if desired.

Export 3D Scatterplot — Pops up a window to choose three variables for X, y and z in a Cartesian coordinate
system, along with options for plotting points, lines or both, with selectable point size, line width and line color. If
Matlab is installed on the PC and the path to the matlab.exe file is entered in the Options—> Analysis Settings menu
option, the 3D scatterplot will appear in a Matlab figure with the color brushing that was applied in Sliver. The
interactive controls and myriad of settings of Matlab can then be applied to the plot as desired, and the plot can be
saved in Matlab format if desired.
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Animate Menu

r - | —- -

File Options Axis Selections Brushes Plots Analysis | Animate | DataTools Help

Real-Time Data Animation

Stop Animation

The Animate menu provides the capability to
1. [Initiate a Grand Tour animation, rotating multi-dimensional data to identify clusters, outliers and structures.

2. [Initiate a count-based data animation to auto-sequence through the data rows at a given rate in a given
direction. This is useful when syncing data to video playing in a video player or with other applications or
instrumentation, or simply to traverse through the data while syncing the data among the various plots,
including Google Earth plots.

3. [Initiate real-time data collection.

NOTE: Initiating a Grand Tour will exit all Java programs, including the Transparent PC Plot window if present.

Grand Tour Animation — Presents a window to select between 3 and 9 variables and launch a separate window
for a Grand Tour as shown earlier. The displayed points represent the projections of the point locations onto the 2D
plane of the monitor as the axes are rotated through n-space, as described earlier. Data clusters and geometries can
be observed as random (or guided) rotations occur, as the points will retain their relative position while uncorrelated
points will move independently. The Grand Tour can be paused and points brushed, and these selections will sync
with the PC Plot and any scatterplots.

Performing Principal Component Analysis (PCA) on the data set prior to using the Grand Tour may be a useful
exercise. The PCA function is available in MatLab, the statistical package R, and other programs. In PCA the
coordinate axes remain orthogonal but represent linear combinations of the variables. The axes (i.e., the new
variables) are created in such a way that the first axis lies along the direction of greatest variance of the data, the
second axis is orthogonal along the direction of the next lower variance, and so forth. Using the modified data set
often optimizes the separations of the data clusters. Also, variable axes that have low variance can be eliminated
from the Grand Tour since they represent “noise” that doesn’t significantly affect the distribution of clusters,
structures or outliers. Dimension reduction in this way is a primary use of PCA, and is helpful in the Grand Tour as
well.

The Grand Tour window is launched nearly full-screen, although the layout assumes that the tour will be conducted
in the left portion of the display. The right edge of the window can be resized to reduce the window to the size
shown here, or the entire window can be used by using the hotkey for zooming out and the hotkeys for shifting the
origin of the plot. This can be very useful to distinguish points and clusters in larger datasets. The small circle
showing the projections of the axes onto the plane of the monitor, as well as the Help text if displayed, remain in
their original locations.

Pressing the H (for Help) key in the Grand Tour window displays a list of available mouse operations and keypress
assignments available in the Grand Tour, as shown in the image below. (The Z/X and Y/U options were added to the
Help list after this screenshot was taken.)
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B Grand Tour

Data from DataViewer software distribution (Benjamin.Radburn-Smith) — see References.

The following actions are supported in the Grand Tour window:
P: Pause or resume the Play of the animation.

Mouse Swipe: When play is paused, swiping the mouse while the left button is pressed draws a rectangle, and on
release any points within that rectangle are colored in the selection color setting of the main PC Plot. The
corresponding lines and points in other scatterplots are colored accordingly. Assigning the selection to a color brush
in the PC Plot window will cause the points to be brushed in the Grand Tour window as well. In fact, any selections
and brush activities, including hiding lines in the PC Plot, are synced among all the plots whenever the Grand Tour
is paused. This syncing operation may take a couple of seconds to propagate.

Ctrl + Mouse Swipe: If the Ctrl key is pressed when a second selection is swiped, the resulting selected points are
added (OR’d) to the existing selected points. Otherwise the previous selected points become unselected and return to
their original color.

Left/Right Arrows: Pressing the right arrow key causes the Grand Tour to play in the forward direction, randomly
generating new rotations in n-space. Pressing the left arrow key rewinds the Grand Tour play at a slower speed,
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allowing the exact position of interest to be located. Pressing a left or right arrow twice in a row results in pausing
the play, and pressing an arrow again then resumes the play in the direction assigned to that arrow.

Up/Down Arrows: Pressing the Up arrow speeds up the play, and holding it continuously will speed up the play to
the maximum speed possible for the number of points and dimensions. Pressing the Down arrow slows the play,
which is useful for the study and isolation of interesting features.

Z /X keys: The Z key shifts the origin of the plot to the left, and the X key shifts the origin to the right.
Y /U Kkeys: The Y key shifts the origin of the plot downward, and the U key shifts the origin upward.
+ /- keys: The +/ - keys (or the shifted versions of them) zoom the display in or out for optimum viewing.

J /K keys: When paused, the J key rotates the display counterclockwise, and the K key rotates it clockwise. This is
very useful when a set of points need to be selected but they lie at an angle, which might require a number of OR’d
selections to enclose them all in selection rectangles while excluding others. By rotating the display, the bulk of the
points can be lined up horizontally or vertically for more efficient use of the selection rectangle.

W: The W key Warps the view to a new location in n-space during play or when paused. This can be useful to jump
out of an uninteresting neighborhood. This is also useful when an automated, guided pursuit is operating, which may
find a local maximum for a selected projection but needs to be warped to another location to find other local
maximums.

F / C keys: During play or pause, the F and C keys select a Finer or Coarser angle step in the animation. A finer
step produces smoother play, but for larger data sets or dimensions a coarser angle step may be needed to speed up
the animation. Generally, the Up/Down and F/C keys are used to optimize the animation for a given data set.

I/D keys: During play or pause, the I/ D keys Increase or Decrease the maximum possible angle changes across
the dimensions. During normal play, this results in longer or shorter times that the points move without shifts in
directions. During guided pursuit described below, these keys result in increased or decreased ranges of angles in
which the algorithm will search for more optimum criteria. It is often useful to decrease the search range once a
reasonably good pursuit solution is found in order to fine-tune the search to find a local maximum. During the
guided pursuit the angle range is shown along the bottom of the display.

G: Pressing the G key toggles the tour into and out of the Guided pursuit mode. The guided pursuit mode randomly
searches the angle space to find new sets of rotation (a transformation matrix) that optimizes a projection index for
the selected pursuit type. When the guided pursuit mode is invoked, a line of text along the bottom of the display
lists the selected pursuit type, the current search angle range as defined through the I/D keys, the current and
maximum projection index found for the selected pursuit type, and the number of tests and samples per test that
have been run, as shown below.

Guided pursuitis m Zing the separation hetween c agimum angle (degy=120.0 CurrentfBest Index

T: Pressing the T key toggles between faster (instant) and slower (the default) Transition speeds when the guided
pursuit finds a more optimized solution and rotates to the new set of angles. The slower transitions can provide
insight into the structure of the data, but they can be distracting when they occur frequently or when there are many
dimensions.

1: Pressing 1 selects a projection pursuit type that maximizes the central space in the plot. Points are scored by the
total distance of all points from the plot origin, inversely weighted exponentially. This pursuit type may help in
separating data clusters for selection, but may not be helpful in some cases.
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2: Pressing 2 selects a projection pursuit type that maximizes the central mass in the plot. Points are scored by the
inverse of the total distance of all points from the plot origin, weighted exponentially. This pursuit type may help in
isolating outliers around the outside for selection.

3: Pressing 3 selects a projection pursuit type that maximizes the separations of the centroids of the different colors
of points in the plot. Points are scored by the total distance among all centroids. This pursuit type may help in
separating color brushed clusters for additional selections, or to simply find the transformation matrix that best
separates clusters.

4. Pressing 4 selects a projection pursuit type that finds the maximum separation of any one centroid of the different
colors of points in the plot. Points are scored by the total distance of any one centroid from all the others. This
pursuit type may help in best isolating one color brushed cluster for viewing.

B /L keys: Pressing B or L results in Bigger or Littler points.
O: Pressing the letter O toggles the point styles between filled and empty circles.

V: Pressing V produces a line of text along the bottom of the display that lists the Variables in the Grand Tour and
their numbered assignments in the projection components circle in the lower right. The variable names and number
assignments are also listed at the bottom of the Help text when H is pressed, as shown in the screenshot above.

S: Pressing S brings up a file browser dialogue to Save the current data to a text file in CSV format. This file
contains

1. the original data for the variables,
the data input to the Grand Tour from the PC Plot (the data after subtracting the mean values of the
variables and scaling each variable to approximately fill the display) and their original colors,

3. the mean of each variable and the scaling applied to it,

4. the current data and colors, and

5. the overall transformation (rotation) matrix that relates the input data to the current display

R: Pressing R brings up a file browser dialogue to Restore a previously saved data file. This involves extracting the
transformation matrix and multiplying the input data of the current session by that matrix to arrive at the same

display (other than color brushing) as when the data was saved.

H: Pressing H toggles the Help text display on and off.
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For illustrative purposes, below are screenshots of the four projection types operating on a 4-dimensional hypercube.
Type 1 in the upper left optimizes the central space. Type 2 in the upper right optimizes the central mass. Type 3 in
the lower left optimizes the separation of color centroids (and is not unique for a 4D cube). Type 4 in the lower right
optimizes the best single color centroid separation (and is also not unique in this case).

Grand Tour screens are not included in PostScript/PDF exports. Simple screenshots are the current method of
recording the results.
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Count-Based Animation — Initiates an animation based on settings in a pop-up window as shown below.

Data row for count = 1 (the top data row is row 1). This value can be negative: 1

Counts per data row (Note: You read in every 1 rows of the input file): 1.0

Input file with the current count as the last line: | Countitet Browse

Executable file to launch that writes counts into the input file: | DataPlayer.exe Browse
Maximum count rate, assuming the Sliver DataPlayer.exe is entered as the executable file above (maximum of 2000): 120
¥ Also animate Google Earth using geo-coordinates

Icon: & Aircraft ¢ Bicycle ¢ Boat ¢ Motorcycle ¢ Runner ¢ Truck ¢ Sphere

¥ Follow the icon by moving the camera position:
Look angle (90 = down): | 70 jl Lock heading offset from icon heading (0-360 degrees): | 20 jl Range: | 20000 jl feet

ook heading: !+ Always use offset above offset in direction of secondary target atch direction to secondary target
Look heading: * Alway: ff: b " Apply offset in directi f dary targ " Match directi dary targ

[¥ Also animate a line from the icon to a secondary set of coordinates (the variable selections will occur a later window)

¥ Color the line per another variable (the variable selection will occur in a later window)

I¥ Show axis values in PC Plot and Scatterplots

Mumber of lines to fadein PC Plot: | 20 ﬁl

Presets:  Sliver Data Player
Select Google Earth Coordinates I Cancel

The current row of data to animate is determined by the current value in the last row of a text file. The first field is
the row of the data file that will correspond to a value of 1 for the count, thus providing for an offset. This value can
be negative, and no data will be animated until the count reaches this minimum value.

The next field contains the ratio of counts per data row. For animation using the Sliver Data Player this would
normally be set to 1.0 even if the file was decimated when read in, but a different external program may require a
different rate.

The next field gives the name of the text file whose last row will contain the current count, with a Browse button to
locate it. Sliver will continuously read the last line and animate the corresponding row of data based on that number.
Leave this filename as Count.txt to use the built-in Sliver Data Player since it saves counts into that filename.

The next field contains the name of the executable script that will be called by Sliver to start appending the count to
the count file. There is a built-in script for the Sliver Data Player, and clicking on a preset button will automatically
populate these fields for that player.

Then there is an option to also animate the Google Earth path with an icon, where the variable selections for latitude,
longitude and altitude will be made in the next window. If this box is checked, an option will appear as shown here
to move the Google Earth view “camera” to follow the moving icon at a given look angle, heading offset and range.
Otherwise, the Google Earth view will remain fixed unless the view is manually changed with the mouse controls.
NOTE: If the motion following the icon is sluggish or jerky, or there is a feeling of motion sickness, change
the fly-to speed to the fastest slider value in the Google Earth Tools—> Options->Navigation>Fly-To Speed
menu selection.

Also, if the box to animate the Google Earth path with an icon is checked, an option will appear as shown here to
draw a line from that icon to a secondary geographic location, and checking this box will show yet another window
before the animation begins to allow the latitude, longitude and altitude variables of the secondary set of positions to
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be selected. And if this box is checked, there will also be an option to color that line according to another variable
rather than the default white color, and there will be yet again a later window to choose this variable. The color of
the line is white if the variable is zero and rainbow-brushed from blue to red otherwise. (The reason for assigning

white to a value of zero is to support Boolean values, so white is off, i.e., 0, and red is on, i.e., 1.)

The next checkbox selects whether to display the data values next to the animated line or point in the PC Plot and
2D scatterplots as the animation proceeds.

Finally, the last item selects the number of fading trailing lines to show in the PC Plot (0 to 20). This number can be
decreased for faster performance.

Initiating the animation after the subsequent selection windows are completed produces the syncing operation as
described in the earlier section on data visualization modes. Selecting the Sliver Data Player results in the display of
the player controls window shown earlier.

Two or more instances of Sliver can run in a common Count-Based Animation. A single Sliver DataPlayer window
will serve to control all instances (creating a new player in any instance replaces the one in the previous instance), so
it is possible, for example, to animate multiple paths in Google Earth simultaneously with their own icons. The
animation is based on row number, so you will want to make sure the data used in all Sliver instances starts at the
same time of day, for example, and have the same data rate. Note that the same data file can be read into multiple
Sliver instances and then different variables selected for the animation.

Real-Time Data Animation — Presents a g1 i

window of options as shown on the right.
The width of the PC Plot line for the current
data can be increased for greater visibility.
There is an option to display all the data as it
is accumulated or to just display the most
recent data to lessen clutter. In the latter case
there is an option to either display all the data
that has been undisplayed when the

animation is stopped, or to delete all the lines e N
. . tart Animation Cancel
except the number being displayed.

Before real-time data animation is selected, it is expected that a file has been read into Sliver that consists of a
header row with the variable names and two data rows that consist of the maximums and minimums of each
variable. As with any input file, the variable axes are displayed, and the two lines appear along the top and the
bottom of the axes since they represent the minimum and maximum extent of each axis. An axis can be range
brushed so that the incoming data is color brushed, and in this case a PC Plot like the one below is produced. In this
case the input data file consisted of these three lines:

| Te analyze collected data, select the menu option Animate-->Stop Animaticn.
Increase the width of the current PC Plot line by | 4 il

" Display all data ™ Display this number of most recent inputs: 100

{* Restore non-displayed data on animation stop ¢ Delete non-displayed data

Varl,Var2,Var3,Var4,Var5,Var6,Var7,Var8,Var9,Varl0,Varl 1,Varl2
0,10,0,20,30,0,-10,0,3.5,7,11.7,24
100,100,150,120,100,95,100,110,90.5,105.5,145,125
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& sliverNG C:/Apps/MyPCSW/aaaartanimstart.csv. @

File Options Brushes Axis Plots Animate DataTools Help

120.0 1 80.0 0 11 90.5 85.0 145.0 .0
3 7.0 11.7
Var4 Varé Var7 9 Yar12

0.0 -10.0 24.0
Varg 9 Var10 Varll

00.0 150.0

00.0 100, 0.0

100.0 1

0.0 10.0 0. 20.0

Varz

Any number of 2D scatterplots (Cartesian or polar) can be created before the animation is started, but stacked 2D
scatterplots are not supported and an error message will appear to request that these be deleted and split into
individual scatterplot windows. At this point all plot windows should be resized as needed for the PC monitor, as
they cannot be resized while the animation is occurring. Then the Real-Time Data Animation menu option can be
selected and the options set in the window shown above. The real-time data collection begins when the Start
Animation button is pressed in that window. At this point the two previously entered lines are deleted and additional
data is plotted as data rows are added to the original data file, as shown in the screenshots provided on pages 58-59.
The animation mode is exited through the Stop Animation menu option described below. The data file is no longer
monitored, and undisplayed data is then displayed if that option was selected. Sliver can then act on the collected
data in any of the ways described in this manual. Restarting the animation mode continues at the point where it had
been exited, quickly populating data generated while it was stopped. To start afresh, stop the animation mode and
load in a new data file comprising a header and two data lines for the maximum and minimum ranges.

Stop Animation — Ends the current animation mode. In the case of a Grand Tour, that window is exited. In the
case of Count-Based Animation, the PC Plot is reconfigured to again display all the lines and the executable file that
was called to populate the count into the count file is exited. In the case of Real-Time Animation, undisplayed data
is displayed again if that option was selected, and all other functions of Sliver are enabled.

Since the Grand Tour animation typically consumes CPU bandwidth, this type of animation exits faster if it is
paused first.
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DataTools Menu

@ Sliver
File Options Axis Selections Brushes Plots  Analysis  Animate | DataTools | Help

Preview Top Rows

View First and Last Rows
Count Number of Rows
Add Column for Row Count
Add Alphabetic Header Row
Extract Range of Rows
Extract Every nth Row
Delete Range of Rows

=8 B —
Add Column of Calculated Values ‘%
View Celumn Min/Max Values

Add Rows of Min/Max Values

Delete Rows with Column Values
Extract Rows with Column Values
Extract Rows with Multi-Column Values
Extract Rows by Column Value Range
Extract Rows by Column Value Change
Sort Rows by Column Value

Convert Date/Time to Numeric

Remove Commas frem Strings

Replace Strings with Numbers
Populate Missing Data Values
Swap Rows and Columns
Merge Celumns of Files

Split a File

Concatenate Files

Merge KML Files

The DataTools menu provides a set of tools for preparing data in a CSV or tab-delimited text file prior to loading the
data into Sliver, plus one function to merge multiple KML files into a single KML file. Using these tools is
generally much faster and more convenient than opening data files in Excel and manually performing the operations,
particularly for large files or for files too large to load into Excel. In fact, these tools are excellent alternatives at
times to working with Excel generally, and therefore a standalone DataTools application also exists.

Selecting a tool from the main Tool Selection Window in Figure 1 produces a new window that describes the
operation of that tool and the required input fields, as well as listing the first 25 lines of the output file when the
operation is completed. An example is shown in Figure 3. The type of file (CSV or tab-delimited TXT) is
determined by the input file suffix, with a default of CSV if a different suffix occurs. The tools operate on a data file
with or without a header row, depending on a checkbox setting. For tools that have the option of choosing variables
(such as Extract Columns by Name), the selected variables can also be saved to a text file or read from a text file that
lists one variable per line (see the screenshot on the next page).

The functions provided by the DataTools program are:
1. Preview Top Rows — Display the top 25 rows of an input file.
2. View First and Last Rows — View the first and last rows of one or more files, with an option to select
which column variables to display the data for assuming all the files have the same header row. This is very
useful when a large file has been split into smaller files and you need to find out which file contains a
particular value of a variable that is sequential, such as time or a frame counter. There is also an option to

show the row numbers in the output, which is useful for determining the number of rows in a file.

3. Count Number of Rows — Display the number of data rows of one or more input files.
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10.

11.

12.

13.

Add Column for Row Count — Insert a new first column with a specified variable name that contains the
row number, with the first data row being row 1. This is useful, for example, as the variable to assign to the
x-axis of a scatterplot in order to plot a variable against the sample or time.

Add Alphabetic Header Row — Add a header row to a file of pure data so the columns have variable
names. An alphabetic scheme such as in Excel columns (A-Z, AA-AZ, etc.) is used. This function may also
be needed in order to perform other functions that involve selecting specific columns.

Extract Range of Rows — Extract a range of rows between start and end values entered here and store

them into an output file.

Extract Every nth Row — Extract every nth row and store them into an output file (also called decimating

a file).

Delete Range of Rows — Delete a range of rows between the start
and end values entered here and store the result into an output file.

Extract Columns by Name — Extract columns of data from an
input file based on one or more selected variable names (see the
screenshot on the right) and then save them in an output file.

Add Column of Calculated Values — Add a user-named variable
column with values calculated from one or more existing columns
using math functions including arithmetic, powers, roots, and
logarithmic and trigonometric functions.

View Column Min/Max Values — View the minimum and
maximum values of columns of data from the file based on one or
more selected variable names.

Add Rows of Min/Max Values — Add two rows to the top of the
data (after the header row), the first containing the minimum
values of the columns of data and the second containing the
maximum values. Selecting any single variable in the variable
selection window will populate the rows with the minimum and
maximum values of each individual column. Selecting more than
one variable will produce rows that will share the common
minimum and maximum values of these selected variables, while
the other values will remain the minimum and maximum values of
the individual columns.

This function is useful to set automatic ranges of a plot such as a
parallel coordinate plot such that the axes of the selected variables
all have the same range. The two additional rows will appear as
extra data points/lines at the ends of the ranges in the plots and
may be deleted after plotting the data.

) Select Input Variables =l e

Check at least one variable below:

¥ signal

q

numlets

<

et
etUnCorr

al

eta

<l

nrgy
hadFrac
caloArea

maxNrgylnEmTowers

< 000

maxMrgylnHadT owers
hadMrgyInHD
hadMrgylnHB
hadMrgyInHF
hadMrgyInHE

KU B i |

emMNrgylnEB
emMNrgylnEE

<IN I 1

emMNrgylnHF

K

JjetMrgy5cale
jetBProbBTag

< 7

JjetProbBTag

<l

partenFlavour

=

NOTE: Because two rows of min/max values are added at the top e Al NSl Al | Gancll| IOK
of the output file, do not use this output file for statistical analysis e | e |
of the data.

Delete Rows with Column Values — Delete all rows for which one or Variable Selection Window.

more selected variables have the entered numerical value or string.
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14.

15.

16.

17.

18.

19.

20.

21.

Extract Rows with Column Values — Extract all rows for which one or more selected variables have the
entered numerical value or string.

Extract Rows with Multi-Column Values — Extract all rows for which one or more selected variables
satisfy Boolean combinations of numerical values or strings across multiple variables.

Extract Rows by Column Value Range — Extract all rows for which the numerical values of the chosen
variable lie within specified minimum and maximum values. A screenshot of this function is shown at the
end of this section.

Extract Rows by Column Value Change — Extract the first row and all rows for which the numerical
value or string of a selected variable changes. A new column is added on the left to describe the change,
such as “O to 1”.

Sort Rows by Column Value — Sort all the rows according to the values in a selected column. The sort
order can be chosen as increasing or decreasing, and the sort type can be chosen as

a. Numeric—values are sorted as floating point numbers, so the column must contain numbers in any
format

b. ASCII—values are sorted in Unicode code-point collation order (Example: 12 8§ Dog Snake dog
horse snake x10y X11y x9y)

c. Dictionary—case is ignored except as a tie-breaker and any embedded numbers are treated as
integers rather than ASCII characters (Example.: 12 8 Dog dog horse Snake snake x9y X10y

x11ly)

Convert Date/Time to Numeric — Convert standard date and time formats, which can include time zone
mnemonics, in user-selected columns to numeric values, which can then be plotted. The output format can
be chosen as the number of days since the oldest date across all selected columns, or seconds relative to the
start of today (which is also useful for time intervals such as 01:24:00).

Acceptable input formats include hh?:mm?:ss?? with or without mm/dd?/yy? or dd monthname ?yy? or day
or dd monthname yy or ?CC?yymmdd or ?CC?yy-mm-dd or dd-monthname-?CC?yy. So, for example, 10
December 2014 or 12/10/14 or 12/10/2014 or 141210 or 14-12-10 or 01:32:45 or 01:32:45 12/10/14 are
allowed, but for a CSV file the comma delimiter cannot be used, disallowing December 10, 2014. If only a
time is specified (hh?:mm?:ss??), the current date is assumed. If the string does not contain a time zone
mnemonic, the local time zone is assumed. The default year is the current year. If the entered year is less
than 100, the years 00-68 are treated as 2000-2068 and the years 69-99 as 1969-1999. Time relative to the
current time, such as 4 hours is also converted, with acceptable units of year, fortnight, month, week, day,
hour, minute (or min), and second (or sec). The relative units can be singular or plural, as in 3 weeks, and
can be modified with tomorrow, yesterday, today, now, last, this, next or ago.

Remove Commas from Strings — Remove commas and any surrounding double quotes from a CSV file.
Sliver associates commas in double quotes in CSV files as delimiters, and fails to load such files since the
column count is deemed inconsistent. Implementing a real-time check on commas when a file is loaded,
though, significantly slows down the input of data, so this DataTools function exists to remove any
commas in double quotes, as well as the quotes, from a CSV file prior to reading the file into Sliver.

Replace Strings with Numbers — Most data analysis tools, including Sliver, can only read numerical data.
Using this function, any variable in selected columns that contains strings will have unique numbers
assigned to the strings. Certain categorical strings are automatically assigned logical values of 1 and O if
available for that variable (such as True and False, Yes and No, On and Off, Low and High). Operating
only on selected columns allows time-formatted data in variables, which Sliver can read, from being
interpreted as strings and replaced with numbers.
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22.

23.

24.

25.

26.

27.

Along with the new output file that now contains no strings, this function also creates a text file that lists
the string mapping to the numbers. If this string mapping file is entered into the Plot Settings of Sliver, then
displays of values on mouse-over, as well as the pop-ups and labels in Google Earth plots, can optionally
display the original strings for any mapped value in a variable.

Populate Missing Data Values — Sometimes data is simply unknown for certain data samples and the
value is left empty. Most data analysis tools will not allow such a file to be loaded. This function has
options to fill all missing data in a file with a given value or to linearly interpolate between the known
values for each variable.

Swap Rows and Columns — Swap the rows and columns of an input file and store the result into an output
file. A header row in the input file will accordingly lie in the first column of the output file.

Merge Columns of Files — Horizontally (left-right) merge columns from two different files into an output
file. The rightmost set of columns has a user-specified prefix added to the variable names in case the two
files contain the same kind of data. This function is useful to analyze two sets of data together whose data
are row-aligned or have been made row-aligned by deleting rows.

Split a File — Split a file into multiple files having a given maximum number of lines. This is useful when a
file has too many rows to analyze as a group.

Concatenate Files — Choose up to 20 files and the order in which to concatenate them into an output file.
For greater numbers of files, repeat using previous concatenations.

Merge KML Files — Choose any number of KML files to combine into a single output KML file. This is
convenient when multiple Google Earth plots are generated in Sliver that should be displayed as one plot.
This merge will work for Sliver-generated KML files and likely for KML files generated by other
programs. Alternatively, KML files and images can be zipped together into a KMZ file (with a .kmz
suffix), which also merges the files and typically provides a 10x reduction in file size.
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€ Data Tooks [E=REEN x ]

To extract rows from an input file into an output file for which the values in a column lie within a given range, select the input
and output file. Then enter the range values, check the box to copy the header ta the top of the output file, and then click Start Process.

You will be prompted for the column (variable name) to check against the range. It is assumed here that the input file has a header row.
Otherwise, use the "Add Header Row" function first, then run this function, and then delete the header using the "Delete Range of Rows" function.

Input Fil !D:.r’Users_fRnn/Dncuments/Paralle\ Coordinates/MyParallelCoordinateSW/DataTools 121 Release/MyData.csv Select
[D:/Users/Ron/Documents/Parallel Coordinates/MyParallel CoordinateSW/DataT ools 121 Release/INTERESTING_COLUMNS_MyData,csv Select

Minimum Column Value (inclusive):

Maximum Column Value (inclusiv

172 QOutput file(s) should keep the header row

Start Process I Click Here to Return to Main Window and Exit

*** 6638 DATA ROWS HAVE BEEN COPIED TO THE OUTPUT FILE. **

Top 25 Lines of Output File:

signal,numJets,et,etUnCorr, eta, nrgy, hadFrac, calohrea, maxNrgyInEnTowers, maxNrgyInHadTowers, hadirgyInH0, hadirgyInHB, hadNrgyInHF, hadiNrgyInHE, emNrgyInEE, e
mNrgyInEE, emNrgyInHF, jetNrgyScale, jetBProbBTag, jetProbBTag, partonFlavour
1,11,622.222,622.222,1.08782,1028.14,0,0,817.968,0,1.39536,0,0,0,852.098,0,0,1,-1,-1,0
1,11,6.52203,6.52203,2.252,31.3446,1,0,0,13.5798,0,0,0,13.5798,0,0,0,1,-1,-1,0
1,11,2.22213,2.22213,2.416,12.5442,0,0,5.81255,0,0,0,0,0,0,5.81255,0,1,-1,-1,0
1,17,6.04408,6.04408,2.25575,29.1545,0.827165,0,2.18759,4.40711,0,0,0,10.4695,0,2.18758,0,1,—
1,17,5.47436,5.47436,1.88448,18.4344,0.642939,0,2.2153,3.98897,0,0,0,3.98897,0,2.2153,0,1, —
1,17,3.81563,3.81563,2.1075,15.9287,0,0,6.27083,0,0,0,0,0,0,6.27083,0,1,-1,-1,0
1,6,535.141,535.141,1.51591,1277.17,0.0585344,0,901.108,11.1771,0,37.2567,0,25.8109,0,1014.38,0,1,-1,-1,0
1,4,696.297,696.297,1.17446,1234,32,0,0,1005.39,0,0,0,0,0,1019.99,0,0,1,-1,-1,0
1,8,381.65,381.65,1.26001,726.873,0.00193292,0,543,809,1.08411,0,1.08411,0,0,559.782,0,0,1,-1,-1,0
1,8,10.8844,10.8844,0.477593,12.1495,0.579499,0,1.30138,2.27704,1.25752,2.27704,0,0,1.65229,0,0,1,-1,-1,0
1,8,5.1123,5.1123,0.4785,5.70881,1,0,0,1.84589,0,1.84589,0,0,0,0,0,1,-1,-1,0
1,19,183.789,183.789,1.9893,684.362,0.00411642,0,549.107,2.34559,0,0,0,2.34559,0,567.467,0,1,-1,-1,0
1,19,12.5108,12.5108,2.59352,84.1448,0.131134,0,10.9853,4.00517,0,0,0,5.6552,0,37.4702,0,1,-1,-1,0
1,19,11.3926,11.3926,0.573725,13.3196,0,0,2.54639,0,1.10907,0,0,0,4.3109,0,0,1,-1,-1,0
1,19,9.07296,9.07296,0.671911,11,1992,0.268327,0,2.58992,0.949804,1.13399,0.949804,0,0,2.58992,0,0,1,-1,-1,0
1,19,5.67375,5.67375,0.539824,6.52072,0,0,1.49133,0,0,0,0,0,2.1165,0,0,1,-1,-1,0
1,4,753.966,753.966,0.908416,1087.05,0,0,565.184,0,0,0,0,0,932.831,0,0,1,-1,-1,0
1,4,5.37522,5.37522,2.50558,33.1445,0.312593,0,6.11685,3.01387,0,0,0,4.91553,0,10.8095,0,1,-1,-1,0
1,8,51.2022,51.2022,1.24972,96.6686,0.350268,0,8.55315,5.1274,0,14.4167,0,0,26.7423,0,0,1,-1,-1,0
1,8,28.4882,28.4882,0.408077,30.8933,0.116202,0,6.37185,1.49863,0,1.49863,0,0,11.3981,0,0,1,-1,-1,0
1,8,24.4066,24.4066,0.408879,26.4753,0.283867,0,2.01089,2.04372,0,2.94944,0,0,7.44077,0,0,1,-1,-1,0 L
1,4,4.77185,4.77185,0.9135,6.90523,0,0,2.06143,0,0,0,0,0,2.0614%,0,0,1,-1,-1,0
1,9,245.05,245,05,2.24843,1173.6,0.0049512,0,944,252,2.92629,0,0,0,5.11443,0,1027.85,0,1,-1,-1,0

Extract Rows by Column Value Range window.

(The variable/column selection window appears after “Start Process” is clicked.)
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Help Menu

H 7 Sliver

File Options Axis Selections Brushes Plots  Analysis  Animate DataTools

Users Manual
About...

The Help menu provides general information on using the Sliver application, as well as the version being used.
Tips — Displays a window listing the mouse and keyboard interfaces of Sliver as shown below.
Users Manual — Displays this Users Manual in the default PDF reader of your PC.

About... — Displays the version number of this release of Sliver.

# | Helpful Tips L= ]

Press Ctrl while swiping to OR a new selection with an existing one,

Press Shift while swiping to AMD a new selection with an existing one,

Press Ctrl-3hift while swiping to XOR a new selection with an existing one.

Press Ctrl-A to select all visible lines.

Press a number (1-8) or press Alt while clicking on an axis name to select the axis.
Press n to select the next axis to the right, or N to select the next axis to the left,
Then invoke the Axis menu or follow the displayed instructions to invert, delete,

move, range brush, gap brush or shift the axis.

To shift lines along a selected axis, press the Up/Down arrows to shift them up/down
at the top, and press the Right/Left arrows to shift them up/down from the bottom.

Certain functions such as inverting, deleting, moving, shifting and compressing an axis
after the PC plot has been zoomed will first reset to the original PC Plot layout.

Press Ctrl and roll the mouse scroll wheel, or just press the = or - key, to zoom a plot in and out.
Press Ctrl-Alt and roll the mouse scroll wheel, or Alt plus the = or - key, to zoom a plot horizontally.
Press Ctrl-Shift and roll the mouse scroll wheel, or Shift plus the = or - key, to zoom a plot vertically.
Press the Up/Down/Left/Right arrow keys to pan a zoomed PC Plot or scatterplot.

Press § to restore scatterplot points to their Plot Setting size after zooming.

Press B or L to make the size of points in a scatterplot bigger or littler, and

press the letter O to toggle between hollow or filled points in a plot if the

point size was greater than 1 in the Plot Settings when the plot was created.

Press K to lock (remain in the current brush colors) or unlock a scatterplot.

For large files, choose the setting to click for the selection rectangle corners instead of swiping.
Then press Enter to select or ESC to cancel.

Press H in the Grand Tour window for related mouse operations and hotkey assignments,

Press H in the Transparent PC Plot window for related mouse operations and hotkey assignments.

o
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Appendix A: Other Parallel Coordinates Software

There are other excellent, free software applications that support parallel coordinates. Some of these run faster than
Sliver for large data files, and a few offer features such as built-in, real-time alpha-blending instead of the separate
transparency window or export to an alpha-blended Postscript/PDF file that Sliver provides. None offer the
animation or Google Earth plotting support, for example, that Sliver provides.

1. Mondrian (www.theusrus.de/Mondrian/)

An excellent software application. Highly recommended for very large files: fast, handles up to a
million records, and natively supports alpha-blending of unselected/uncolored lines.

Supports linked Histograms, Boxplots, Scatterplots, Barcharts, Mosaic plots, Missing Value Plots and
Parallel Coordinates

Rather bland color options

Can interface with the R statistical software

No installation required—a single JAVA executable

Free software under GNU GPL, written by Martin Theus of the University of Augsburg

No decimation, zooming/panning, gap brushing, animation, 2D polar scatterplots, 3D scatterplots,
Google Earth plots, clustering or Grand Tour that Sliver supports.

2. Ggobi (www.ggobi.org/

Supports linked 1D/2D Scatterplots, Barcharts, Time Series Plots and Parallel Coordinates
Offers variable transformations and can handle missing data fields

No support for alpha-blending

Provides a 1D/2D Grand Tour with pursuits as well as manual guidance

Offers the R package rggobi that interfaces with GGobi (see their book on the site)
Currently in maintenance mode only as the authors develop an implementation directly in R
Installation required

Free software originated at the University of Washington

No alpha-blended export, decimation, zooming/panning, gap brushing, animation, 2D polar
scatterplots, 3D scatterplots, clustering or Google Earth plots that Sliver supports.

3. CrystalVision (fip:/www.galaxy.gmu.edu/pub/)

Supports linked Scatterplot Matrix, Parallel Coordinates, 3D & “4D” Scatterplots

Natively supports alpha-blending (no export required as in Sliver)

Supports zooming and panning, and sizing of dots

Colors are additive, e.g., overlap of red and green lines are yellow, of red, green and blue are white
Provides a unique automated Grand Tour animation

Inputs tab-delimited TXT (numerical data only) with a minor header change

A CPU processing hog, but usable

Supports numerical data only

Installation required

Free software by Edward Wegman of George Mason University

No saving, decimation, range brushing, gap brushing, animation, 2D polar scatterplots, 3D scatterplots,
clustering or Google Earth plots that Sliver supports.
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DataViewer (http://benjamin.web.cern.ch/benjamin/DataViewer.html)

A fast data visualization tool under active development for Windows, Mac OSX and Linux

Natively supports alpha-blending of colored or uncolored lines using the additive color scheme and the
alpha-channel (no export required as in Sliver)

Supports linked Scatterplots and Parallel Coordinates, with horizontal or vertical orientation of the
latter. Displays axes values on mouse-over of both types of plots, and a logging function to save
actions and statistics of the data.

Can produce a best order of the axes based on calculated correlation coefficients to give the user the
best chance of finding interesting patterns.

Supports moving and deleting axes. Can also renormalize them for new maxima and minima following
data deletions.

No installation required

Written by Benjamin Radburn-Smith of CERN

Actively being developed; at present the released Windows version does not support decimation,
zooming/panning, gap brushing, animation, 2D polar scatterplots, 3D scatterplots, Google Earth plots,
clustering or Grand Tour that Sliver supports.

XmdvTool (http://davis.wpi.edu/xmdv/)

Supports linked Scatterplot Matrix, Parallel Coordinates and Pixel-Based Graphs

Selection is performed by resizing a band through the parallel coordinate plot

Automatic or no color brush—no manual brushing other than the current selection

Provides a true, customizable clustering algorithm rather than just alpha-blending

Supports numerical data only

No cropping or hiding of data

Installation required

Free software by Matt Ward, et al, of Worcester Polytechnic Institute

No compound Boolean selections, cropping (hiding), saving, decimation, range brushing, gap
brushing, animation, 2D polar scatterplots, 3D scatterplots or Google Earth plots that Sliver supports.

Parvis (www.mediavirus.org/parvis/)

Supports Parallel Coordinates only

Automatic alpha-blending works well

Manual color brushing by axis range or novel brushing of lines within angles

Anti-aliased lines. Brushes can be “fuzzy”, giving a cool wet look to the clusters.

Can save currently-brushed line numbers

Clusters can be formed from AND/OR of brushes and saved with names and colors (Brush List) for
sequencing

Can AND/OR clusters into new clusters with a new color, but cannot show more than one cluster color
at one time

Can zoom into lines at axes to spread out a range of interest

Internally supports strings

No installation required—a single JAVA executable

Free open-source (GPL) software by Florian Ledermann of the VRVis Research Center in Vienna

No decimation, range brushing, gap brushing, animation, 2D polar scatterplots, 3D scatterplots, Google
Earth plots, clustering or Grand Tour that Sliver supports.
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Appendix B: References

There are a large number of references on using parallel coordinate plots linked with scatterplots to visualize and
analyze multivariate systems. The following are very readable overviews of the subject.

1. Inselberg - Parallel Coordinates Chapter in Handbook of Data Visualization

2. Inselberg - Multidimensional Detective

3. Malik - Interactive Graphics: Exemplified with Real Data Applications (uses Mondrian)
4. Theus - Interactive Data Visualization using Mondrian

5. Inselberg - Parallel Coordinates: Interactive Visualization for High Dimensions

6. Hauser — Angular Brushing of Extended Parallel Coordinates (uses Parvis)

7. Cook — Grand Tours, Projection Pursuit Guided Tours, and Manual Controls

Please visit www.sliversoftware.com to find out how to obtain these and other references.
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Appendix C: Format of Saved Session Files

It may be useful to programmatically assign brushes and states to data prior to opening the data in Sliver. For a large
number of data sets this can replace many swipes and button clicks. This preformatting can be done be populating a
Sliver session file, which is normally saved after Sliver editing is performed, and restoring the session file rather
than opening the original data file. This appendix describes the format of these session files.

Saved session files should have a .csv suffix. They are ASCII text files that can be opened in any text editor. The
format of the text is given below, followed by an example.

1)
2)

3)

4)

5)

6)

7)

8)

9)

The first line must identify the file as a session file with the text “Saved Session File”
The second line is the number of data rows (N).

The third line is a listing of whether each axis is inverted or non-inverted, separated by commas, where 0
means inverted and 1 means non-inverted. The values are displayed in the order that the axes are ordered at
the time of the session save, left to right. This is the original order of the variables in the input data file only
if no axes were moved.

The fourth line is a listing of the axes variable names separated by commas. Again, the order of the variable
is that of the axes at the time of saving the session file, which will not be the order in the original data file if

any axes have been moved.

The next N lines consist of the comma-separated data for the axes in the order of the axes at the time of the
save.

The next line is the number of color brushes assigned (B). This could be 0.

The next B lines are the brush colors in the order shown in the Brushes—> Show/Hide/Recolor Brushes
menu option. The format is “#” followed by two-digit hex values for RGB, such as #00ff00 for green.
NOTE: Always use lowercase hex letters.

The next line is again the number of color brushes assigned (B).

The next B lines contain either 0 or 1 for a brush in the earlier brush order, where 0 means the lines with
that brush color were hidden and 1 means they were visible when the session was saved.

10) The next line contains the number of polylines that were color brushed (C). This could be 0.

11) The next C lines list the indexes into the N lines of step 5 for only those polylines that are color brushed,

starting at O for the first data row listed in step 5. Polylines that are not color brushed are skipped.

12) The next line is again the number of polylines that were color brushed (C).

13) The next C lines give the colors for each of the lines listed in step 11. The format is again “#” followed by

two-digit hex values for RGB, such as #00ff00 for green. NOTE: Always use lowercase hex letters.
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14)

15)

The next line is the number of polylines that were selected (in purple by default) when the session was
saved (S). This could be 0.

The next S lines are the indexes into the N lines of step 5 for only those polylines that are selected, starting
at 0 for the first data row listed in step 5. Polylines that are not selected are skipped.

THE ENTRIES BELOW ARE OPTIONAL. However, any entry must include all lines prior to it.

16)

17)

18)

19)

20)

21)

22)

23)

24)

25)

The next line is the number of axes (A).

The next A lines are comma-separated current (after any range adjustments were made) minimum and
maximum values for each axis, regardless of whether the axis is inverted. NOTE: There must be some
range, so if all data for a variable is the same (say, n), make the range something like (n-1) to (n+1). This is
what Sliver does in that case when it reads in a file.

The next line is the number of axes (A) again.

The next A lines are comma-separated original values (before any range adjustments were made) of the
minimum and maximum values for each axis as well as the mean and sum of the values for the axes,
regardless of whether the axis is inverted. NOTE: There must be some range, so if all data for a variable is
the same (say, n), make the range something like (n-1) to (n+1). This is what Sliver does in that case when
it reads in a file.

The next line is the number of thickened lines (L).

The next L lines list are the indexes into the N lines of step 5 for only those polylines that are thickened,
starting at O for the first data row listed in step 5, and their difference in linewidth from the default value set
in the Options>Plot Settings menu option, separated by a comma. Polylines that are not thickened are
skipped.

The next line is the path to the current file that was read in to Sliver, to allow the option of saving all
variables in the original file when using the File->Save Selection or File->Save Visible menu option.

The input decimation value n from the Options=>Plot Settings menu option titled “Read every [n] line(s)
of the input file”. This is needed to allow the option of saving all variables in the original file when using
the File->Save Selection or File->Save Visible menu option, which saves every n lines to match the input
data.

The next line contains the size and position of the main PC Plot window. The format is widthxheight+x+y,
where the width and height are in pixels and x and y are the horizontal and vertical offsets in pixels of the
upper right corner of the plot window from the upper right corner of the display, e.g., 1024x768+35+40.
The x value can be larger than the main monitor if a secondary monitor lies to the right of the main
monitor. If the window lies on a secondary monitor to the left of the main monitor, the x value will be
negative, as in 1024x768+-800+40. Note that the + still appears before the — in this x value.

The next line contains the comma-separated colors (in the same format as earlier, e.g., #00ff00) for the PC
Plot background color, axis color, text color, initial line color when loaded, unselected line color, and color
when displaying axis values. If the background color is followed by a space (not a comma) and another
color, the second color is the scatterplot point outline color—otherwise, the current setting in Sliver is used.
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This allows backward compatibility to earlier versions of a session file that did not support point outlines.
For example, the line

#000000 #949494 #{f{00, #1100, #{TTTT,#949494 #{TOOLT,#{F00
means that the background color is black (#000000), the axis color is yellow (#{fff00), and so forth, while
#000000 #949494 #1100, #{TT00,#LTTTTT,#949494 #TTO0LT,#{f00
also means that the scatterplot point outline color is #949494, or light gray, rather than the current setting.
26) The next line is O if the axis names are not currently staggered, or 1 if they are.

27) The next line is the number of bins currently defined for histograms, followed by a comma, followed by the
indexes of the axes that are currently showing histograms and means, starting at 0 for the leftmost axis,
each separated by a comma.

28) The next line is the number of scatterplots (P).

29) The next P lines list parameters of each scatterplot, separated by commas. They will be restored in this
order, so the rearmost scatterplots should be entered first if the display order matters (they are stored by
Sliver in this stacking order). The parameter fields, in order, are

a. The index of the variable used for the x-axis, where 0 is the leftmost axis variable. If a stacked
plot, the indices are separated by a space.

b. The index of the variable used for the y-axis, where 0 is the leftmost axis variable. If a stacked
plot, the indices are separated by a space.

c. The plot width in pixels

d. The plot height in pixels

e. 0 for a Cartesian plot, or 1 for a polar plot (note that stacked plots can only be one or the other).
f. 0 for a polar plot in radians, or 1 if in degrees (set to 0 for Cartesian plot)

g. 0 for a polar plot running counter-clockwise from the x-axis, or 1 if clockwise from North (set to 0
for a Cartesian plot)

h. The current point width in pixels, or if the point width varies according another variable (a bubble
chart) then 10000 plus the index of that variable, where 0 is the leftmost axis variable. If a stacked
plot, the point width values are separated by a space.

i. 0 for filled points, or 1 for hollow points

j- The initial scale factor that was specified when the point width was set according to another
variable (a bubble chart) in creating the scatterplot, or either 1 or -1 if the plot has a fixed point
width. If a stacked plot, the initial scale factors are separated by a space.

k. The current scale factor (which can be different from the one above after pressing the B (bigger)
or L (littler) keys) when the point width was set according to another variable (a bubble chart) in
creating the scatterplot, or either 1 or -1 if the plot has a fixed point width. If a stacked plot, the
current scale factors are separated by a space.
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1. 0 for a locked plot, 1 for an unlocked plot

m. The size and position of the overall plot window in the format given for the PC Plot window in
item 24 (each dimension is typically 4 pixels greater than the plot width and height above)

n. The minimum x-value of the plot. If a stacked plot, the values are separated by a space.
0. The maximum x-value of the plot. If a stacked plot, the values are separated by a space.
p- The minimum y-value of the plot. If a stacked plot, the values are separated by a space.
q- The maximum y-value of the plot. If a stacked plot, the values are separated by a space.

r.  The background color of the plot and optionally the point outline color. If the background color is
followed by a space (not a comma) and another color, the second color is the scatterplot point
outline color—otherwise, the current setting in Sliver is used. This allows backward compatibility
to earlier versions of a session file that did not support point outlines.

s.  The axis color of the plot
t.  The text color of the plot

u. Ifalocked plot when the session was saved, indicated by a 1 in item / above, the colors or
visibility may not match that read in for the main PC Plot, so the next N lines will contain the
color of a point, then a comma, and then 0 if the point is hidden or 1 if visible. The order will
match the PC Plot polyline order in item 5 above for each point that corresponds to the data in that
polyline. If a stacked plot, the N color values for each plot are listed in order.

For example, the line
2,3,929,249,0,0,0,2,0,-1,-1,1,933x253+87+70,90.0,165.0,2124.0,3693.0,#000000,#££f00,#fff00

describes a single, unstacked plot with an x-axis variable corresponding to the third axis variable from the
left in the PC Plot (index 2) and a y-axis variable corresponding to the fourth axis variable from the left
(index 3). The plot is 929 pixels wide by 249 pixels high. It is a Cartesian plot (type 0) and the next two
fields are set to 0 because they only apply to a polar plot. The point width is constant at 2 pixels rather than
varying according to another variable, and the points are filled (0). The next two fields are set to -1 because
the point width is constant. The plot is unlocked (1). The overall plot window has a width and height 4
pixels greater than the plot (933 and 253) and the top left corner is located 87 pixels from the left edge of
the main display and 70 pixels from the top. The x-axis ranges from 90.0 to 165.0 and the y-axis ranges
from 2124.0 to 3693.0. The background color is black (#000000) and the point outline color is undefined so
it will revert to the current Sliver setting, the axis color is yellow ((#{fff00) and the text color is also yellow
(#£1£00).

Since the plot was unlocked when the session was saved, the coloring and visibility will match that of the
main PC Plot so there are no more lines describing the plot.

Let’s look at a similar line for a plot consisting of two stacked plots:

22,3 5,929,249,0,0,0,2 10004,0,-1 1.0,-1 5.5,1,933x253+87+70,
90.0 90.0,165.0 165.0,2124.0 32.0,3693.0 45.0,#000000 #£f0000,#{fff00,#{ff00

describes two stacked plots with an x-axis variable corresponding to the third axis variable from the left in
the PC Plot (index 2, repeated here since there are two stacked plots although they will always be the same
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value since the x-axis is the same for a set of stacked plots). One y-axis variable corresponds to the fourth
axis variable from the left (index 3) and the other y-axis variable corresponds to the sixth axis variable from
the left (index 5). The plot is 929 pixels wide by 249 pixels high. It is a Cartesian plot (type 0) and the next
two fields are set to 0 because they only apply to a polar plot. The point width of the first stacked plot is
constant at 2 pixels rather than varying according to another variable and the point width of the second
stacked plot varies according to the fifth axis variable from the left (10000 + 4). The points are filled (0).
The next field has its first value set to -1 because the first point width is constant and the second to 1.0
because that was the initial scale factor for the second variable-size stacked plot. The next field has its first
value set to -1 because the first point width is constant and the second to 5.55 because that is the current
scale factor for the second variable-size stacked plot in which the point size has been increased using the B
key. The plot is unlocked (1). The overall plot window has a width and height 4 pixels greater than the plot
(933 and 253) and the top left corner is located 87 pixels from the left edge of the main display and 70
pixels from the top. The x-axis minimum value is 90.0 for the first plot and 90.0 for the second, and the x-
axis maximum value is 165.0 for the first plot and 165.0 for the second plot (these must have the same
values because the x-axis is common in stacked plots). The y-axis minimum value is 2124.0 for the first
plot and 32.0 for the second, and the y-axis maximum value is 3693.0 for the first plot and 45.0 for the
second. The background color is black (#000000) and the optional point outline color is red (#ff0000), the
axis color is yellow ((#{fff00) and the text color is also yellow (#ffff00).

Again, since the plot was unlocked when the session was saved, the coloring and visibility will match that
of the main PC Plot so there are no more lines describing the plot. Otherwise there would be N lines for the
color of each point in the first stacked plot followed by 2N lines (N lines for each stacked plot) giving the
colors of the points in each stacked plot as described in the next example. The colors should be the same for
the two plots, but they need to be repeated for each one.

As a third example, the line

1,3,929,929,1,0,0,10004,1,3,22.78125,0,933x933+-500+8,3.0,8.0,2124.0,3693.0#{1ftft,#000000,#000000

describes a plot with an x-axis variable corresponding to the second axis variable from the left in the PC
Plot (index 1) and a y-axis variable corresponding to the fourth axis variable from the left (index 3). The
plot is 929 pixels wide by 929 pixels high. It is a polar plot (type 1) in radians (0) running counter-
clockwise from the x-axis (0). The point width varies according to the fifth axis variable from the left
(10000 + 4), and the points are hollow (1). The original scale factor applied to the other variable was 3, but
the points have been increased in size with the B key and the scale factor is now 22.78125. The plot is
locked (0). The overall plot window has a width and height 4 pixels greater than the plot (933 and 933) and
the top left corner is located 500 pixels to the left of the left edge of the main display (i.e., on a secondary
monitor to the left of the main monitor) and 8 pixels from the top. The x-axis ranges from 3.0 to 8.0 and the
y-axis ranges from 2124.0 to 3693.0. The background color is white (#{fffff) and the point outline color is
undefined so it will revert to the current Sliver setting, the axis color black (#000000) and the text color is
also black (#000000).

Since the plot was locked when the session was saved, the coloring and visibility of the points may differ
from that read in earlier for the main PC Plot, so the next N lines will consist of text such as

#00£100,1
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indicating that that point color is #00ff00 (or green) and is visible (1). These are in the same order as the N
lines of data written in item 5, with the color and visibility data given for the points corresponding to those

lines.

Below is a session file for a session with two unstacked plots, one of which is locked.

Saved Session File
6
1,1,1,1,1,0,1

MPG,Cylinders,Horsepower, Weight,Acceleration, Y ear,Origin(US/Japan/Europe)

18,8,130,3504,12,70,1
15,8,165,3693,11.5,70,1
24,4,952372,15,70,3
22,6,95,2833,15.5,70,1
18,6,97,2774,15.5,70,1
18,3,90,2124,13.5,73,3
2

#00FF00

#£f0000

2

N NO R~~~

4
#0000
#0000
#00£f00
#0000
1
1
7

sliver C:/MyPCSW/Releasel.1 - Working/Sliver_v1.1.1Alpha/SampleData/carsportion.csv

Fle Optons Brushes Axis Plots Anmate DataTools Help
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Title Text

6 data rows (polylines)

Only the 6" axis is inverted
Axis names in left-to-right order
6 rows of polyline data

2 color brushes are assigned

First color brush is pure green

Second color brush is pure red

Again, 2 color brushes are assigned
Polylines of the first color are visible
Polylines of the second color are visible
4 lines are color brushed

The 1st polyline data above is brushed
The 3rd polyline data above is brushed
The 5th polyline data above is brushed
The 6th polyline data above is brushed
Again, 4 lines are color brushed

The st polyline data above is green
The 3rd polyline data above is red

The 5th polyline data above is green
The 6th polyline data above is red

One polyline is selected (in purple)
The 2nd polyline data above is selected
There are 7 axes
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15,24

3,8

90.0,165.0

2124,3693

11.5,15.5

70,73

1,3

7

15,24,19.83333,119
3,8,35,5.833333
90.0,165.0,672,112
2124,3693,17300,2883.33333
11.5,15.5,83,13.833333
70,73,423,70.5

1,3,10,1.66667

0

C: Sliver/SampleData/cars.csv
1

1204x684+-8+34
#000000,#{Ff00,#TF00,#{FTTT,#949494 #TOOff, #{Ff00

7 rows of current min/max axis values

List minimum first even if axis inverted

There are 7 axes
7 rows of original min/max/mean/sums

List minimum first even if axis inverted

There are 0 thickened lines

Path to the file that was read in
Decimation n when file was read

Size and position of the PC Plot
Background, axis, text and other colors

0 Axis names are not staggered

102 102 histogram bins, shown on no axes
2 There are 2 scatterplots
2,3,929,249,0,0,0,2,0,1,1,1,933x253+87+70,90.0,165.0,2124.0,3693.0,#000000,#{fff00,#{ff00 See main text above
1,3,929,929,1,0,0,10004,1,3,22.78125,0,933x933+-500+8,3.0,8.0,2124.0,3693. 0#{ftfff,#000000,#000000 Locked, see text
#00££00,1 First point is pure green and visible
#110000,0 Second point is pure red and hidden
#88£100, 1

#ff00ae, 1

#45ffdd,0

#0000ft,0 Sixth point is pure blue and hidden
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Appendix D: Format of Saved Dashboard Files

A dashboard file contains information on the PC Plot and any scatterplots, including locations, point sizes and
styles, and so forth. Specifying a dashboard file to apply when opening a data file can replace many swipes and
button clicks, and it creates a consistent display format for the data for presentation and comparisions. The
File->Create Dashboard from Session menu option is used to save the current configuration to a dashboard file,
and the File->Read File into Dashboard is called to apply the dashboard configuration when reading in a data file.
If there are small changes you would like to make to a dashboard file, it may be easier to directly edit the file. This
appendix describes the format of these dashboard files. In some ways they are similar to session files but without the
variable names and without any embedded data.

Saved dashboard files should have a .csv suffix. They are ASCII text files that can be opened in any text editor. The
format of the text is given below, followed by an example.

1) The first line must identify the file as a dashboard file with the text “Saved Dashboard File”
2) The second line is the number of variables (V).

3) The third line is a listing of whether each variable axis is inverted or non-inverted, separated by commas,
where 0 means inverted and 1 means non-inverted. The values are displayed in the order that the axes are
ordered at the time of the session save, left to right, and there will be V values. This is the original order of
the variables in the input data file only if no axes were moved.

4) The fourth line is again the number of variables (V).

5) The next V lines consist of the comma-separated minimum and maximum ranges and the text labels for
each of those in the order of the axes at the time of the save. Typically, the text labels are the same as the
ranges but truncated to 5 decimal places if needed. For example, a valid set of lines for three variables
might be:

1613,5140,1613,5140
11.333101333333335,21.253333333333334,11.3331,21.25333
05:23:22,12:00:10,5:23:22,12:00:10

6) The next line contains the size and position of the main PC Plot window. The format is widthxheight+x+y,
where the width and height are in pixels and x and y are the horizontal and vertical offsets in pixels of the
upper right corner of the plot window from the upper right corner of the display, e.g., 1024x768+35+40.
The x value can be larger than the main monitor if a secondary monitor lies to the right of the main
monitor. If the window lies on a secondary monitor to the left of the main monitor, the x value will be
negative, as in 1024x768+-800+40. Note that the + still appears before the — in this x value.

7) The next line consists of comma-separated values for the current color scheme, including in order the plot
background color, axis color, text color, line color when the data file is first loaded, the unselected line
color, the selected line color, and the color when axis values are shown such as when swiping. The format
is “#” followed by two-digit hex values for RGB, such as #00ff00 for green. NOTE: Always use lowercase
hex letters. If the background color is followed by a space (not a comma) and another color, the second
color is the scatterplot point outline color—otherwise, the current setting in Sliver is used. This allows
backward compatibility to earlier versions of a dashboard file that did not support point outlines. For
example, the line
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#000000 #949494 #{T100, #1100, #LTTEFE,#949494 #TOOLE,#{F00
means that the background color is black (#000000), the axis color is yellow (#{fff00), and so forth, while
#000000 #949494 #{f{00, #1100, #{TTTTT,#949494 #{TOOLT,#fF00
also means that the scatterplot point outline color is #949494, or light gray, rather than the current setting.
8) The next line is 0 if the axis names are not staggered, or 1 if they are staggered.

9) The next line contains the number of bins currently set for axis histograms, followed by a comma-separated
list of the axis indices that currently have histograms drawn on them. If no axes have histograms drawn on
them, the line will just consist of the number of bins (102 by default).

10) The next line contains the variable index for which any brushing of the main PC Plot will occur. This is the
value corresponding to the “Variable number to color brush” at the top of the window that appears when
the File->Create Dashboard from Session menu option is invoked, except that it will be one less than that
because the window value starts at 1 and this dashboard file value starts at 0.

11) The next line contains a value indicating the type of color brushing for the main PC Plot that was selected
in the dashboard creation window: -1 for no brushing, 0 for range brushing per an entered palette, and 1 for
brushing per the entered ranges.

12) If the color brushing type given in the previous line is 0, this line contains the comma-separated name of
the color palette and number of colors to brush, both entered in the dashboard creation window, such as
Sliver_rainbow, 16. If the color brushing type given in the previous line is 1, a separate line is written for
the 10 range entries in the dashboard creation window with comma-separated values for the from value, the
to value, and the color in the same format as above ( “#” followed by two-digit hex values for RGB, such as
#00ff00 for green, using lowercase hex letters), for example “6.5,8,#ff0000” to color the range from 6.5 to
8 in red. There are 10 entries because 10 possible ranges are available in the dashboard creation window.
Entries that are left blank have no values inserted, for example, “,,#949494” where the color was the default
color for that entry. If the color brushing type given in the previous line is -1, no lines are written here.

13) The next line is the number of scatterplots (P).

14) The next line lists parameters of the scatterplot behind all the others in display, separated by commas, in the
same format as that for a session file. The parameter fields, in order, are
a. The index of the variable used for the x-axis, where 0 is the leftmost axis variable
b. The index of the variable used for the y-axis, where 0 is the leftmost axis variable
c. The plot width in pixels
d. The plot height in pixels
e. 0 for a Cartesian plot, or 1 for a polar plot
f. 0 for a polar plot in radians, or 1 if in degrees (set to O for Cartesian plot)

g. 0 for a polar plot running counter-clockwise from the x-axis, or 1 if clockwise from North (set to 0
for a Cartesian plot)
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15)

16)

17)

h. The current point width in pixels, or if the point width varies according another variable (a bubble
chart) then 10000 plus the index of that variable, where 0 is the leftmost axis variable. If a stacked
plot, the point width values are separated by a space.

i. 0 for filled points, or 1 for hollow points

j- The initial scale factor that was specified when the point width was set according to another
variable (a bubble chart) in creating the scatterplot, or either 1 or -1 if the plot has a fixed point
width. If a stacked plot, the initial scale factors are separated by a space.

k. The current scale factor (which can be different from the one above after pressing the B (bigger)
or L (littler) keys) when the point width was set according to another variable (a bubble chart) in
creating the scatterplot, or either 1 or -1 if the plot has a fixed point width. If a stacked plot, the
current scale factors are separated by a space.

1. 0 for a locked plot, 1 for an unlocked plot. Note that plots will be unlocked only if the selection to
“Link brushes to the PC Plot” option is selected for this plot in the dashboard creation window.
Otherwise it will be locked, even if the same color palette is chosen for range brushing.

m. The size and position of the overall plot window in the format given for the PC Plot window in
item 6 (each dimension is typically 4 pixels greater than the plot width and height above)

n. The minimum x-value of the plot. If a stacked plot, the values are separated by a space.
0. The maximum x-value of the plot. If a stacked plot, the values are separated by a space.
p.- The minimum y-value of the plot. If a stacked plot, the values are separated by a space.
gq. The maximum y-value of the plot. If a stacked plot, the values are separated by a space.

r.  The background color of the plot and optionally the point outline color. If the background color is
followed by a space (not a comma) and another color, the second color is the scatterplot point
outline color—otherwise, the current setting in Sliver is used. This allows backward compatibility
to earlier versions of a dashboard file that did not support point outlines.

s. The axis color of the plot
t.  The text color of the plot
See the examples of this line in the previous appendix for the format of session files.

The next line contains the variable index for which any brushing of the scatterplot will occur. This is the
value corresponding to the “Variable number to color brush if not linked to the PC Pot” for this scatterplot
in the dashboard creation window, except that it will be one less than that because the window value starts
at 1 and this dashboard file value starts at 0. If the scatterplot is to be linked to the main PC Plot, enter 0.

The next line contains a value indicating the type of color brushing for this scatterplot that was selected in
the dashboard creation window: 0 to link the brush to the main PC Plot window, 1 for range brushing per
an entered palette, and 2 for brushing per the entered ranges. Note that brushing per the entered ranges is
not allowed for a stacked scatterplot since there are different ranges for each subplot.

If the color brushing type given in the previous line is 1, this line contains the comma-separated name of
the color palette and number of colors to brush, both entered in the dashboard creation window, such as
Sliver_default, 16. If the color brushing type given in the previous line is 2, a separate line is written for the
10 range entries in the dashboard creation window with comma-separated values for the from value, the fo
value, and the color in the same format as above ( “#” followed by two-digit hex values for RGB, such as
#00£f00 for green, using lowercase hex letters), for example “6.5,8,#ff0000” to color the range from 6.5 to
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8 in red. There are 10 entries because 10 possible ranges are available in the dashboard creation window.
Entries that are left blank have no values inserted, for example, “,,#949494” where the color was the default
color for that entry. If the color brushing type given in the previous line is 0, no lines are written here.

18) Items 14 through 16 are repeated for each scatterplot in their stacking order, rearmost to frontmost.

An example dashboard file is provided below.

Saved Dashboard File Title Text

7 7 variables (axes)

1,1,1,1,1,0,1 Only the 6" axis is inverted

7 7 variables (axes)
05:23:22,12:00:10,5:23:22,12:00:10 from, to, mintext, maxtext for first axis
15,18,15,18

7,9,8,8

130,165,130,165
3436,3693,3436,3693

11.5,12.7,11.5,12.7 from, to, mintext, maxtext for last axis
1204x684+74+51 widthxheight+x+y for PC Plot
#000000,#T100, #1100, #ITTTTT,#949494 #TO0fT,#{TTT00 Color scheme colors (see text)
1 Axis names are staggered
102,0,3 102 histogram bins on 1% and 4™ axis
0 PC Plot brushing is based on first axis
0 PC Plot is range-brushed with palette
Sliver rainbow,16 The palette and number of colors
3 There are 3 scatterplots
2,3,929,249,0,0,0,2,0,1,1,1,933x253+87+70,90.0,165.0,2124.0,3693.0,#000000,#{fff00,#fff00  Rear plot (unlocked--see text)
0 Brush per the first axis if not linked
0 Scatterplot is brushed per the PC Plot
1,4,929,929,1,0,0,10004,1,3,22.78125,0,933x933+-500+8,3.0,8.0,2124.0,3693.0#{fffff,#000000,#000000  Next plot (locked)
4 Brush per the fifth axis if not linked
1 Scatterplot brushed per palette
Univ_Tennessee, 10 The palette and number of colors
1,3,400,1200,1,0,0,2,1,3,22.78125,0,933x933+-500+8,5.0,10.0,26.0,38.0#{fffff,#000000,#000000  Next plot (locked)
1 Brush per the second axis if not linked
2 Scatterplot brushed per entered ranges
3,5,#00ff00 Range 3 to 5 is green
7.5,8,#£f0000 Range 7.5 to 8 is red
,,#949494 No range entered
,,#949494 No range entered
,,#949494 No range entered
,,#949494 No range entered
,,#949494 No range entered
,,1#949494 No range entered
,,1#949494 No range entered
,,#949494 No range entered

Blank line at end

Page 112



Sliver v1.6.5 User's Manual | 16 February 2018

Appendix E: Format of String Mapping Files

The Replace Strings with Numbers function of DataTools creates a new string mapping file as a reference for
retrieving the original strings for those replaced by numbers. These can be found manually by simply opening the
text file and finding the variable name and its assignments. In addition, if this file is entered into the Plot Settings in
Sliver, the Plots->Display Values on Mouse-Over—> With Strings menu option will access this file and display
any original strings instead of values when hovering over lines in the PC Plot. The pop-ups and labels in Google
Earth can also be set to access the file and display any original strings.

It’s possible, and often useful when strings can be related to values of a variable, to manually create a string
mapping file. The format is very simple, and a sample file is shown below. Variables are on their own row and end
in a colon without a space. If there are mapped strings, each number and corresponding string immediately follow
the row with that variable name, where the number and string are separated by a colon with a space before and after
it. The number can be a decimal value instead of an integer, and the number-string pairs can be in any order. There
can be many thousands of these pairs for a large dataset.

A blank line then separates this block from a new variable name. If no number-string pairs exist after a variable
name, then no values are mapped to strings for that variable, and in fact there is no reason to list that variable at all
(they are shown here because the Replace Strings with Numbers function of DataTools does show variable names
that have no mapped strings). There must be at least one blank line at the end of the file.

ID:
Beat:

Case Number:
:HZ131333
: HZ129324
: HZ129627
: HT626172
: HZ216949

A WO = O

Block:

0:030XX S WABASH AVE
1:132XX S RIVERDALE AVE

2 :000XX S LEAMINGTON AVE
3:060XX S FRANCISCO AVE

Arrest:
0: FALSE
1: TRUE

Domestic:
0: FALSE
1 : TRUE

Year:
<make sure there is at least one blank line at end of the file!>
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Appendix F: Format of Color Palette Files

The available color palettes for range brushing are listed in the Options—> Plot Settings menu. The palette names are
derived from the names of existing “.txt” text files in the Palettes subfolder under the main Sliver folder, so
magma.txt, for example, automatically populates magma in the listing of palettes.

Custom palettes can be added by adding palette files. A color in a palette file consists of a # symbol followed by the
hex values of r, g and b in order, in uppercase or lowercase letters, without any hex value for alpha transparency at
the end. For example, an RGB value of R=4f, G=5a and B=2d would be written as #4f5a2d.

The number of colors to use when range brushing is selectable in the Plot Settings, from two to sixteen colors. The
palette can specify colors for any or all of these numbers of colors. If a palette is selected that does not support the
number of colors that are selected, an error message will appear and the number of colors will be set to the last

number supported in the palette file. The file format is simple: The number of colors followed by a colon “:” must
appear on the line just above a line with that number of colors separated by commas. Below are the contents of the

existing magma.txt file, which like all the included palette files supports the full set of two to sixteen colors.

2:
#000004, #fcfdbf

3:
#000004,#b5367a,#fcfdbf

4:
#000004,#701e7f,#ec6163, #fcfdbf

5:
#000004,#4f127b,#b5367a,#{b8761 #fcfdbf

6:
#000004,#3b1165,#8a2880,#db4a69,#fc9d6f #cfdbf

7:
#000004,#2b1155,#701e71,#b5367a,#ec6163 #fdae7a #fcfdbf

8:
#000004,#21104a,#5d177d,#962c7e,#d0456¢ #f47762 #feb98 1 #fcfdbf

9:
#000004,#1b1042,#41127b,#712481,#b5367a,#e44165 #{b8761 #fec086,#fcfdbf

10:
#000004,#190e3¢,#43126¢,#701e7f,#9d2e7d,#cad170,#ec6163 #{c9469 #{ec68b,#ctfdbf

11:
#000004,#160d36,#3b1165,#62197d,#8a2880,#b5367a,#db4a69,#27162,#fcodo6f #fecc90,#cfdbf

12:
#000004,#140¢32,#32115¢,#57157¢,#7¢2380,#a2307d,#c63172,#e65264 #7762, #fda675 #fed094 #fcfdbf

13:
#000004,#120b2e,#2b1155,#4f127b,#701e7f,#912a7f,#b5367a,#d5476¢,#ec6163 #1b8761 #{daeT7a,#fdd498 #fcfdbf

14:
#000004,#1102a2a,#26104f,#481274,#651a7¢,#832681,#a5317¢,#c33d74 #e14e66,#{16d62,#{b8e66,#{db3 7e,#fdd89c,#fcfdbf

15:
#000004,#100928,#21104a,#40116b,#5d177d,#792280,#962c7e,#b5367a,#d0456¢,#e75664,#{47762 #£c986¢,#{eb98 1 ,#fdda9d, #fcfdbf

16:
#000004,#010926,#1¢1046,#3b1165,#55147¢,#701e7f,#8a2880,#a7317¢,#c13d75,#db4a69,#ec6163,#188061,#1c9d6f #iebe83, #fddcof #fctfdbf
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Appendix G: Built-In Color Palettes

There are a variety of color palettes included with Sliver for use in range-brushing along an axis. Any of these can
be chosen in the Options->Plot Settings menu function. Names that do not end in a hyphen and number support
any number of colors from 2 to 16, where the number of desired colors is also entered in Plot Settings. Palettes that
only support a single number of colors end in a hyphen and the numbers of colors they support, e.g.,

gold _and_black-5 supports exactly 5 colors, no more or less, while gold marigolds-10 supports exactly 10 colors. If
a palette is selected that does not support the number of colors entered into the Plot Settings, an informational
window will prompt to change the entered number of colors to one that the palette supports.

Note that PC Plots with different axis selections but using the same range brush palette will look dramatically
different depending on the distribution of the data along the axis. Try to experiment to get the best-looking one.

The default palette is named Sliver_rainbow, and consists of 2-16 brilliant rainbow colors. Another palette that
supports 2-16 colors is Univ_Tennessee. Finally, there is set of palettes from the colormap of the statistical software
R that also support 2-16 colors (see https://github.com/bhaskarvk/colormap). All of these are shown below.

SliVer_rainbOWZ
Univ_Tennessee: -:-D

[ | B 1
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Below are palettes that support exactly 4 or exactly 5 colors. There are others not shown here that support, say, 10
colors, but are simply combinations of two palettes that support 5 colors each, such as adventurous_afternoon-10.

adventurous-5:

afternoon-5:

aqua_army-5:

arctic_sunrise-5:

artistic-5:

baleric_beauty-5:

black and gold-5:

bold-5:

bolivian_beauty-5:

brisk-4:

cold as_ice-5:

compote-4:

fall collection-5:

french_connection-5

greek salad-5:

green_gold-5:

harbor-5:

icy_green-5:

in_the field-5:

lingua-5:

lovely-5:

mai-5:

marigold mix-5:

mellow musings-5:

morning_mist-5:

mystic_red-5:

IR
L

new_mexico-5:
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nordic_woods-5:

pebble-4:

pink dreams-5:

scholar-4:

scuba-4:

serene_sakura-5:

siesta_hour-5:

summer-5:

sweet_lolly-5:

thought provoking-5:

tropical punch-5:

uncorked-4:

very_venice-5:

vintage sundown-5:

waimea_waters-5:

warm_antique-5:

wet_look-5:
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Copyright Notice and Disclaimer

©2010-2018, Ron Doerfler. All Rights Reserved.

This program can be used for personal, educational or business purposes, including the publication of output data
and any screenshots or other pictorial information produced by it. However, the program cannot be mass-distributed
nor incorporated into other products or collections of products without the express consent of the author. The author
bears no responsibility for any loss of information, incorrect rendering of data or results, or any other adverse effects
of using the Sliver application.

REQUISITE LEGAL STATEMENTS

PROPRIETARY RIGHTS

Sliver contains proprietary and confidential information that is protected by applicable intellectual property and
other laws. Except as expressly permitted by applicable law or authorized by Sliver Software, you agree not to
modify, rent, lease, loan, sell, distribute or create derivative works based on Sliver, in whole or in part, without
express written approval.

DISCLAIMER OF WARRANTIES

Sliver Software and its author expressly disclaim all warranties of any kind, whether express or implied, including,
but not limited to the implied warranties of merchantability, fitness for a particular purpose and non-infringement.
Sliver Software and its author make no warranty that (i) the software will meet your requirements, (ii) the software
will be error-free, (iii) the results that may be obtained from the use of the software will be accurate or reliable, (iv)
the quality of the software will meet your expectations, and (v) any errors in the software will be corrected. No
advice or information, whether oral or written, obtained by you from Sliver Software or its author shall create any
warranty not expressly stated here.

LIMITATION OF LIABILITY

Sliver Software and its author shall not be liable to you for any direct, indirect, incidental, special, consequential or
exemplary damages, including, but not limited to, damages for loss of profits, goodwill, use, data or other intangible
losses (even if Sliver Software has been advised of the possibility of such damages), resulting from: (i) the use or the
inability to use the software; (ii) the cost of procurement of substitute goods and services resulting from any goods,
data, information or services obtained or messages received or transactions entered into through, from or as a result
of the software; (iii) unauthorized access to or alteration of your data; (iv) statements or conduct of any third party
on the software; or (v) any other matter relating to the software.

You agree to indemnify and hold Sliver Software and its author harmless from any claim or demand, including
reasonable attorneys' fees, made by any third party due to or arising out of content you make available through the
use of the software, or your use of the software.

CONTRIBUTIONS TO SLIVER SOFTWARE

By submitting ideas, suggestions, documents, and/or proposals ("Contributions") to Sliver Software through its
suggestion or feedback web pages or otherwise, you acknowledge and agree that: (a) your Contributions do not
contain confidential or proprietary information; (b) Sliver Software and its author are not under any obligation of
confidentiality, express or implied, with respect to the Contributions; (c) Sliver Software and its author shall be
entitled to use or disclose (or choose not to use or disclose) such Contributions for any purpose, in any way, in any
media worldwide; (d) Sliver Software and its author may have something similar to the Contributions already under
consideration or in development; and (e) you are not entitled to any compensation or reimbursement of any kind
from Sliver Software or its author under any circumstances.
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